Hi all,

I'm working on a Dell that suddenly won't load the network adapter drivers (code 31), I've un/re-installed drivers, installed a different adapter which won't load either, same problem; the 1394 network adapter also same. I've ran scans, no major viruses or malware, it just can't seem to load any network adapters. I've ran the netsh int ip reset command to rebuild the tcpip stack, but nothing seems to fix it. I've ran a repair install (OEM disk w/sp3), no luck. Any ideas? Thanks in advance for any suggestions.

jray

Are you sure that the network adapter is still in a proper, functional state, and did you make any changes to the computer recently that might have lead to this result?

Need more info. Are we talking integrated network, USB, or express card slots?? Or all of the above??

Thanks so much for the response, but, this job is long gone. I never could resolve the network adapter issue, (pci card btw) but the adapter issue was just one obvious problem of many internal Windows issues. I cloned the drive (for backup) and repartitioned the drive, reloaded everything, and it runs much better. (It had a 5 year old installation and 3 different receptionists over the years using it.)
Again, thanks for the reply.

jray

Cool, can we mark as "solved" then, just so other's with similar issues not tempted to post their problems rather than starting a new thread?

Cheers :)

I am having a similar issue to the on above. I installed Windows Ultimate 7 from disk, FULL version, NOT the Upgrade, now it says I need to update my drivers and I can't access my network or the internet. Its a Lenovo V570 laptop. My Network Adapter is an Intel Centrino Wireless-N +WiMax 6150. I used my other computer to go to Lenovo's website & downloaded a driver to my thumb drive, went to Microsoft website and downloaded a driver to my thumb drive, went to Intel's website and downlaoded a driver to my thumb drive; then I tried uploading them to my Lenovo & every driver says I need to install Network Adapter Hardware. The Adapter is there but the drivers do not recognize it. Opened the Device Manager and I've got exclamation points next to all my drivers that are missing. I tried re-installing Windows but it says I need to hook up to the internet to get the latest updates - I can't hook up to the internet. I am a novice so please use layman's terms.

Sounds like W7 has not found your network adapter. In Device Manager (Start, Run devmgmt.msc) click Scan for Hardware Changes button, then try to install the Intel driver.