0

I have 3 computers 2 are administrators and the other is a user.
I have 2 printers one on each of the administrator computers I want to share both printers to the users computer. I set it up with the admin account but when I switch to the users accounts no printers and I can't add on either.
what am I doing wrong? all the OS's are win 2000 pro sp4.

3
Contributors
15
Replies
16
Views
12 Years
Discussion Span
Last Post by dvr
0

If you share the printers as administartor.. then login as regular user..


Then BROWSE to the pc that is sharing and simply double click that printer it will add it to that machine

0

Yeah, shared Printers on windows are profile specific, ie. you need to set it up for each user. A good point to add is to ensure the user has full permissions to the spool directory located in the system32 folder on the PC he/she uses.

0

I tried that but it doesn't show the printers I can see the other computers but not there printers. how do I add the permissions to the spool directory?

0

Right click on the folder, go to the security tab.

If everyone is not present, then select add, type Everyone and press ok.

Then select Everyone in the list of groups / usernames and check the full control box.

Apply then OK

0

Supplemental. Make sure that user has permissions on that Printer.

On the PC with the printer attached, go to Printers and Faxes, Right-Click the printer and add the users username and check all the boxes, much the same as setting permissions for the spool directory.

Then go to start run and type \\(pc name the printer is on) and ok.

Right click the printer and press connect.

0

thanks that did it.
I just need that line \\"username"
than I could connect to it and set it up.
thanks again

0

well it worked for a day, and now I can't print under the user accounts.
what is the problem? I checked in the security settings and everything is checked everyone,network,admins all checks are the same.
when I sign on as the administrator I can print. when I sign in as a user it says it can't connect to printer.

0

I had a similar problem with some drivers on certain Computers, it depends what type of printer it is.

Check the they have modify, read and write permissions to C:\winnt or C:\windows as applicable.

Right click the folder, add Everyone or Users (as applicable), then give modify permissions and apply. Then select advanced and mark check box "Replace permissions on all child objects...." and press Apply.

If that doesn't work, go to the system32 directory and open secpol.msc.

Have a look in local policies and then security options. Disable "prevent users from installing printer drivers."

Let me know how you get on.

0

SOunds like your profile might not be saving....

Is the printer still in your Printers Folder under control panel when you log back in?

0

the printer is still in my printer folder and is checked as default. but to the left of the window it shows status and it says "access denied, unable to connect". its a hp7700 printer USB. also if I click run and type \\user name "the one with the printer on it" it ask's for a login and password after I do that it starts working again.

0

OK then you need to add the other users credntials.

Do you have a domain? Workgroup?

Go tot the printer security tab and add the user.

Example

\\DOMAINNAME\username | FULL CONTROL <-- or whatever you want
\\WORKGROUP\username | FULL CONTROL

or

\\PCNAME\username | FULL CONTROL

0

ok I tried that \\workgroup\username and nothing it says
\\WORKGROUP\"USERNAME" is invalid to specify an object on a computer, use computer\item. to specify a computer, use \\computer

I tried computer name\user samething
i tried just computer name samething

I am doing it on the PC with the printer is that right?

0

Yes. You should be going to the security tab and doing it.

Ok do this..

Make a user on that machine.. make it the SAME username and password as the user on the other machine and try it.

0

thanks adding all the users names to that computer solved the problem. :D

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.