0

Hi all,
my PC wouldn't start showing file is missing "system32\DRIVERS\pci.sys
I tried to repair this using windows xp setup. Everything wroked well and after following all steps for about half hour I was very relived to see my computer start normally, dsiplaying every thing as usual. Unfortunately this only lasted about 3 minutes and then it blue screened.

"kernel_stack_inpage_error"
"Bios caching, shadowing"

Being patient I treid to do it all gain but now during installation my partion C
doesn't show and all it offers is "unpartitioned space 476938 MB". Seems awfully little and I'm also worried to loose all my data continuing installation from here.

ANY advice?????
Petra

Also this is the secong time this happened to me within 3 month, any idea what the source could be? Had a new motherboard and hard disk installed. Could they be faulty?

3
Contributors
16
Replies
17
Views
7 Years
Discussion Span
Last Post by gerbil
0

Quick question or two... does your machine have a video card? and what is it? What is the model of your mb? What version of XP are you trying to load?
476938 MB is a 500GB hdd? Did it have, say, 10GB of free space left before the problems? A guess will do..
I imagine from that msg re unpartitioned space and no C: available that your MBR is now corrupt. But if as you enter setup you try instead to enter the Recovery Console: [Press Enter to start the Windows Setup, choose "To repair a Windows XP installation using the Recovery Console, press R"].. and if your OS is recognised, run..
chkdsk /r
If your OS is not recognised RC will not start.
Back to those questions..

Edited by gerbil: n/a

0

hi gerbil, thanx so much for your reply - yes have a video card, its NVIDIA nForce4, my mb is an ASUS A8N-SLI,
yes, had loads of free space, more than half at least. Tried recovery console, no C: there either...Don't mind re-installing and I've got most off my stuff backed up on an external HD...only that last time quite a few files didn't copy back correctly and I hoped to somehow at least keep my stored data on D?????

0

quickly checked the recovery console again...says "the path or file specified is not valid"

0

Hello, Petra.. not quite there... that ASUS A8N-SLI mb, is it the deluxe or premium version?
Your NVIDIA nForce4 is the chipset of that mb.... there is no onboard graphics, so there must be an add-on graphics card as well - what is it?
What Service Pack is your XP installation cd? It must be at least XP-SP2 to be able to install XP to a mb with PCI-Express, such as yours.
This error ... kernel_stack_inpage_error... indicates that when your sys tried to read back data from the hdd page file it failed, and that could mean either a hdd or RAM problem, related also to your PCI.SYS missing msg. I'd test RAM first. Two sticks? Pull one and try again. But you must have an SP2 or 3 disk.
Your MBR partition table may now be corrupt; if a Windows Repair works then your data will be accessible, but if a Repair won't run [and it will not if Setup cannot find your OS] then we would have to try another method to repair the MBR so that you could get back your data.
Answer those questions...

0

ok...here we go:
- can't find any info on mb version, it has M618 printed on the CD that comes with it, would that mean anything? Yes there is another VGA driver,Galaxy vers. 64.0
- I'm installing XP home edition, with SP3
- in the meanwhile I've decided to replace my hd, thought that's the smoothest option
and then try to recover as much as I can from my old one - what do you think?
I'm a teacher and in the middle of exams, I need to get things running fast agin *grin* can improvise a few things at work, but the school network is so incredible slow and clumsy, drives me banana's

0

Galaxy means nought to me, nor does M618. I guess i should have told you that you would have to pull the LHS case cover off to actually check on th physical video card. It is possible that it is a RAM problem, and because that is quick and easy to check I would have done that before splurging on a replacement hdd [3 months old? they should throw you a new one... true...].
Try Memtest86+ from http://www.memtest.org/
-halfway down the page are downloads for bootable cd, USB flash drive or floppy versions. I use the floppy version when I can. Create, boot from it, run the test for an hour or two. A single error is a total failure of that stick.
Lemme know how you get on.

Edited by gerbil: n/a

0

ran memtest for 2 hrs, no errors so far *Yay*
gave up on reading very samll writing in very dark places *lol* no further info on the mb or video card, except from things that look like barcodes and endless numbers...sorry

0

Well, that is something. Try plugging your hard disk drive into another Sata port, just to knock out interface chip errors. And ensure that the cable connection to the drive itself is well seated.

Edited by gerbil: n/a

0

did that too, same result no errors - hope that's good news?

0

Well , somewhat... it does imply the problem is not with your mb's chipset. If you wish to retain your data on that drive you must be careful to not do anything which will destroy the Master File Table... ie no formatting, quick or otherwise. Your MBR is damaged [no partition table there] but that is not a problem [it can be regenerated]; however when Windows Setup sees that "unpartitioned space 476938 MB" it will insist on doing a format, so don't run Setup [different to trying to enter the RC, which did not work]. Setup [to install an OS] would require a primary partition and would demand a format prior to creating that partition. So..
There are a few pathways to doing this, and this is possibly the most straightforward. Let's hope it is fruitful. I am going to assume that you only have one partition on that hdd, C: ?
We need a bootable disk repair tool ; this one will do the job: http://www.partitionwizard.com/download.html -you want the bootable cd from the bottom of that table. Burn the .iso to a cd.
-boot from it [press F8 to get the boot selection menu in BIOS], defaults should be fine.
-in the rhs window select your hdd; with only one in your sys you would highlight "Disk 1" [not the unallocated space listed beneath].
-in Operations on the lhs press Rebuild MBR if it is available [not greyed out]; press Apply [in that Pending box it will show the disk no.-1... ignore that].
-with Disk 1 still highlighted, in the lhs press Partition Recovery; in the window that pops choose full disk; Next; quick scan; Next. BEFORE you press Finish check the discovered partition[s]. Note that you can check content also... Finish.
-if under Disk 1 your partition[s] are shown as *: then highlight your partition; in the lhs choose Change Drive Letter, C should be assigned, press OK. Repeat for other partitions?
-press Apply.
Cool. Now if you have a lot of faith you might restart your sys to see if Windows boots. If you do, and it does not, then reboot with Partition Wizard. If you don't, then you're ready for this next step.... we want to create a new partition to install a fresh Windows into. Note how much data is shown in C:, and keep C: well above that size in this next job, consider also how much data you might wish to copy over..
-in PW, rhs, highlight your newly discovered C:
-choose Move/Resize Partition, in the window that pops move the rhs slider so that you get enough space after it but preserve your C: data by a considerable margin... up to you, but XP itself needs say 7GB, add more for copying over data. OK. Apply.
-select that newly unallocated space, create a partition in it [defaults are fine]; give it a drive letter.
Ripper job. Reboot now with your XP disk, and be careful to install to the new partition. Setup will want to format it... quick is fine. Do NOT let it format your original [first] partition!!
Sorry about all the detail.... it's just to reassure you with a new tool. Tell me what you get.

Edited by gerbil: n/a

0

This smells like a faulty drive to me. Can you boot recovery console and run chkdsk /f

0

Hi gerbil, thanx again for all your efforts to give me advice....I have a replacement hd on the way, would you still recommend going through the steps above in order to retrieve my data - before putting the new one in?
And it is partioned into 2 parts, whith c only 80 MB.

0

Pitti, an easy way to get your data is with a linux boot disk. You can mount a share to a network drive, or mount a usb stick and copy your data. You shouldnt need to tweak the mbr as the stuff you need im sure is just things like documents and media.

0

" Can you boot recovery console and run chkdsk /f". Read back. And the f parameter is not valid in RC.
C: = 80 MB?? GB?? XP would not fit on 80MB.... I'll go with 80 GB. The same method applies... just do the actions for both partitions. End object is to get XP back onto the partition where it originally was, with all data there. I haven't included those steps yet.

Edited by gerbil: n/a

0

sorry of cours its 80 GB - the dangers of trying to think very early in the morning *grin*...will follow your intructions...and let you know how it went....
Thanx to you too Ryan, no can't run RC at all....

0

Ryan... I feel the need to apologise for my previous post - I was highly irritated by something else entirely... work... and was merely being brief, but now it just looks so rude. And it very likely is a faulty drive, but I'd like to rule out MFT corruption of some form. Anyway, it's fun trying to fix stuff; absorbing. And if my bits don't break, I have to try things out on guinea pigs wherever I can find them.
:)

Edited by gerbil: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.