0

Hello all,
I am new here, so please be gentle if I am posting in the wrong forum. I have Win XP PRO SP2. Almost a week ago, my desktop icons and taskbar disappeared upon booting. I was able to get them back by using control alt delete and running explorer.exe. Today, the same thing happened again upon booting. This time, however, explorer will not run. It appears for about a second in the running processes and then disappears. I have run three different virus/trojan/worm scans with different programs. Nothing was found. I ran Adaware and deleted any spyware. I have spent the whole day today googling for a fix, but my mind has just melted and can't seem to figure out what to do next. Help me, I'm drowning,
Thanks,
Very frustrated Caron

9
Contributors
11
Replies
12
Views
12 Years
Discussion Span
Last Post by Minster
0

Hello there,

This is actually quite simple to fix if you have system restore activated. What has likely happened is that a key in your registry is corrupt. Anyways, here are the steps to fix it.

1. Reboot your computer, and tap the F8 Key while booting to bring up the boot up menu.
2. From the menu, select "Safe mode with command prompt".
3. Now type \Windows\system32\restore\rstrui.exe into the command prompt.

This will allow you to revert back to sometime when your computer was working fine before.

Once you revert back and get things back to your current settings (best of your ability), I would consider manually creating another system restore (although xp regularily does it automatically, I would feel much safer doing it myself after taking the time to update my settings back to how I want them).

You can go about this by going into the start menu, then programs, then accessories, then system tools, and then into system restore. From there you can create it yourself.

I hope this helps you out. If you didn't have system restore activated you could always try to repair windows using the windows disk, or ultimately reformatting which would take approximately 95 minutes and then additional time to update xp from windows.com. The only down side is losing all of your stuff. I always like to keep backups, and am very glad to have a second hdd installed.

Regards,
-Emily

0

Hello there,

This is actually quite simple to fix if you have system restore activated. What has likely happened is that a key in your registry is corrupt. Anyways, here are the steps to fix it.

This will allow you to revert back to sometime when your computer was working fine before.


Regards,
-Emily

Thanks for your reply. I did try a system restore yesterday, but it didn't work. Thanks for trying.

An update: This morning, I was able to get explorer to run using the task manager. Very strange. It brought the desktop and taskbar back. However, the usual start up items are not there. I'm afraid to re-boot since I will probably lose my desktop again.

0

if your isp(internet service provider) is sbc global.net,boot to safe mode,and if icons are there>start>run>msconfig>put check beside selective startup on general page>click on startup tab>uncheck ipmon32>apply>close>restart>done

0

Thanks, but that's not it either. I do appreciate the effort.

0

Thanks, I think I am going to back up and re-install this weekend. Thanks to all who tried to help.

0

Dear All,

I had the same exact problem, I already using:
Taskbar Repair Plus (patched full)>>>not solved
fsecure Shellfix.reg file>>>not solved
reinstall my Windows XP Pro>>>not solved

I'm thingking to sold my Laptop, and buy another new one.
But before I did that, pleaseeeee anyone's help.

Tons of thanks

0

I had a same problem with caron, i have just followed the instruction post by emily, and its work.. A bunch of thank to emily.. :) I am just thinking to format my laptop before i read your post..Its save my day... thanks a lots

0

* Click Start, Run and type REGEDIT. Navigate to the following key

HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ Explorer

* Double-click NoActiveDesktopChanges and set it to 0
* Double-click NoActiveDesktop and set it to 0 (if exists)
* Close Registry Editor and restart Windows.

To change the setting via Group Policy Editor for Windows XP Professional:

* Click Start/Run and type GPEDIT.MSC
* Navigate to this path:

User Configuration
=> Administrative Templates
==> Desktop
===> Active Desktop

* Double-click Prohibit Changes and set it to Not Configured
* Double-click Disable Active Desktop and set it to Not Configured

0

I had this problem with my dell laptop and I think it has something to do with USB netgear wireless adapter corrupting the win log on. What I did was going safe mode and do a system restore to get my desktop and task bar back. Next is going to control panel and click user. Inside you have an option about change the way window log on. When I tried changing it, XP gave me a pop up saying that RTgina2.dll was preventing me to change. I google that file and download this. After that reboot.

I reboot my laptop a few times and I can safely say I got that anomaly fixed.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.