0

Hi everybody!

This is my very first post, so bear with me.

Anyways, as the title says, I'm having problems formatting my slave hard drive. It's a 60-Gb Seagate U series 7 that my friend gave me. It shows up in BIOS and My computer and Disk Management just fine. Under Disk Management, it's apparently "Healthy", but there is no file system. When I try to format it, it will start, and then take about two days to finish. Afterwards, I reboot, and IT'S NOT FORMATTED! I've tried this twice now, with no luck. Any suggestions?

Sorry this was so long, I just included what I thought was relevant.

Edited by DaMoose75: n/a

4
Contributors
20
Replies
21
Views
7 Years
Discussion Span
Last Post by SaintThomas
0

Hi. Your post is not at all long... I hate guessing. Queryiing for more info just wastes time.
"It shows up in BIOS and My computer and Disk Management just fine. Under Disk Management, it's apparently "Healthy"" just means that the controller on the hdd is working and responding to probes. It does seem that the actual disk R/W process is failing, though. If it has SMART support you could use a tool like SIW by Gabriel Topala to query its performance. Failing that, then try DBAN to wipe the drive, and try formatting again.
DBAN = Darik's boot n nuke... dl and copy to a medium you can boot from... a floppy, USB flashdrive, point it at the CORRECT drive.. :)

Edited by gerbil: n/a

0

I tried SeaTools, and the drive failed the short test(self diagnostic). It referred me to SeaTools for DOS, and I did a long test there. It "repaired" some of the bad sectors. After this I tried another short test to see if it would "pass after repair". It froze. After waiting a full day with no progress, I decided to shut it off. Now, in BIOS the drive is recognized as ST!!0506(smiley). The drive is not recognized anywhere else. Why could this be?

Edited by DaMoose75: n/a

0

It would appear to be mortally wounded; you could have no confidence that anything you managed to get on it would be accessible. A drive should just work, and perfectly. Personally, I wouldn't use it even if it did struggle to life. I must ask, does it work properly on your friend's computer?

Edited by gerbil: n/a

0

I must say that is quite a disappointment. Of course, I did get this drive for free.
I'm not sure if the drive worked on my friends computer or not. We just take "junk"
computers that people give us because they woud have thrown them out anyways; and
salvage parts from them. He gave me the drive, and I've been trying to restore it ever since.

0

I understand. i like to get things working, too, and sometimes will invest more time than the object is worth, just because it's a challenge. And that's just fine. But there is something bigger here - data security. Please don't risk the pain of losing stuff. Open the drive [remove the silver? tape] and you have a ripper mirror.
So all is not lost. :)

0

Please don't leave out any options for me under the barriers of data security. As far as I'm concerned, there is nothing on this disk of value. I've never actually been able to see what's on it, for goodness' sake! Every bit of data I feel like keeping is on my smaller (master) IDE disk.

0

I'm not leaving out any options that i am aware of. Basically, those things perform in two states only: perfectly well, anything else is not at all.
For fun, give it an hour in the refrigerator.

0

Still nothing. Do you think that maybe the MBR got messed up when it "fixed" the bad sectors?

0

Possibly it did, possibly it already was from when the formatting failed. A successful formatting would write a bootsector for the partition being created, and also write the MBR to the first disk sector [before the first partition]. Certainly, a disk without an MBR won't be seen by Explorer because it won't be able to find any partition information [partition info for up to four primary partitions is in the MBR, or up to 3 primary and one logical; further logicals are chained]. Explorer won't present a partition with no drive letter, either.
You can use a Windows Setup cd to format the drive if it can be recognised - just go as far as you wish creating partitions and then exit by pressing F3 twice.
Or use Partition Wizard [free].
As an aside, I checked the SMART records of my drives... not a single bad sector recorded.

Edited by gerbil: n/a

0

I tried SeaTools, and the drive failed the short test(self diagnostic).

Sorry to hear that!

I agree with gerbil that drive cannot be reliable - probably better to recycle.
Especially given the prices for much larger drives are so low these days...

PP:)

0

I'm not so sure the drive is completely dead, because BIOS still recognizes it. (Even though nothing else will). But as you said, these things only seem to work in perfect condition. I'm sort of at a loss on this one...

0

As far as I know, BIOS during POST just interrogates the controller as part of its process of listing connected hardware. No actual test of functionality is involved, just a return of type information. If it won't format with either of the two methods I suggested, it is for all intents dead.

Edited by gerbil: n/a

0

I have come to a new developement, the drive's ability to be recognized has been restored. I just put a jumper on it to configure it as "master". Of course, this doesn't put us much further ahead than before, but I can start firing away with more formatting tools. Another question, what exactly does Boot 'n' Nuke do?

Edited by DaMoose75: n/a

0

DBAN writes a jumble of ones and zeroes to the whole drive. It the disk will take a format, don't worry about it. IDE optical drives I place as Master on the secondary IDE interface. Or I used to... don't have one now.
Setting the jumper to Master or Slave should not matter at all, as long as you don't have two drives on the interface identified the same way.

0

Ok, correction -- I placed a jumper on the "Limit capacity to 32 Gbs" setting, and now the drive can be recognized. I know you said that shouldn't matter, but that's how it happened. I still haven't been able to format the drive though, but something in the back of my head keeps saying "Don't stop, it'll work." I also have my IDE optical drive as master on the secondary IDE controller. Can you boot with the FAT32 format? As a side note, I plan to make this a dual boot drive with XP and Ubuntu.

Edited by DaMoose75: WOW, that's jumbled. Sorry!

0

I did say "Setting the jumper to Master or Slave should not matter at all, as long as you don't have two drives on the interface identified the same way.", and that is true.
The jumper you placed is to limit the disk size seen by the interface so that a FAT32 format into just one partition can cope with it [for W2000]. That, however, is not the disk size limit, not is it the volume size limit for XP. I suggest you read this: http://support.microsoft.com/kb/184006
and this: http://support.microsoft.com/kb/314463
And yes, you can boot with it. Just that nobody uses FAT32 when NTFS is available... for data security.
Linux is a different kettle of fish as far as disks go. I know nothing of it.

0

DBAN failed... I've given up. Thanks to all who replied. Your ideas were wonderful, and you're all so nice. I appreciate it greatly.

0

Good-oh, DaM. It does seem as thought the R/W capability has been blasted. Option 2 for the drive is a shaving mirror.

0

Most of have this types of problem related to HDD. The reason is your HDD having a problem of read/write. Or sometime or may be very time your PC having a low configuration so process is in that "having no end" like endless process or out of bound.

The solution is try to format in other PC.
or use some tool to format like Norton Partition magic it's best.

Or try to format in "quick format" mode. another is first check your each drive with CHKDSK command.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.