0

Hi all,

Let me first start off my saying that I've looked through this community and I think that it is one of the best I have ever seen. The people are friendly and the fixes you guys provide to many problems actually work. :cheesy:

Anyways, here's my problem:

I play a game called Final Fantasy XI, and to get into that game, you need to go through the PlayOnline viewer. Well, I've never had trouble with anything for almost 2 years now, but all of the sudden when I go into the game, about 5 minutes into it, everything exits, FF11 and the pol viewer and it says that PlayOnline viewer has occured an error blah blah. It says that it had a problem with dinput8.dll .

I would show a screenshot of the error, but unfortunately I'm not near my PC at this time.

Now, I've done some research, and I know that this dll is associated with DirectX from Microsoft. As far as I know, though, I've only seen it related to Windows 98/ME, and DirectX 8. Well, I have Windows XP and DirectX 9...so I'm not sure what to make of this.

I'd appreciate it if any of you knew how to fix this problem...maybe it's a bad dll file? Right before it happens in the game, I did notice that it does one or two 'dings' like when you click around a dialog message that you can't close in windows. Then it crashes.

Thanks for your help!

6
Contributors
7
Replies
9
Views
11 Years
Discussion Span
Last Post by Hockeykid586
0

Without knowing the exact text of the error (I don't need a screenshot, just the exact error message), it's hard to diagnose the issue.

I do have a couple of ideas though.

  • FFXI crashes whenever you shift focus away from it.

    Are you trying to alt+tab?
    Do you have any programs running in the background that might try to grab focus?
    Do you have spyware or adware that is creates popups (following the clean up guide linked to in my sig)?

  • Are you running Xfire? Xfire is known to cause FFXI to crash.

What version of DirectX are you running?
What graphics card are you using?
Have you updated your graphics card drivers to the latest version?

0

Ohhh come to think of it, this started after I installed XFire.

That's probably it..

I know I'm running the latest version of DirectX, whichever one that is. I know that when you try to minimize the game it crashes, so I never do Alt+Tab or Ctrl+Alt+Dlt unless I need to exit really quickly, and I haven't done that in months.

So maybe it is XFire...I'll close it and run FFXI and see if it does the same thing. Since I'm not at home, I can't give you the text from the error, or test to see if it's XFire, so I'll post it in a couple of hours.

Thanks for your help, I hope that's all it was.

0

Oh, and my Graphics card is a nVidia 5700LE, and I have the latest drivers, to my knowledge.

I'm planning on upgrading to a 6800GT.

0

Yeah i just got a new game and right when i click on it it says " A required .DLL file, DINPUT8, was not found." what should i do send me a message if you can thanks.

0

I have a similar problem; "C:\Windows\system32\DINPUT8.dll is either not designed to run on Windows or it contains an error... try reinstalling blah blah blah" This gives me a bad image error when I run certain programs like Chess Titans from windows vista or Hellgate London. I used to be able to run chess titans fine but then it suddenly started giving me these kinds of errors and I don't remember if there was something I installed other than maybe new drivers for the 8600M GT. I tried downloading a new dinput8.dll and my comp got mad at me, tried a registry cleaner but i gotta pay a million bucks for it to look at more than 2 effing files. Is dinput8.dll possibly something that I downloaded in a driver file that isn't supposed to be in vista at all? I think all else that i can tell you is that other games work like World of warcraft work. Lemme know whatcha know please. thanks a bunch happy holidays.

0

I have a problem with my computer that everytime i try World of Warcraft it close the launcher. So when i try to open it Wow.exe folder directly this comes up. Wow.exe bad image C:windows\system32\DINPUT8.dll is either not designed to run on windows or is contais an error. Try installing the program again using th origianl installation media or contact your system administrator or the software vendor for support" also when i do a run Directx diagnostic test and this comes up. dxdiag.exe. bad image C:\windows\SysWOW64\dinput8/dll is either not designed to run on Windows or it contains an error. Try installing the program again using original istallation media or contact your system administration or the software vender for support" I have installed World of Warcraft before and it worked fine on here. I have re-installed it over and over and nothing works. please i need help

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.