0

I'm having a problem with the backup for Windows 7. I get an error message "The backup application could not start due to an internal error. Class not registered (0x80040154)"

I recently installed Windows 7 on a new hard drive, I'm backing up to a new external hard drive.(both 1TB) I didn't make rescue CD's when I installed it because I figured I had the installation CD. Now I wish I had because I would have caught the problem earlier. Now I have all kinds of updates on here. Some Microsoft, some programs and some driver updates. I don't really want to have to do a clean install if I don't have to to fix this. I have run sfc and there doesn't seem to be any system problems. I also ran a disk check on both hard drives, no problems. I don't know what "internal" error there would be. I ran Memtest on the Ram, not problems detected. I also used AIDA64Extreme to do a stress test on the hardware, software and system. All running well within parameters. I can't think of anything else to try. I did try to use some third party backup software (Acronis TI for WD and Macrium Reflect) I could not get a verifiable image from either. Something is wrong somewhere, just don't know where.

When I ran a search on the 0x80040154 it seems that code covers a plethora of stuff. It's hard to track something down when they throw a generic error code on it.

If anybody knows of a way to fix this (without doing a clean install) I'd appreciate some help.
Thanks

2
Contributors
2
Replies
4
Views
6 Years
Discussion Span
Last Post by up the creek
0

Which version of Windows 7 is this? Is it 32-bit or 64-bit?

What are you using for security / anti-malware / etc? Have you installed any kind of operating system 'optimizer'? Have you run any online 'optimizers' or cleanup utilties?

What do you mean by 'cannot verify' the Acronis backup?

0

Sorry about that, it's Windows 7 Pro version 32 bit. Security is Windows firewall, Microsoft Security Essentials anti-virus, Malwarebytes for malware.
I'm not sure what you mean by "on-line optimizers"? The only program I can think of that optimizes is my Acer Empowering Technologies see attachment for what that does.
I run RegCure for registry cleanup, again see attachment. I have "drivecleanup" which gets run from command prompt, but that only removes drivers no longer associated with anything.

If an image can't be verified as a good, usable image it's next to useless. I also threw in a screenshot of why the Acronis fails verification. I have no idea what this "0-0" partition is, unless it's the reserve partition.
I also have Macrium Reflect for image backup but that wouldn't verify the image either so I uninstalled it.
Thanks

Attachments Image_failure.jpg 123.56 KB optimizer.jpg 46.78 KB registry_cleaner.jpg 84.6 KB
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.