0

Hello Everybody!

I came to discuss a strange behavior of my WSUS. I started some days ago and I could not find any solution yet. I hope you might be able to give me one.

The problem is the following. When I start the WSUS the "add-snap in to console" part takes a lot of time, I think more than it should. After it finished the snap in the console starts and when I try to get any information about the server status it pops-up an error window with the following:

"The snap-in is not responding

To return to MMC and check the status of the snap-in, click Cancel.

If you choose to end the snap-in immediately, you will lose any unsaved data, to End snap-in now click End now."

I can reset server node, but I do not know what it is.

I checked the windowsupdate log and it is full of errors. I tried to figure out what those means but I am not an expert so I paste a part of it here:

2011-04-27 11:45:12:422 952 1e78 PT WARNING: GetCookie failure, error = 0x80072EE2, soap client error = 5, soap error code = 0, HTTP status code = 200
2011-04-27 11:45:12:422 952 1e78 PT WARNING: PTError: 0x80072ee2
2011-04-27 11:45:12:422 952 1e78 PT WARNING: GetCookie_WithRecovery failed : 0x80072ee2
2011-04-27 11:45:12:422 952 1e78 PT WARNING: RefreshCookie failed: 0x80072ee2
2011-04-27 11:45:12:422 952 1e78 PT WARNING: RefreshPTState failed: 0x80072ee2
2011-04-27 11:45:12:422 952 1e78 PT WARNING: PTError: 0x80072ee2
2011-04-27 11:45:12:422 952 1e78 Report WARNING: Reporter failed to upload events with hr = 80072ee2.
2011-04-27 12:14:24:762 952 1fcc PT WARNING: Cached cookie has expired or new PID is available
2011-04-27 12:14:24:762 952 1fcc PT Initializing simple targeting cookie, clientId = 3ce1fa90-8105-46a0-b5a0-f049c987364b, target group = xyz, DNS name = xyz
2011-04-27 12:14:24:762 952 1fcc PT Server URL = xyz
2011-04-27 12:15:25:555 952 1fcc Misc WARNING: Send failed with hr = 80072ee2.

I do not know whether it helped or not. I hope so.

Could you help me to reach the management again? Do not know where and how to start it. I checked and restarted the proper services in windows. Restarted the whole server neither worked.

Thanks for your patience and understanding!

5
Contributors
6
Replies
9
Views
6 Years
Discussion Span
Last Post by lasitha2005d
0

go to control panel - admin - event log
clear the application event log
restart the server and try to open the wsus management console

post the errors that appear in the application event log here and ill try to help out

0

The WSUS administration console was unable to connect to the WSUS Server via the remote API.

Verify that the Update Services service, IIS and SQL are running on the server. If the problem persists, try restarting IIS, SQL, and the Update Services Service.

The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists,

Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.


System.IO.IOException -- The handshake failed due to an unexpected packet format.

Source
System

Stack Trace:
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
at System.Net.TlsStream.CallProcessAuthentication(Object state)
at System.Threading.ExecutionContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.ConnectStream.WriteHeaders(Boolean async)
** this exception was nested inside of the following exception **


System.Net.WebException -- The underlying connection was closed: An unexpected error occurred on a send.

Source
Microsoft.UpdateServices.Administration

Stack Trace:
at Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer(Object[] args)
at Microsoft.UpdateServices.Administration.AdminProxy.GetUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
at Microsoft.UpdateServices.UI.AdminApiAccess.AdminApiTools.GetUpdateServer(String serverName, Boolean useSecureConnection, Int32 portNumber)
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.GetUpdateServer(PersistedServerSettings settings)
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ConnectToServer()
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ConnectToServerAndPopulateNode(Boolean connectingServerToConsole)
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.OnExpandFromLoad(SyncStatus status)

After clearing the log I got this in the new one. I just restarted the Update service service because I was unable to restart the main server during worktime. I hope it might help you to figure out the problem.

Many forums writes that I should reinstall the WSUS and everything will be fine. What is your opinnion?

Thank you for your reply!

0

Hello Ted,

Are all your MMC's broken? Do you get a blank screen with a red x in the upper left hand corner? If so I had the same problem and it was caused by installing a patch for .net I believe 3.5. After I uninstalling/reboot it my mmc worked fine, at which point I was able to reinstall the .net patch.

If other MMCs work don't bother uninstalling. If that is the case I agree with other posts you have read, it is really easy to reinstall WSUS which have done before when I broke mine.

0

I reinstalled WSUS and it has been working fine.

Thank you Zelkea!

0

My WSUS under SBS 2003 is redundant and causing more trouble than it is worth. Can someone please tell me how to totally remove it + the pseudo SQL DB + massive file store.
If only SBS installation asked if you want WSUS or not. I would always take NOT.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.