0

I have a ton of files that the 'owner' changed to 'Owner can not be displayed'. They are photos (.jpg's) and they come up as 'invalid image' when I try to open them. If I change the owner of the file to 'Administrator' (or me) and then add 'Everyone' under 'Users and Groups' the image comes back.

I can't figure out how to do this to an entire folder and there are at lease a few hunderd files that this has happened to.

In some cases the entire folder has changed and in others there will be two or three thumbnails displayed and the rest don't show up and display 'invalid image' if I try to open them.

If I select and entire folder and try to add 'Everyone' as a user again it will flash through several fles that are okay and then say 'Access Denied' on the ones that won't open. The only way to regain access is to go in and change ownership and then add Everyone as a user to each individul file. Not liking Windows 7 to much at this point.

I can't imagine having to go through several hundred images like this. This is a new installation of Windows 7. The files are on my old hard drive. I have dozens of folders with hundreds of pictures that display thumbnails and open fine and then a dozen or so folders that display the problem I've described.

I can detail exactly what I'm doing if you think you can help.

Thanks,
Tom

Edited by Gr8fultom

4
Contributors
4
Replies
7
Views
5 Years
Discussion Span
Last Post by Shinedevil
0

Well, with Linux and a bash shell, this would be trivial:

find . -type f -exec chown name.group {} \;
find . -type f -exec chmog ugo+rw {} \;

etc. So, you can install Cygwin (free Linux/Unix environment for Windows) and have these tools available for you. I find they are very useful on Windows systems for these sort of bulk updates.

0

Try closing down windows explorer. And then ctrl+shift+ALT-click windows explorer again to open it as admin (make sure you are logged in as admin obviously)
Right click on the folder of files you want access to, go to properties, make sure i the two checkboxes in the tab that opened is unchecked, then go to security tab, edit, and change all the permissions to allowed for all users.

Does this help? Not sure what you have already tried, so lets start here. Tell me if this worked.

Edited by joankim

0

{previous post deleted - ardav}
Woops, Im realy sorry, that post was meant for another thread

Edited by diafol: Couldn't delete as references made to this post

0

Woops, Im realy sorry, that post was meant for another thread

It's okay.

As for the question in the thread, right click the folder, go to "Security" --> Advanced --> Owner tab --> Edit --> Add yourself to the list, click the check box "Replace owner on subcontainers and objects" --> press okay or apply then okay, and then you're done :3

Ask more questions if you need help.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.