0

Hi cracks, please assist,

crossplattform program pdf forms designer will not start in windows7 64bit SP1
Java 7 installed 32 bit for firefox

doubleklicking batch file does open cmd-window for a second, closes and nothing happens.

any clues on where to start looking for problems

thanks

3
Contributors
8
Replies
9
Views
5 Years
Discussion Span
Last Post by javanoclue
0

Rater than double clicking te batch file run it directly from a commas prompt to see the error. It may require elevated access. If so you should be able to right click te shortcut and run as administrator.

0

I tried to run the batchfile as adminitrator with the right click but same thing, cmd window appears for a fraction of a second, goes and nothing happens.
I also tried to drag the batchfile to a cmd window and hit enter, see post below.
Any ideas?

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Markus>C:\Users\Markus\Desktop\windows_forms\run.bat

C:\Users\Markus>java -cp jpedal.jar;itext.jar;swing-layout-1.0.jar;vldocking_2.1
.4.jar;forms.jar org.pdf.forms.gui.VLFrame
'java' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Markus>

0

Add the bin folder of the jdk into the path variable.

I am not sure I know what you mean.
I added the location of the java bin folder to the path variable as following these instructions Click Here, but same old, program not running.
This is the path I added: **;C:\Program Files (x86)\Java\jre\bin**
or do I have to add it to the batch file? If so, could you give me a sample, as I am not familiar with the slachs and dashs and semicolons.
The text of the batch file is: java -cp jpedal.jar;itext.jar;swing-layout-1.0.jar;vldocking_2.1.4.jar;forms.jar org.pdf.forms.gui.VLFrame

0

Are you sure the path is correct? What java version do you have?

Edited by scudzilla

0

the thing is when i fiddle within the guts of programs or the operating system I am not sure of anything, I just follow the instructions somebody else has found out.

Anyway, the Java version is 32bit (build 1.7.0_04-b22) and it is located in the program folder
C:\Program Files (x86)\Java\jre7\bin\javaw.exe

I don't know if there is a conflict between the Java 32bit and Windows7 64 bit?

0

This is what you added to the path variable:
C:\Program Files (x86)\Java\jre\bin

This is what you're supposed to add:
C:\Program Files (x86)\Java\jre7\bin

0

I be damned, that's it, it works, I can't beleive, I was just about to give up and throw myself out of the window, you saved a live. thanks a lot for your help!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.