0

I'm having trouble with a home-built desktop PC where wireless network cards don't appear to be working for it. I put one in a PCI-E slot on the motherboard and I also tried just using a USB wireless card.
Neither work, according to the windows trouble shooter there is a problem with the drivers on each of them. I have tried reinstalling the drivers with no effect.
Can anyone suggest a way of dealing with this? Thanks!
Also I have Windows 7 operating system and processor and motherboard in computer are (if at all relevant):
Intel Core i7 2600K 3.40GHz (@ 4.60GHz) Sandybridge CPU Asus P8P67 DELUXE Intel P67 (Socket 1155) DDR3 Motherboard
The PCI-E wireless card is a D-link DWL-G520 Wireless G 108 Mbps PCI Adapter and the USB one is a TL - WN722N

3
Contributors
2
Replies
3
Views
5 Years
Discussion Span
Last Post by Dragennd
0

hi,perhaps it a problem with the wireless device you are trying to connect to ,did you try resseting the wireless modem ,sometime just unplugging from the power foe a few minutes ,or sometime it may require using the reset button on the back

0

Couple things you might try (if you haven't already):

1) Check on a different computer that has internet to see if more up-to-date drivers are available; the ones that came with your device might be out-of-date.
2) Make sure your device is designed to work with Windows 7 and if it is make sure that it is compatible with your version of Windows 7 (32-bit or 64-bit)
3) Make sure your wireless card does not need extra power from the power supply. Also make sure your motherboard has proper amounts of power being supplied to it.
4) You might also make sure that the port is turned on. This can typically be done in the bios of the machine.

I'm not sure if I have just pointed out anything that you have already tried, but perhaps it will come in handy for your troubleshooting efforts.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.