0

Hey guys, I was sondering if you could help me with a small (maybe not so small =S ) prob I have with my pc at the moment...

Ok so here's the deal... I came home one day about a week ago with a couple of m8's to have an all-night LAN session... when I went to fetch my pc, it wouldent turn on. so after a few minutes of contemplation on wtf is wrong with my pc, it miraculously switched on...

Now my problem is NONE of my USB Ports work... My device manager tells me that everything is in working order, and when i plugg things such as my iPod or mouse, the mouse laser turns on and the iPod charges... its like windows just isnt realizing that something is plugged into the pc =/

I have checked my drivers and my usb host controller is appaarently out of date ( Driver is Intel(r) 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD) - I cant seem to find an update for this on the web. plz let me know if you find a valid download cause most site just send me to the windows update page -.-

I have Attached a file with my pc's CPU-Z dump-file so you can take a look at it... (This computer is a lap-top just so you know so its most likley that the USB's are attached to my MB) I really appreciate anything you might have to offer me at this point in time as having no USB devices is interfering with my Web-Design and Gaming =( Purchasing a new MB is my last resort right now as it is a laptop and it could take weeks to find a repair...

Thanks for your time!
Andrew

(plz excuse the spelling =P Its kinda late and im tired =)

4
Contributors
5
Replies
6
Views
10 Years
Discussion Span
Last Post by andrew08
0

If you tried downloading the latest drivers for you motherboard etc, and that still doesn't help when detecting the usb ports. Try a reformat?

0

well i have tried reinstalling the drivers but it still didnt change anything :rolleyes: Is re-formatting really the only thing i have left to try?

0

Have you tried Google? Try asking some of your co-workers if you work at a computer business.

Hope you find out what's wrong. If not, reformat (sorry).

-- Alex

0

windows will have a driver copy stored in your pc. Try refreshing the USB driver stack....
So first - unplug all USB devices, and uninstall their software.
Reboot into Safe mode, navigate to Device manager. In view tab check show hidden devices. Delete/uninstall ALL USB drivers and devices: firstly printer, scanner, mouse etc, then root hubs, then controllers.. until there are no USB items of any sort left. Turn off and restart in normal mode. Windows should detect the controller and try to install new drivers. Go from there.

0

Thanks everyone! Im gonna give these ideas a shot and see what happens...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.