0

My son was using his toshiba satelitte win 8.1 64bit computer and it crashed. Now all it does is go through the repair loop with no success.

I thought maybe it was the MBR and tried to replace that but only screwed things up. I replaced the BCD file with the backup I made and now it's booting again.

The error I got before I played with the MBR is 0xc0000185, seems to be a registry error. I tried going back to an earlier time using restore but it said I had no restore points. I never set this computer up so I don't know if the restore system is even on. It looks like it's not. So I got no where.

After I restored the MBR it said I had an error of 0xc000021a. This seems just as bad, failure to access winlogon and such.

So this is where I am. I don't have a recovery disk which makes it even more fun.

Is there anything I can do? I have a Win7 computer and a USB to SATA cable which gives me access to the drive using the Win7 machine. This is how I was able to play with the MBR (using diskpart etc...)

Is there anything that I can do with this drive external to the Win8.1 machine?

Thanks

3
Contributors
20
Replies
44
Views
3 Years
Discussion Span
Last Post by cgeier
0

Since I can't use the recovery partition, for whatever reason that it won't let me. I have extracted the files from the hidden partition and put them into a folder on the drive.

How do I go about making the recovery disk using these files? Since they are about 9GB worth of files I figure I'll have to use a USB drive instead of a DVD.

0

If the MBR was borked, then it is likely the disc is fried and your attempts at recovery will be for naught. You need to run a sector scan on the drive to see if there are too many bad sectors. Is this a hard drive, or an SSD?

0

I repaired the MBR by putting the backup that I created of the BCD file back in place. I was successful as the computer boots, but doesn't complete and gives the error 0xc0000185 or 0xc000021a. When I had the corrupt MBR I was getting the error 0xc000000f, which no longer occurs.

I am limited to what I can do on the computer as the repair utility seems to go into a loop and doesn't exit. On ocassion it will come out and lets me into the troubleshooting area. I've tried to boot into safe mode but it won't let me.

When I connected this drive to my Win7 computer it asked if I wanted to scan the disk and I said yes with the fix option enabled. It said it fixed it and placed some files on the drive. I haven't looked at those files.

This is a Hitachi 500GB HDD. While in diskpart it said that all the volumes were healthy.

0

Ensure that you have saved any data from the hard drive that is important before proceeding. Making a image of the hard drive can also be useful before attempting any os installation repairs.

One of the first things that should be done is to verify that the computer can boot. Booting from your hard drive is not necessary at this step. How is this done? Use a boot disk. Many free ones can be found on the internet (WinPE, Linux, etc). This will help to eliminate the possibility of hardware issues (motherboard, memory, etc).

After verifying the computer can boot from a boot disk (or USB bootable device), then you can run disk scanning software (such as chkdsk) on the hard drive.

If it is determined that the OS installation is the issue, it may be easier and require less time to re-install the OS. Since you don't have a recovery DVD, you can order one from the manufacturer, or may be able to purchase a Windows DVD from MS.

0

I'm glad you mentioned the computer might be the problem because I think that is what it is. I have a Ubuntu Linux USB and tried it out and I got a list of errors while it was booting.

I took a picture of the list, wondering if you can possibly figure out what the problem might be from it.

Picture of the computer screen:

http://www.fototime.com/1D1292D13331633/orig.jpg

Edited by Leo G

0

Ensure that the processor fan is working and the vent ports are free of dust/dirt. Has this computer been overclocked?
If so, reset BIOS/UEFI firmware settings to the default values.

What model is this computer? Did it Win 8 come installed or was it upgraded? From some info I found on the internet, if the Toshiba Satellite came installed with Win 8, then it uses UEFI firmware, otherwise it uses BIOS.

Try turning computer on and pressing/holding F2 to get into the BIOS/UEFI firmware settings.

I'm not all that familiar with UEFI. From the (limited) research I have done, it appears that UEFI uses GPT (GUID Partition Table)--not MBR. To use MBR, one would need to choose CSM (Compatibility Support Module).

At this point, I suggest that you try booting using WinPE. See below "Demo 2: Installing Windows PE on a USB Drive".

The following resources may be of use:
Windows Setup: Installing using the MBR or GPT partition style

Applies To: Windows 8.1

When installing Windows on UEFI-based PCs using Windows Setup, your hard drive partition style must be set up to support either UEFI mode or legacy BIOS-compatibility mode.

For example, if you receive the error message: “Windows cannot be installed to this disk. The selected disk is not of the GPT partition style”, it’s because your PC is booted in UEFI mode, but your hard drive is not configured for UEFI mode. You’ve got a few options:

1. Reboot the PC in legacy BIOS-compatibility mode. This option lets you keep the existing partition style. For more info, see Boot to UEFI Mode or Legacy BIOS mode.

2. Reformat the drive for UEFI by using the GPT partition style. This option lets you use the PC’s UEFI firmware features.

You can do this yourself by reformatting the drive using the instructions below, or if you need to preserve the data, use a third-party utility to convert the drive to GPT format.

Toshiba Satellite C855D-S5303 downgrade to Win 7

While Windows 8 was still installed on my system getting to the BIOS was not difficult. All that was required was for you to press the F2 key while Windows was booting. Active Function keys for the booting screens are:
F2 - Takes you to the Bios.

F10 - Which takes you to an advance options screen.
F12 - Which takes you to a boot sequence screen.

All the above steps are operational while the system is still running Windows 8.

Getting back to the BIOS

Now after Windows 7 have been installed on my system, I ran into an issue. When Windows is loading, my F2 key does not take me back into BIOS so that I can make changes. To be frank, none of the keys work at this point. Don’t worry, I have done all the work for you.

To enter into the bios just follow these steps:
1.Turn computer off
2.Now press and hold the F2 key
3.With the F2 key still press, press the power button
4.When the system lights turn on, release the F2 key.
5.Now you may sometimes see the Toshiba Logo, or you may not. The system will still enter into the BIOS.

Note: If the key is held too long the system will make a long beeeeeeeeep….not to worry it will still enter into the BIOS.

How to Check if Windows is Booted in UEFI or Legacy BIOS Mode

WinPE for Windows 8.1: Windows PE 5.1

Demo 2: Installing Windows PE on a USB Drive

How to Enable or Disable Secure Boot in UEFI

How to Install Windows 8 or Windows 8.1 using the "Unified Extensible Firmware Interface" (UEFI)

Necessary changes in the UEFI Firmware (BIOS) for a successful downgrade from Windows 8 to Windows 7

How to Do a Dual Boot Installation with Windows 8 and Windows 7 or Vista

How to Set Windows 8 PC to Boot with Legacy BIOS Mode Instead of UEFI Mode

How to change from UEFI to CSM on New Toshiba Satellite Windows 8

if you switch it to CSM, Windows8 might not boot

Edited by cgeier

0

If your computer uses UEFI firmware, I suggest checking whether it is set for "UEFI boot" or "CSM boot".

It appears that "UEFI boot" is used with GPT and "CSM boot" is used with MBR.

See the above post "How to Check if Windows is Booted in UEFI or Legacy BIOS Mode".

And since you said that you "replaced the MBR", the disk partitioning may be messed up at this point. See the following:

Wiping Out Old GPT Data

"I've been seeing a new GPT problem crop up with increasing frequency: Disks that have been used with GPT (on a Macintosh, for instance) are being re-used with MBR (on a Windows or Linux system, for instance). There's nothing wrong with this practice, but there is a pitfall: Because the basic MBR data occupies just one sector, compared with several for GPT, using an MBR-only partitioning tool can leave the disk with both valid MBR data and mostly-intact GPT data. The GPT data will not have a valid protective MBR, and any software that adheres strictly to the GPT specification will therefore ignore the GPT data in favor of the MBR data; however, some utilities and OSes will use the GPT data in this case. This is true of GParted 0.5.2 and 0.7.0 (and probably others), for instance. (It prints a warning to the text-mode console from which it was launched, but if you run it from a GUI menu, you won't see this warning!)

Such disks can be identified in several ways..."

Additional resources:

Converting to or from GPT

Repairing GPT Disks

Although, I've never used it.

Edited by cgeier

0

Sorry, I'm still old school. The MBR I was referring to was in fact the UEFI. I followed instructions on how to rebuild it and the program stalled and didn't write the file. I just replaced it with the one I saved as a backup.

I tried to boot in Ubuntu Linux and it failed Gave me a bunch of Machine Chech Errors. I posted a JPG of the screen with the list of errors on it.

I've been in and out of the setup area dozens of times since the crash. Trying to boot up Ubuntu required me to disable the security of the UEFI and change it to CSM. The machine has really never been tampered with, no overclocking. This is the first time I've really ever looked at it for him. He did have a crashing problem that I looked at but never found anything. It's only a gaming computer so personally, I didn't care. If this was for school or something I might have cared more.

I opened up the computer last night and yanked the DVD drive to see if it might have been faulty, nope. Everything looked fine inside, nothing burnt, no bulging capacitors. Not absolutely positive the fan is working, guess I'll have to check. I pulled the memory card and reseated it, I put it into the other slot and still had the same problem.

Originally, early on after the crash I removed the HDD and Ubuntu did install. It was the one and only time I got it to work. Since then I haven't been able to get it to load. I've also tried Kasperski's Rescue Disk which is also a Linux based system and that doesn't load.

So I'm pretty sure now that I have a hardware issue and not a software issue.

Thanks for all the links, I'll look at them later when I have some time. Off to work.

0

I wouldn't focus too much on the computer not booting linux. The version of linux you are using may not be supported on that computer.

0

Did you happen to view the JPG I linked a few posts up? Pretty sure it booted Ubuntu once without the harddrive installed, in CSM mode.

0

Download and run Memtest86+:

Download by looking under "Download (Pre-built & ISOs)".

Under "Memtest86+ V5.01", click on "Download - Pre-Compiled Bootable ISO (.zip)"

This will test your memory, and since the memory test requires use of the processor, it will make sure the processor works.

0

I already have a bootable USB drive. Can I place the ISO on that without having to use the installation program, or do I need to get another USB drive to put this on because it needs to be bootable on it's own USB drive?

Thanks.

0

Answered my own question. Looks like I'll need a new drive to put this on.

0

You can just write it to a CD/DVD. Or I think there is one that you can download for a USB drive, but it will probably overwrite the USB drive. You can use tools like the following:

ImgBurn

ISORecorder

to burn the ISO to a CD/DVD. CDs and DVDs are typically cheaper to buy.

Edited by cgeier

0

I have the program to write it to a DVD, but don't have a writable media. I rarely use them. I'll just get a new USB drive, this will be added to my rescue tool kit I have been building up over the years.

0

Buy two so you can have one for Win 5.1 PE or for use as a Win 8 recovery tool.

Edited by cgeier

0

Do you know how big of a drive WinPE will require? I can probably get away with a one gigabyte drive for memtest. If they even make them that small anymore lol

0

The following process is for use once you get your Win 8 working. But it states what size USB drive you will need. So, for WinPE 5.1, you will need 256 MB, but if you want to include the recovery partition on the drive (once Win 8 is bootable), you will need 16 GB or larger.

Create a Recovery Drive in Windows 8

...the USB flash drive you choose to use will become a dedicated Recovery Drive - you won't be able to use it for anything else. In its base configuration, the contents of the Recovery Drive will require about 256MB of space. However, if you choose to include the OEM recovery partition, you'll need more space. Thus, if you are creating a basic Recovery Drive, you can use a 1GB USB flash drive. (If you have a smaller sized drive, from the old days, you could use it as well.) If you are going to add OEM recovery partition, you'll want at least a 16GB USB flash drive...

Creating Recovery Media for Windows 8 - Toshiba

Have you tried pressing F12 at boot time to access the recovery partition?

Edited by cgeier

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.