Hi...I'm having a problem with using this command when trying to change the password for only 1 user.

C:\Documents and Settings\bOpS^>net user

User accounts for \\HOME3

Administrator            bOpS^                    Guest
HelpAssistant            SophosSAUHOME30          SUPPORT_388945a0
The command completed successfully.

I have used the command "net user" to retrieve a list of all the users on the computer. This proves that the user "bOpS^" exists on the system. Now when I try the command "net user bOpS^" in order to retrieve the information about this user, it repeatedly says "More?" until I specify yes or no.

C:\Documents and Settings\bOpS^>net user bOpS^
More? y
The syntax of this command is:

[username [password | *] [options]] [/DOMAIN]
         username {password | *} /ADD [options] [/DOMAIN]
         username [/DELETE] [/DOMAIN]

C:\Documents and Settings\bOpS^>

But however entering a username I know does NOT exist on the system, instantly replies saying the user cannot be found...

C:\Documents and Settings\bOpS^>net user abcdefg
The user name could not be found.

More help is available by typing NET HELPMSG 2221.

C:\Documents and Settings\bOpS^>

I have tried, changing the passwords for the other users i.e. "C:\Documents and Settings\bOpS^>net user administrator password" (which works fine), logging in on another account and trying to change "bOpS^" password (no success). I have also tried changing my username from "bOpS^" to "admin" using the control panel\user accounts and then re-trying both of these and still I have no success. I think that it may have something to do with an invalid character or something i.e. "^" in the name.

I want to be able to just change my own password using the command line, I'm working on a small app so that I can quickly run a program to change my password back and forth without having to go to control panel each time. I have administrative priveleges on all of the accounts, and it seems to be only the username "bOpS^" which is the problem. (Windows XP Professional SP1)

Recommended Answers

All 3 Replies

It's the special character that's throwing things for a loop; the "^" is a line-break character. Try this:

Enclose the entire username in qoutes when you issue the net user command:
net user "bOpS^"

Oh your kidding. I'm surprised I didn't think of doing that already. Thanks a lot anyway.

sorry maybe i am posting it in the wrong forum but i wanted to change my username for daniweb accoun bt. i have tried using the control panel but to no avail.please do help


Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.