-1

I get an"Invalid Boot.ini file booting from C:\windows" message when starting up . I use WIN XP. I have done a search for this file which shows 0kb as contents. The computer boots up after this message but I tried to repair or reinstall win xp but because of this file, cannot due to this file being empty. I have noticed this message for quit a while but never realized its significance, so system restore is of no use. I would like help in getting this file reinstalled

22
Contributors
30
Replies
35
Views
13 Years
Discussion Span
Last Post by garayen
0

I get an"Invalid Boot.ini file booting from C:\windows" message when starting up . I use WIN XP. I have done a search for this file which shows 0kb as contents. The computer boots up after this message but I tried to repair or reinstall win xp but because of this file, cannot due to this file being empty. I have noticed this message for quit a while but never realized its significance, so system restore is of no use. I would like help in getting this file reinstalled

You'll have to use the XP cd. Select the option to repair, but make it go into "Recovery Console mode." From there, you can bring up a help menu by typing help or a question mark (?). You're only interested in two commands in the list called "fixboot" and "fixmbr."

You want to run "fixboot" first, then exiting the Recovery Console and seeing if that fixes your issue. If not, retrace your steps back to the Recovery Console and run "fixmbr." You shouldn't have to run "fixmbr," but there is always a possibility.

0

Also, run chkdsk /r on the system before running fixboot.

These errors just don't occur willy-nilly. There could be some filesystem corruption-- chkdsk /r might help on that angle.

0

I cannot seem to get to the repair option when using the win xp cd. Please advise and thanks for your help.

0

Below is how to edit your BOOT.ini:

Most people cannot find BOOT.INI on their hard drive. This is because they have hidden files and have not elected to see them. Open up my computer, choose tools, folder options.
Go to View, choose the option to display system files, and also the option to display hidden files.

Now do a search for BOOT.INI (it should be on C:\ and not in any folders). You can right click on it and choose 'open.' Now you can edit it how you would like to. I've included the default examples for boot.ini for XP and 2000 below.

Here is an example of a boot.ini in XP:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Here is an example of a boot.ini in 2000
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows 2000 Professional" /fastdetect

0

Thank you very, very much. I followed your win xp edit instuctions and eliminated the messge.

0

For those of you who are not Genuine, follow this simple step by step instruction.(Note: tested and work on Windows XP Professional and Windows XP Media Center, other, you are on your own do it at your own risk) Step 1: Go to start > All Programs > Accessories and click on Notepad to open. Step 2: Copy and paste the following into notepad: [boot loader] timeout=30 default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect Step 3: Save it boot.txt Step 4: Move it to C:\ Step 5: Rename it boot.ini You are done, congratulation.

0

i have the same error message..i tried the suggestion but it didn't work...when searching forr boot.ini in c:/ .. i diddn't find it
most icons disappear from desktop.....i have winxp home...
is there any other suggestion...i check to view all files
let me know please..thanks

0

well found a solution from another site.
"my computer/properties/advanced/startup&recovery/settings
look for "to edit the startup options file manually" this opens 'BOOT.INI' in notepad
look for another OS system listed as "default" other than XP....remove the line
safe and exit"
see no more error message

0

hiya guys i have the solution for the invailid boot.ini problem and it couldnt be any easier just follow instructions below:

double click my computer and double click on your c:drive
From the menu bar click on tools then scroll to folder options whilst there click the view tab and select the part that says "Show Hidden Files and Folders".
once you have done that goto c:\Windows\pss
you will see a flie there thats called "boot.ini.backup"
copy this file and paste to your c:drive
all that is left to do now is change the name of the file from boot.ini.backup to boot.ini
then right click the file you have just renamed and goto properties under attributes tick the two boxes that say read-only and Hidden
now once more goto the tools tab folder options click view and select do not show hidden files and folders

now Reboot and all will work fine

0

for all who do not hv boot.ini missing...
right click on my computer go to properties then click the advanced tab then cilck settings under start up and recovery under system startup then click edit and paste
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

and restart

0

Thanks TKS, I copied the information for the XP Boot.ini into the blank Boot.ini on my system and rebooted...works a treat!

Very simple and straightforward.

Paul

Below is how to edit your BOOT.ini:

Most people cannot find BOOT.INI on their hard drive. This is because they have hidden files and have not elected to see them. Open up my computer, choose tools, folder options.
Go to View, choose the option to display system files, and also the option to display hidden files.

Now do a search for BOOT.INI (it should be on C:\ and not in any folders). You can right click on it and choose 'open.' Now you can edit it how you would like to. I've included the default examples for boot.ini for XP and 2000 below.

Here is an example of a boot.ini in XP:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Here is an example of a boot.ini in 2000
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows 2000 Professional" /fastdetect

0

Greetings All...

I followed all instructions posted here and the "edit boot.ini" post finally fix the error. The one thing that I have now is that upon boot I get the screen to select from two [exactly the same] XP operating systems.

0

You can edit and delete the duplicate entry in boot.ini if it bothers you.

Foz

0

yeah did that and another site said do this

Open command prompt (type cmd in Run box).

8. Type the following command

attrib C:\boot.ini +s +h

and now when it loads up the screen is black and stays that way could you help with this

0

yeah did that and another site said do this

Open command prompt (type cmd in Run box).

8. Type the following command

attrib C:\boot.ini +s +h

and now when it loads up the screen is black and stays that way could you help with this

This should not be related to the change you made. Are you sure that was all you did? To confirm, boot windows to safe mode. Run a command prompt and attrib c:\boot.ini -h -s -r then move the file into another directory (c:\testboot could be a good idea). This should take you back to invalid boot.ini message and still load windows. If ok create a new boot.ini and copy info into it. If you want to protect it the command is attrib +r +s +h.

Foz

0

Sir, I followed your instructions and it worked perfectly except for one issue. On a reboot, the file boot,ini disappeared and could not be found. When I rebooted, the same error notice appeared as it did before I copied and renamed the file. So I re did everything and again it worked perfectly. However, on the next reboot, the file disappeared again. If you have any suggestions, please advise. Joseph T. Coste

0

I have the same message on mine, and I followed everything but it will go to the screen where I would select the operating system to start, and I can select one, but it continues to go back to that screen instead of booting windows...I can not start in safe mode either when I press F8. Any suggestions? Thanks!

0

Shannon,
This could be because you do not have a default install of windows. If you have multiple hard drives or, more likely, multiple partitions on one drive, the information in the boot.ini needs to be customised to know where to find the correct windows installation. (technical info can be found here: http://vlaurie.com/computers2/Articles/bootini.htm) To confirm this, rename and move the boot.ini file to another directory (ie c:\bootest) and restart the PC. This should take you back to receiving the error message and then loading windows. Its then a matter of identifying the correct partition info. This is best done with an installation cd, which will identify where windows is on your PC.
Foz

0

I'm glad somone had put up some examples. I opened a small file 2kb cut and paste the win xp pro listed and changed it to win xp because I have the home edition. I then saved the file as boot.ini and saved it in C:\

Thanks much, Perry

0

I get an"Invalid Boot.ini file booting from C:\windows" message when starting up . I use WIN XP. I have done a search for this file which shows 0kb as contents. The computer boots up after this message but I tried to repair or reinstall win xp but because of this file, cannot due to this file being empty. I have noticed this message for quit a while but never realized its significance, so system restore is of no use. I would like help in getting this file reinstalled

[SOLVED!!]
Boy! I spent a WHOLE DAY trying to figure this one out. Scanned my PC with Norton, AVG, Spybot and Adaware (yeah, that took a while) thinking it could be a virus or spyware. REFORMATTED and everything seemed to be going ok. Started installing software and then the boot.ini disappeared again :angry:

You will not believe what causes this problem! It's the fu$#&ng "Ask toolbar" that was installed on my (and your) system without ever granting it permission.

SOLUTION: UNINSTALL the "Ask toolbar" (Control Pannel - Add/Remove Programs), open C:\Windows\pss\ In there you will find a file called boot.ini.backup (which is an original backup of your boot.ini) Copy it to C:\ and rename it boot.ini
That should do it!

Damn Stupid Ask toolbar!!!!

0

[SOLVED!!]
Boy! I spent a WHOLE DAY trying to figure this one out. Scanned my PC with Norton, AVG, Spybot and Adaware (yeah, that took a while) thinking it could be a virus or spyware. REFORMATTED and everything seemed to be going ok. Started installing software and then the boot.ini disappeared again :angry:

You will not believe what causes this problem! It's the fu$#&ng "Ask toolbar" that was installed on my (and your) system without ever granting it permission.

SOLUTION: UNINSTALL the "Ask toolbar" (Control Pannel - Add/Remove Programs), open C:\Windows\pss\ In there you will find a file called boot.ini.backup (which is an original backup of your boot.ini) Copy it to C:\ and rename it boot.ini
That should do it!

Damn Stupid Ask toolbar!!!!

0

I'm getting the
Invalid Boot.ini booting from c:\windows\
But I just installed Windows 7
My disc offers no Repair console and there's no
boot.ini on the drive (yes I've unhidden files)
What is the correct format for a boot.ini
in Windows 7
Thanx

0

The boot.ini file is always 0 kb.
There are also some other OS files like ntldr whose size is also 0kb

1

I know this is an old thread, but I do have something useful to add.

I had the same problem as the OP, and my search for a solution led me here and several other places. I just moved, and haven't come across my Windows disks yet, so I wanted a solution that didn't involved a Windows disk.

My boot.ini file was completely missing. But to add to the problem, I also had no boot.ini.backup, and I couldn't even locate a pss folder in the windows directory, in spite of the fact that I had set the options to view hidden/system files and folders and all that. I did manage to get to it another way, though I don't recall how right off. There were two other backup files in it, but none for boot.ini.

I copied the text from a sample boot.ini for Windows XP Home from the Microsoft website. Then I went to Start>My Computer>Properties>Advanced>Startup & Recovery> Settings. I got an error message about it being unable to locate boot.ini, and I clicked OK and then selected the Edit button under System Startup. It told me again that there was no boot.ini file, and asked if I would like to create one. I clicked yes, and it opened a window for me. I pasted the text I had copied, saved it, and got out of it, and clicked OK and OK again. I then navigated to c:\ to see if it was there, and it was. I copied and pasted it into the pss folder, which was now showing up in the windows directory.

It remains to be seen whether this will solve the problem. Thank you for pointing me in the right direction!

1

...I couldn't even locate a pss folder in the windows directory, in spite of the fact that I had set the options to view hidden/system files and folders and all that. I did manage to get to it another way, though I don't recall how right off...

I remembered how I got there -- Start>Run>typed "%windir%\pss" in the box and hit enter.

I also wanted to report that the problem was solved by doing this.

I know this is an old thread, but I wanted to post to it because I know that others, like myself, will find it when they search for a solution to this problem, just like I did. :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.