0

I have a DSL 504G (4 port switch and router/ADSL Modem) connected to 2 PCs at home. they both run winxp sp2, and accessing the internet is fine on both. just about everything is possible, EXCEPT playing 2 games which i enjoy very much: warcraft 3 and starcraft. everything else seems to work just fine. when i'm playing these games, i can access the game servers, see the people online at the moment, and even connect to the game, but as soon as i'm in the game, i get disconnected and booted back to the channel chat room. i figure this is a NAT problem with my router, so i type in the ip address (default 10.1.1.1) and go to change the settings. HOWEVER, i cant access anything in the menus apart from the setup wizard that comes with the software, and a few other basic functions, like help, status, and one setting in tools, called DMZ. i'm aware this is a setting i need to change in order to make NAT work properly, but when i change it to my IP address on the LAN (which is 10.1.1.2) and disable NAT, i can no longer even connect to the channels on these games, or access the internet, or even do a simple ping to a website. im not entirely sure, but i think it is a problem with the software on the router/modem, and i desperately need some help. i've got the latest firmware for the DSL-504G as at 09/04/05 (dont ask me what it is), and the problem still persists. this is a brand new modem, no idea what has caused this.
any help greatly appreciated.

5
Contributors
6
Replies
7
Views
12 Years
Discussion Span
Last Post by fantasynz
0

I haven't used your exact router, but what your looking into seems way too much, for how these things should work. The games could be a firewall problem, but first you need to get back to that original state.

I would try a factory reset, or something of the sorts, and get the router working from the initial instructions. I imagine that the problems with Warcraft and Starcraft aren't to do with your routers ip settings, or NAT, and it would be a firewall problem of some sorts, either on the router or SP2 perhaps.

Lets us know how you get on. (Not to be critical, but pls paragraph you future posts, I find it hard to read like that, bit like Ulyssees)

0

advice noted.
okay, i've done the factory reset on my router/modem, and im back to the default settings. i'm able to access the internet after putting in my user name and password as well as specifying what my internet connection is (PPPoE LLC encapsulation).
my networking is fine, both computers can access the internet and each other, no problems.
every single game works, INCLUDING warcraft 3 now. the only one i have problem with is starcraft. the problem is exactly the same as described above.
i'm now able to access the advanced options in my modem configuration, the problem was I was using Firefox (out of habit) and i then tried IE. it works fine.
the firewall in SP2 is turned off completely, and i dont have antivirus/firewall software running.
as an added note, the modems ive had before this one were DSL-302, DSL 200, and a NetComm (that one was a long time ago, not sure of the model number).
so that rules out the problem being with any software apart from the modem, right?

0

Cool. Glad your back up and running again.

Try Starcraft without the router / modem firewall on, then you'll hopefully narrow down the problem to that.

I tried to find the relevant ports on google for your modem, but can't speak Spanish. Perhaps post on a games forum, your more likely to get results i would imagine. Then of course get SP2 firewall up and running, and perhaps even a AV sorted.

Good luck.

0

Perhaps another thing you could try, if your router supports it, is uPnP. This makes it much easier for an application to "punch" the appropriate ports in the firewall automatically for you for a particular application.

You'll need to look in your router's manual whether or not it's supported..

M.

0

Man, you should feel special, I signed up to this shit just so I could reply to you and say that the DSL-504G is impossible to use with direct connection gaming, I know this, because I HAVE ONE, and I also have the latest firmware and I have extensive knowledge of portblocking and portforwarding and let me tell you know, IT IS NOT POSSIBLE. 5 other friends of mine who are also good with routers have tried and failed. It's just not possible!

You are better off getting something else like a LynkSys, anything but a D-Link.

Case closed.

0

I have the same problem as you.. just keep on disconnecting warcraft 3 and MSN messenger.. this router is no good?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.