I've just moved my Compaq Presario 8000T Desktop from Comcast cable/modem direct ethernet connection to my fiance's house - now I am connected via Lynksis router to AOL DSL direct with proper cable into my machine. I'm running Windows XP Professional, and I'm pretty sure Internet Explorer 6.

Here's the problem: we've connected my computer to his router - he's a pro at setting these things up. We can access EVERY web site known, except those belonging to Microsoft. I use Hotmail routed to Outlook - can't access it. Cannot go to msn.com (my home page I use), cannot go to microsoft.com, hotmail.com. no problems with Yahoo, Google, HPshopping, sears, Cingular, etc. No problems except with Microsoft sites.

My fiance has a Compaq AMD processor laptop with Windows XP Professional - we can connect perfectly through same router - but wireless - to any website we want. His machine can get to all MS sites, so we know it is within my machine that there is a problem.

Here's what we've done - set up connectivity with my desktop to the router. Realized we could not get to any Microsoft sites. No firewalls were set up or active during this time. I downloaded SVP2 (I was a holdout until just a few days ago). Still cannot get to any Microsoft websites (but yet I can download updates .... I clicked on the balloon "you have updates waiting" so it really didn't seem to go to website to download). once SVP2 was loaded, I tried disabling MS Firewall - still not able to connect to any Microsoft websites.

We are BAFFLED to say the least. Again, he's using Linksys Router, AOL DSL. I just want to be able to read e-mail at home!!

Thanks for any advice.

Sounds like a spyware problem to me. Have you run the usual spyware programs? You might run "Hijack This" and post the results on the appropriate place.

I'm wondering if this could be an MTU problem, as I remember reading something like happening before. So I've Googled and came across this interesting post on another site (with apologies to those who may recognise as their own posting, but we've got try and help the original poster haven't we? ;)):

I recently installed a router at home. And switched to cable.

Turns out it was MTU that was my problem. Because I could access many other internet sites, but yahoo! mail would return a blank screen.

Setting the MTU on the ethernet interface on my PC fixed this problem. I had to set my MTU to 1490 bytes (Telstra Australia BigPond ISP limitation). Other people have to set it to 512. (Note this is an advanced task in windows, you have to google around for a while and try and work out what it is in the registry you need to change to force the MTU to be set to a lower value).

Note that setting the MTU in the router wasn't sufficient.. it was my PC that had to have the MTU changed (I was running Windows 2000).

The MTU for an interface can sometimes be changed with utlility software supplied with the network card, or alternatively within the Device Manager for that device. Check there.

M.

Hello,

It is possible that you have bogus definitions for the microsoft sites in your hosts file. do a search for hosts... it will be in System32\drivers\etc or something like that, and you will need to open it in a text editor. Do not merely delete the file... check it to see if there are IP numbers and listings. The information of 127.0.0.1 belongs in that file.

You can also do a ping test

ping www.microsoft.com

and see if the numbers resolve properly.

Christian

Thank you to everyone's suggestions. My fiance logged into his Linksys router IP and changed the MTU setting to 1400 - THAT WORKED!!!!

I can't get into yahoo.com now, but I DON'T CARE!!!!!!. As long as I have my Hotmail, I'm happy.

Thanks again - problem solved.

It almost certainly is a Spyware problem. I have had exactly the same problem. Even though McAfee reported my machines as free from spyware, when I downloaded Spybot, it found 30 + infections. When I eventually cleaned them all up, which involved downloading Service Pack 2, the problem went away.

Recomendations:
1) Run Spybot to see if it reports anything
2) Update Windows Xp

I have been using a netgear router dg834 with AOL without any problems until yesterday, when I lost complete access to the internet. I had to reset the router back to default settings. After setting the router up again I was able to access the internet, however I found I could not access any microsoft sites, but I could access any other site. I found help on the AOL site which pointed me to my MTU settings. I also found these postings and thought I should add my exsperience to it. I reset my MTU to 1400 and all is well.

I ran into the same issue and after days of virus and spyware/adware scans, I discovered this post. I had recently changed the MTU's on my firewall to try to fix a VPN issue, but inadvertently killed my Microsoft updates. Changing the MTU back to 1500 on the internal interface corrected the issue. The standard ethernet MTU is 1500; PPPoE is 1492.

I have essentially the same problem, and I have no idea where to start as far as changing MTU numbers in my router. We have a Zoom ADSL X6 router with wireless. I'm running Vista and my fiance is running XP, and neither computer can access any microsoft sites. All was fine with our old router, which stopped working completely last week, which led to the purchase of the new one. I know how to access the router, however I am unable to find anything resembling "MTU." If anyone can give me more detailed instructions as to how to resolve this issue it would be much appreciated.

I have essentially the same problem, and I have no idea where to start as far as changing MTU numbers in my router. We have a Zoom ADSL X6 router with wireless. I'm running Vista and my fiance is running XP, and neither computer can access any microsoft sites. All was fine with our old router, which stopped working completely last week, which led to the purchase of the new one. I know how to access the router, however I am unable to find anything resembling "MTU." If anyone can give me more detailed instructions as to how to resolve this issue it would be much appreciated.

I had the same problem and after reading this thread and a few others was able to fix it. As was mentioned, you need to change your MTU in Vista in the Command Prompt. The command you need to run is below. Two things I had to change were the "Local Area Connection" to the name of my connection and the mtu to 512.

Netsh interface ipv4 set subinterface “Local Area Connection” mtu=1492 store=persistent

Secondly, I had to make sure that the command line was running in admin mode (go to all Programs/Accessories and right click on the Command Promt and click on run in admin mode)

If you don't know what your connection name is then type in ->
> Netsch
> interface ipv4
> show subinterface

I had the same problem and after reading this thread and a few others was able to fix it. As was mentioned, you need to change your MTU in Vista in the Command Prompt. The command you need to run is below. Two things I had to change were the "Local Area Connection" to the name of my connection and the mtu to 512.

Netsh interface ipv4 set subinterface “Local Area Connection” mtu=1492 store=persistent

Secondly, I had to make sure that the command line was running in admin mode (go to all Programs/Accessories and right click on the Command Promt and click on run in admin mode)

If you don't know what your connection name is then type in ->
> Netsch
> interface ipv4
> show subinterface

My problem turned out to be a nasty piece of spyware which Norton couldn't see but I downloaded spybot and it cleared it up nicely.

NOOO WAAYYYY!!!!, this MTU stuff actually works damn fine!!, it's 100% legit!!, here's the situation, a few days ago I went to a website that I visit frequently and I never had any problems loading that website EVER, until a few days ago, I just use to type in the URL of the website and it would come up like almost instant (just a few seconds maybe on a bad day lol) but before now starting a few days ago the damn thing was taking forever to load and when the load does complete all I got was a firefox message telling me "The Connection To the Server Was Reset While The Page Was loading" or if you're using Internet Explorer "Page Cannot be Displayed" GOSH!!,::angry:

so all along here I was thinking it was just this particular website since most other websites "seemed" to have been working just fine, that is until I checked Microsoft.com!!!:-O:$ , the same thing happened over there too so instantly I came to they conclusion that maybe everything is not as fine as I think it is:-/ , infact I may just have this problem with yet another website that i may know all to well so what I did was go back to some of the websites that I had bookmarked and some popular ones to see if some may exhibit the same problem and low and be hold:@:@ I did infact encounter this page loading problem with some websites that use to work excellent and gave absolutely no trouble so right there and then I knew there must be a problem with either my computer or my internet connection settings;) , you know things to do with my computer and my internet specifically, something that I just don't know about and hadn't' encountered before.

I did a search "Can't Load/access Microsoft.com" or something like that and came across this website read what I saw about MTU settings then went to do a little bit of research on that(to tell you the truth I found some information on the MTU issue a couple of times before but none where quite specific to the point of a solution) and came across this site
"http://www.dslreports.com/faq/5793" and on the example of the MTU and Ping testing/solving etc they got it explained pretty clear!:X :X , so I started following the steps mentioned in their examples and as it turned out my MTU was set too high:| and it was just a metter of me tweaking my MTU settings from about 1472 or 1500 to 1464!!:ooh: :ooh: and that worked for me.

I went to the Microsoft site and it's loading smoothly also went to the other sites I was having this issue with also and they now are working as they should, to tell you the truth I would have had this MTU stuff fixed earlier if I hadn't overlooked it and regarded it as "irrelevant":D lol, I absolutely did not think that this MTU stuff was my problem:X, those same website worked with the same modem i'm using with the same "NOW" "problematic settings" it had before I edited the MTU stuff:confused: , so i really had no reason to believe it was my modem/ "Ethernet" modem that was the problem in fact before I thought it was a problem with my internet connection I actually though it was a problem with that one websites server lol that is until obviously when I encountered the problem on other previously working websites:yawn:.

I guess this happened as the result of some abrupt computer malfunctioning that occurred with my PC a few days ago which forced me to reinstall windows XP and my DSL:icon_rolleyes:

Hi all,

I have the exact same problem as the original poster of this thread. However, I am a complete amateur when it comes to the complexities of computers, so I would be very much appreciative if someone could perhaps try to explain a solution to this problem which I could either follow or perhaps give to somone more knowledgable to follow.

Many thanks.

i have the same problem , but after setting MTU=1500 in PC and MTU=1500 in Firewall (SOnicwall). We get no change .
any one can help me
thanks in advance

Hi,

I'm also looking for an answer to the same question.

I have installed Windows XP SP2 on a Dell Optiplex 745, I am unabe to download Windows Updates and even cannot access any microsoft website.

But can access any other website i.e howstuffworks, google, yahoo .... etc..

It is a virus that's giving you the problem.

You can remove it by going to http://safety.live.com

there you find a scanner from Microsoft which will remove it.

ALSO: Take notice to your modem or dsl activity, as it will constantly be sending and receiving info to the source of the infection.

Good Luck, Ed

Satsriakal!!
Just click on Start --> Run --> Type services.msc. Find DNS client , right click on it and stop it. You will be able to access the blocked sites of microsoft.

Hello HEYBETS30

I am Brazilian and my friends here in Brazil had the same problem yours, I see that I can solve your case (I have several solutions to this problem, I put one that I deleted your need, but if my hint does not work I put other, OK). I'm sorry if you could not read what is written, correctly, that I use google translator service, as it is not efficient .......... kkkkkkkkkk! !!!!! More that's not the case.


We go:

1 Click the Start menu.

2 * Search for the word RUN, thinking gave a click

3 * Type this command SERVICES.MSC

That done, you search the word CUSTOMER DNS, finding one you click with right mouse button on top, and then switch to OFF.
Now search for the word Web client, which is just above the client dns after is repeat the same procedure as quoted anteriomente.Espero you solved this problem here, if you want to believe that it is global.

If, just remember if you can not solve with this trick, post your comment, I'll be here with several others. But if I decide not forget to thank me ............. KKKKKKKKKK

YESS! that fixed the problem...restart the dns client in your services...(and in English!)

1. right click on my computer
2. go to manage
3. find services
4. restart dns client
5. serve and enjoy!

problem solved!

Edited 6 Years Ago by jasonhchrist: n/a

IT WORKED! i love all of you. the instructions on top of me worked

Edited 6 Years Ago by PwnPrawn: n/a

Satsriakal!!
Just click on Start --> Run --> Type services.msc. Find DNS client , right click on it and stop it. You will be able to access the blocked sites of microsoft.

I just wanted to thank you and let people know that this resolved my problem with connecting to www.microsoft.com. I also tried the spybot suggestion but the problem continued. I was getting discouraged With all the advise to change the MTU's and the command prompt local lan connection.

What worked for me: I had the same problem with my browser. I couldn't access any microsoft or other untivirus sites. I couldn't even change my search provider from my tool bar to google!. I had already tried to fix it with updated versions of SDfix and ConboFix and nothing worked. A quick semi-fix was to install firefox. What worked for me was cfremover, which I found at a different blog. Just download and follow the prompts. The program starts about 4 times, each time re-booting the computer. Internet explorer worked fine after that.
link: http://www.enigmasoftware.com/tools/conficker/cfremover.exe

OK here is some additional information for those of you with this problem. I am a consultant and I had the same problem but on a network wide basis for 2 of my customers. All of the computers on their networks including the servers could not access Microsoft web sites. They are both connected to DSL (Qwest in this case) via unmanaged switches. What I found was the DSL connection was defined as PPoE, I changed them to PPoA and the problem went away. I hope this helps someone.

I just use XP and have had the same problem
below has worked for me
Just click on Start --> Run --> Type services.msc. Find DNS client , right click on it and stop it. You will be able to access the blocked sites of microsoft.

cannot connect to microsoft and various others.Ihave just installed xp pro wth ie6 on abrand new hard disc.can you help please ,Iam not using a wireless router but a modle provided by isp provider, thi module works with my other PC.

Had similar problems - I solved mine by going to SERVICES under System Tools.
Then I changed from Disabled to Automatic and STARTed the following 3 services
(You must click on APPLY to get to START - then click OK)
1. Automatic Updates
2. Background Intelligent Transfer Services
3. Event Log
I was then able to access Microsoft sites including getting Microsoft Updates to work.
Be aware that once you turn off and restart you may have to reset these 3 fields
(at this moment I do not know why this happens).
Good luck and hope this helps someone.

Thanks for your reply Mark709. I stopped DNS client as posted by you which allowed me to update to SP3 on newly installed XP PRO on my laptop, I restarted to configure the new updates,I coudn`t connect to MS again and no other sites which I could before,I made sure DNS client was stopped, but still no joy! I tried your other suggestions still no joy.

Re my last posting, I did not update to SP3 but a few other updates which allowed me to update again to SP2,restarting to configure these updates. Now by keeping a check on auto updates , bits,and event log in Services.msc that they are set to automatic and services started also keep a check DNS CLIENTS IS DISABLED TO ALLOW YOU TO CONNECT TO microsoft update site, I had a lot of trouble that this was in the right state, Microsoft don`t make it is easy for us poor punters! Refer back to Mark709`s
previous 2 postings for more enlightenment if needed. Now to to update to SP3?? Another day for that. Updated to SP3 without too much trouble, and I think a reasonable working system (:-))

This article has been dead for over six months. Start a new discussion instead.