0

I'm having trouble with sending and receiving messages using MSN Messenger. Some messages arrive at their destination, while others don't. I'm assuming this problem is related to the fact that I've recently started using a router, because I never had the problem before.

Are there ports that need forwarding or something along those lines? I'm new to this stuff, so please help! hehe.

I use Windows XP Pro, and I have a 2 meg ADSL broadband line. I don't use a Windows-based firewall, because the router has one built in (although I use Norton Anti-Virus 2005, which protects me from various internet-based threats)

Thanks muchly :)

3
Contributors
16
Replies
18
Views
12 Years
Discussion Span
Last Post by Paddy
0

I originally posted this problem in June, and to this day I am still having the same troubles. Can anyone shed any light on this situation? Here's a run down of the problems I'm having:

* Some messages I send don't reach their destination, and some messages my friends send to me don't reach me either. We are constantly copying and pasting messages to each other. There is rarely an error (i.e. the program doesn't inform either of us that the message has not in fact been sent, we have to just assume each time.)

* The program disconnects me from the service frequently, regardless of how much of my 2 meg bandwidth is available.

* File transferring is impossible. Transfers are cancelled half-way through, and sometimes the program doesn't even acknowledge that I've sent files or accepted files to be sent to me; it just hangs.

I've read countless articles on the net about this, and I keep coming across the terms "NAT" and "UPnP" etc. I have tried to understand the concepts of these terms and how they apply to my problem, but I'm genuinely unable to grasp what it all means lol.

I no longer use Norton Anti-virus; I use ZoneAlarm Internet Security Suite, and I have granted 101% permissions to the MSN program, with little effect. I use P2P programs quite a lot, and this is what my problems have been atrributed to in the past, but even when I'm not doing anything else on the computer/net, i.e. when I dedicate every ounce of my bandwidth to the MSN program, it makes no difference whatsoever.

Please help if you can.

Thank you :)

0

What is the manufacturer and model of your router?

What version of Windows are you using?

After some quick searching, it seems that you may not be able to get this to work while behind a router without either reducing security on your system or doing some really nasty configuration that may not be possible for you.

This is why I stopped using MSN. It's silly that Microsoft can't even make their products work properly in standard operating environments.

0

Ahhh, I was afraid someone would ask this lol. I have no idea who the manufacturer is. I even posted a thread on this forum to try and find out. Check it out:

http://www.daniweb.com/techtalkforums/thread24523.html

Don't s'pose you have any idea who made it? :P

Cheers for replying :)

[EDIT]Oh yeah, I use Windows XP Professional SP2 (I had this trouble before I used SP2)

0

FYI: I updated my post above.

As for your router... Nasty. I guess it's one of those modem/router combo deals. Did your ISP send it to you with your connection subscription or did you buy it?

How do you access the configuration screen?

0

It's not the modem that my ISP sent. I bought it myself, because I was having trouble with my home network, and I was told that a router would solve a lot of these problems. Which it did hehe

I access the router's configuration page by browsing to http://10.0.0.2 and then I log in with the standard details.

Actually, I just noticed that it gives the firmware version (CX82xxx_4.1.0.21), and after a quick Google it appears that Hawking routers use the same firmware. Although I can't seem to find a Hawking router that looks remotely like the one I have lol.

I've attached a screenshot of the main configuration page to see if it looks familiar.

Attachments RouterConfigPage.jpg 55.84 KB
0

Can you show me screenshots of what your configuration page looks like after you select "BASIC" and after you select "ADVANCE"? This will help me to know what your router is capable of letting you configure.

Routers really do solve many, many issues with running broadband. I always recommend that anyone that has broadband get one. It may require some configuration and a little know-how, but it cetainly improves the quality and reliability of the connection while enabling easy connection sharing.

0

Here are screenshots of the BASIC tab, ADVANCED tab and the SPECIFIC FEATURE tab which is within the ADVANCED tab.

Attachments AdvancedTab.jpg 21.63 KB BasicTab.jpg 14.13 KB SpecificFeatureTab.jpg 24.11 KB
0

I have found two solutions to your problem. They follow in order of most recommended to least.

UPnP
Microsoft recommends that you use a router that supports UPnP (Universal Plug and Play). This feature allows Windows to tell the router to forward and close ports on the fly. I use this for many different applications and it does work well. Since you are having this problem, it would seem that you do not have that feature on your router, you have UPnP turned off in your services, and/or you have UPnP turned off on your router.

Port Forwarding
You can manually forward the ports needed by MSN Messenger. You do this by accessing the firewall ruleset or port forwarding configuration page of your router. The ports that need to be forwarded are Ports to open are:

  • MSN Messenger feature: Protocol used (Port number/range)
  • Voice: TCP and UDP - (6901)
  • File Transfer: TCP (6891 - 6900)
  • Instant Messaging: TCP (1863)

These ports need to be forwarded to the computer that you wish to use MSN Messenger on.

Note: individual ports can only be forwarded to one machine, so you need to decide which machine will be used for all MSN Messenger tasks.

Since you will be forwarding to an IP address, it is important that the same machine receives the same IP address. See if your router configuration mentions anything about MAC Filtering, Static IP DHCP, or MAC Addressing. Using MAC Filtering, you can ensure that your chosen machine receives the same IP address each time it is booted.


If you need any assistance setting any of this up, just let me know what parts you need help with.

0

Thank you SO much for all of your work on this thread pal, it doesn't go unappreciated.

The only problem I have is the problem you yourself pointed out - that ports can only be forwarded to one machine. Is it possible to switch off the firewall in the router without killing the connection? I have a software-based firewall for each of the machines connected to the router, so the router's firewall isn't really necessary, but if memory serves I tried to do this before and the router just stopped completely lol. If not, I guess me and my brother will have to flip a coin haha. Or, alternatively, can the ports used by MSN Messenger be manually set? Perhaps in the registry if not the program itself?

Thanks again mate, you're a star ;)

1

Even if you could turn off the firewall (you can't), ports can't be forwarded to more than machine. In all my research, I did not find any means that allows for MSN port assignments to be modified. It is for this reason that I have decided that the MSN Messenger was very poorly designed or designed to be fully functional for only a small subset of users.

As for your router's firewall not being very important, that's not true at all. The router's firewall protects your machines from attacks all day long. If you turn on full logging on your router, you will no doubt see all the deflected port sniffs, buffer overflow attempts, excessive ping requests, and other potentially harmful requests that your router's firewall absorbs so that your machines don't have to. Furthermore, the NAT feature on the router means that your machines are never directly exposed and that a whole network of computers appears as just one.

Votes + Comments
Many thanks for your work on my thread - Paddy
0

Thanks for looking into that for me. It's a shame there's no easy solution to this hehehe.

With regards to the firewall issue, I am aware of the protection it offers, but surely a software-based one would be sufficient in its place? Well, it's all accademic anyway, because it can't be turned off hehehe.

I will set up the ports for one system, and see what I can do for a new router perhaps, because this isn't the only program that we've had trouble with...

Thanks for all of your help, folks like you are the backbone of this site :)

0

but surely a software-based one would be sufficient in its place?

By the time an intruder hits your software firewall, he's already at the front door of your system. The external firewall provides an extra layer of protection in the form of a "perimeter defense ".

0

DMR: Ahhh I see. Makes sense I suppose hehehe.

chrisbliss18: I forwarded those ports that you mentioned, and things seem to be working a little smoother as far as I can tell...

Thanks guys!!

0

I think I may have worked out what the problem is. Well, I didn't work it out, some tech guy did and posted it on the net for me to find :p

The MTU settings for the router and my system needed to be optimised. Without getting too technical, I had to find a unique setting that worked for my system/router. So, for those of you suffering similar problems, here is the link I used to correct the issue:

http://www.dslreports.com/faq/5793 (I recommend that you do NOT use the "quick fix", which basically tells you to use 1492 as your MTU setting. Figure it out properly!)

I'm not 100% sure if it has worked, but things seem better so far. Regardless, it's something you should check into anyway :)

Cheers.

0

Oh, you will want to change your router's MRU settings to match the MTU settings.

0

Ok, it's been a few days since I tweaked the MTU settings and I can now say that this hasn't helped the problem at all. God damn it.

Any ideas?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.