0

I have a Dell Latitude 610 laptop -- had it for about 2.5 years. It's set up to dual-boot Kubuntu 9.04 and Windows XP (SP2). For a long time, I was able to connect to my home network or other networks either wirelessly or by Ethernet. The computer has both capabilities built-in.

Several months ago, however, I found myself unable to make a network connection. First, it was just the wireless gone bad. I couldn't connect to any network with either OS. I am fairly certain it's the computer, not the router, as a neighbor was able to see and connect to my home network with her wireless machine. At that time, though, I was still able to plug in the Ethernet cable and get into the network.

A few weeks later, though, I found myself unable even to connect via the Ethernet cable. I know it's not a cable or router problem because I can use the same cable and the same jack on the router to connect a different computer to my network; the computer is the only variable. Again, the failure is OS-independent -- can't get on-line with either Windows or Linux.

Anyone have any suggestions how I might get this machine back on-line?

6
Contributors
14
Replies
15
Views
7 Years
Discussion Span
Last Post by qajaq49
0

Okay, thanks. I gave that a try this morning and was able to get the Ethernet connection working.

I still do not have a wireless connection. Other resources on-line have suggested I use the Network Connections icon (in the WinXP Control Panel) and open the Wireless Network Connection icon -- but there is no such icon in the Network Connections folder on my machine. When I open the network connection software in Linux, it reports that no wireless networks are found, even though I have my wireless router on and set to broadcast the SSID, and I know there are numerous other wireless networks active in the neighborhood.

I'm happy to have the Ethernet connection back. That makes it possible, at least, to connect to my network, but it would be nice to be able to do so without the cable, so I could be more mobile.

Any further suggestions?

0

Check device manager and see if you have a wireless network device listed and if it is working properly. If not re-install the wireless device driver (uninstall first if it is installed but shows a problem.)

0

Checked that. No wireless device is listed. I have deleted and re-installed the Dell wireless device driver, but still find no wireless device listed.

0

have you tried
ifconfig wlan0 down
ifconfig wlan0 up
iwconfig txpower auto
iwconfig
ifconfig -l
in linux?
also try going to the bios and if there is a embedded wireless option turn it off then boot normally then bios enable it then boot normally

Edited by avarionist: n/a

0

Another bust, I'm afraid. When I tried ifconig wlan0 up, I got the error message: "SIOCSIFFLAGS: No such file or directory"

I re-booted and got into the BIOS set-up, found an embedded wireless option and ran through the disable-boot-enable-boot sequence suggested, but wicd still shows "No wireless networks found" and the ifconfig command returns the same error message as above.

0

I do not follow the syntax of your question exactly, but if you're asking if the wireless card is enabled in the BIOS set-up, the answer is yes -- that's what I did in accordance with avarionist's final suggestion. It was enabled when I first checked; I disabled it, rebooted normally; re-enabled it; and rebooted normally once again. Still no wireless reception.

0

I am guessing your wireless hardware in malfunctioning because all the required steps you've performed already

Edited by mabbasj: n/a

0

Ok dont know what Flavor your running but hit your favorite package manager up for Network manager. because wicd is finicky.

good example ive got a broadcom 4318 airforce one 54g works under network manager with b43cutter but not under wicd. or try knetwork manager (i think thats kde's net man) if your a kde fan.

0

If you are Using Dell Lap top U Must use dell Wireless software for connecting Wi-Fi ,It u can get in dell Website ...

0

Good to know that. I did get the driver from Dell, in fact. I'm increasingly inclined to believe it's a hardware issue. I've ordered a new wireless card (again, from Dell) and I'll post an update here after I get it installed.

0

Good to know that. I did get the driver from Dell, in fact. I'm increasingly inclined to believe it's a hardware issue. I've ordered a new wireless card (again, from Dell) and I'll post an update here after I get it installed.

almost forgot you could try ndiswrapper(i am assuming your running linux judging from the wicd statement right ?) with the drivers from dell that you download.

i really hope you get it working i feel your frustration.
my broadcom card is absolutely the hardest thing ive ever installed.

0

New card received from Dell; installed. Driver un-installed. Wireless disabled in BIOS, computer re-booted, then wireless re-enabled and computer re-booted again. Driver re-installed. Still no wireless signal, neither in WinXP nor in Linux. At Linus CLI, neither ifconig nor ip link show will list the wlan0.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.