shean1488 -3 Light Poster

Hi everybody

Please help me to configure Tomcat server. I was trying to do a lot of things also search a lot in internet for similar problems but can not find an answer.

So I installed Tomcat and I belive it is running correctly:

root@serg-PORTEGE-Z835:~/Downloads/apache-tomcat-6.0.35/bin# sh version.sh
Using CATALINA_BASE:   /home/serg/Downloads/apache-tomcat-6.0.35
Using CATALINA_HOME:   /home/serg/Downloads/apache-tomcat-6.0.35
Using CATALINA_TMPDIR: /home/serg/Downloads/apache-tomcat-6.0.35/temp
Using JRE_HOME:        /usr/lib/jvm/java-6-openjdk
Using CLASSPATH:       /home/serg/Downloads/apache-tomcat-6.0.35/bin/bootstrap.jar
Server version: Apache Tomcat/6.0.35
Server built:   Nov 28 2011 11:20:06
Server number:  6.0.35.0
OS Name:        Linux
OS Version:     3.0.0-16-generic-pae
Architecture:   i386
JVM Version:    1.6.0_23-b23
JVM Vendor:     Sun Microsystems Inc.

But when I'm trying to do http://localhost:8080/ I'm getting error:

HTTP Status 404 - /

type Status report

message /

description The requested resource (/) is not available.

Apache Tomcat/6.0.35

I even tryed to show some file like http://localhost:8080/index.jsp , but still same error
And my program from eclipse doesn't work also.

Also when I tryed to run my prigram in eclipse I got some INFO and one Warning:
Apr 5, 2012 4:59:33 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:ServletTom' did not find a matching property.

I tried netstat:

root@serg-PORTEGE-Z835:~# netstat -an | grep 8080
tcp        1      0 127.0.0.1:38547         127.0.0.1:8080          CLOSE_WAIT 
tcp6       0      0 :::8080                 :::*                    LISTEN  

But not sure, if it could be a problem.

Please help me to solve this.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.