0

So here's the situation, I can't connect to the internet. Wireless is working, other PC's in the home are working, I can ping the gateway, host names and IP addresses outside of the local network, LAN connection in the bottom right-hand corner is looking normal, ie there is no red cross or yellow triangle. Also, tried other cables and router ports. When I restart the PC, I get internet connectivity for about 2 minutes, then it's gone. Any suggestions please?

3
Contributors
5
Replies
18
Views
4 Years
Discussion Span
Last Post by Cross213
0

Depending on the motherboard, some of these on-board NICs may not be as reliable as other brand names. Hard to say, but what I would try is to remove the device from Device Manager and let Windows rescan for new hardware. It will load the drivers and if you have updated drivers from the vendor, I'd install them at that time. Sometimes when devices behave quirky, this removal/rescan process solves the issue.

If the problem persists, its probably not worth a lot of time and troubleshooting based on the cost of a new network adapter.

0

So you've tried to remove/rescan in Device Manager, update drivers --> No success
You've also tried a different adapter --> No success

You may have some other problem with your Windows installation, you may want to consider re-installing the OS. Sounds like an overkill, but the reaility is that you can have the OS back up and running in a very short amount of time, where you may spends days if not weeks trying to find a solution.

Before you wipe the drive, you may want to test your NIC with another OS. The easiest method is to boot from bootable media (CD or USB) with a Linux OS. This way, you dont touch the OS on your hard drive. While in the Linux environment, if the problem goes away, you know its due to your Windows installation. If hte problem follows the Linux bootable, then you have a hardware problem somewhere.

0

Have you checked Windows Event Viewer for any error messages?

How old is your Router and how many devices are accessing it both via cable and wireless? Some Routers can only cope with a certain amount of devices.

Is it possible that your Router has been limited to a range of addresses? Do you need to increase this?

Have you assigned an IP address to this device that could be in conflict with another device having the same IP address?

Some configure their Routers to allow only recognised MAC addresses, could it be that you need to add this device to the list?

0

Problem is resolved, turned out it was the ISP being problematic. How troublesome I know.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.