0

I am trying to help a customer restore their connectivity to their server.

earlier this week, a power outage wiped out thier servers' internet connection and the connection to 2 computers, I'll call them 1 and 2. We advised them to replace the wireless usb adapter they were using to have internet connectivity on 1, 2, and the server only. Here is the way this is all connected:

the server (windows XP sp3) has a wired connection (.88) that goes to a switch, and allows those computers to connect to the server, no problems there.
the server has a wireless USB adapter (Netgear A6200) coming off of it (.111) that wirelessly connects to the router (Linksys wrt54g)

PC1 (xp as well) has an ip ending in .102, it is wired to the linksys router directly.
PC2 (Windows 7, ip ends in .103) connects to the linksys router.

server, pc1, and pc2 all connect to the internet. I can ping the gateway (router) from all 3. I can ping .102 from .103, and .103 from .102, but I can't ping either .102 or .103 from the server (again, which is .111) and I can't ping .111 from pc 1 or 2. They all connect to the internet, looking at the dhcp client table in the linksys router, all 3 are seen.

I tried to disable the wired connection (.88) from the server, and suddenly server, 1, and 2 worked in harmony, but the switched computers couldn't connect to the database.

There is no authentication turned on the router, no firewall settings blocking anything.

The customer swears this configuration worked before the power outage and replacing the usb adapter coming off the server. I can't figure out why tis is happening.

2
Contributors
6
Replies
19
Views
3 Years
Discussion Span
Last Post by JorgeM
0

Your description is a bit confusing. A network diagram with IPs would be helpful.

I don't understand why you have wired and wireless connections and a computer with both. Doesn't make sense.

0

server's wireless connection connects to 2 back office computers. the IP of the wireless connection is .111 The wifi adapter is a netgear A6200 usb.
the server's wired connection goes to a cisco switch that connects to several other computers in another area, that ip is .88
I don't know why they did it this way, but we are trying to configure remotely and I can't reconnect myself. He says this configuration worked previous to replacing the wireless adapter.

PC1 - .102, connected directly to the linksys

PC2 - .103, connected to the linksys (192.168.1.1)

I can't draw it right now.

I can ping 192.168.1.1 from all 3 computers. I can't successfully ping the server from pc1 or 2, nor can I ping 1 and 2 from the server, but they can all use the internet, so the server is connecting to the router, just not the wired ports off the router.

When I disable the wired (.88) connection on the server, the above problems disappear.

0

Based on your description, the .88 interface should be set up on a different subnet, say 192.168.2.x/24 assuming the hosts on the cicsco switch do not require connectivity to the Linksys router or pc1 or pc2.

The problem that I see is that your win XP computer has two interfaces on the same subnet, but physically they are two different segments. Packets are likely coming in the the .111 interface and leaving out the .88 interface likely because .88 has a higher priority in the routing table or because .88 is configured with a default gateway which is should not be. Only the .111 interface should have a default gateway of 192.168.1.1.

0

Changing the Linksys router to 192.168.2.1 fixed the problem. thank you

0

Glad to hear it resolved your issue. It was evident once you posted a diagram/description that it would be resolved with a slight config change.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.