Re: Connection refused or ports closed problem 80 80

No, the other conf files do not come into play here.

Everything here looks fine. Apache is listening on 80... unless you have 2 separate apache installs or something.

Re: Connection refused or ports closed problem 80 80

I have only one, I wonder why it worked all fine without any problems first day after I opened ports, and then next day it was broken.

Does my dynamic ip have something to do with this problem, or my ISP blocking my ports after they detect some transfer with those ports?

Re: Connection refused or ports closed problem 80 80

ISP is not involved here. We have determined from previous steps that the ISP and router are forwarding packets correctly and that this host is receiving them.

This host is not configured correctly or is serving up a web page not from another application on the same port.

The conf file you sent looks ok, so unless you have other conf files in sites-enabled or elsewhere in the 'include' directories or perhaps a 2nd apache process running, then I am at a loss.

Re: Connection refused or ports closed problem 80 80

Is it possible that other pc which is connected to same router via wireless, uses port 80 like skype or something else.

I will check tomorrow all apps installed there.

Re: Connection refused or ports closed problem 80 80

Well, when we tested by turning off the apache host, nothing answered on port 80. Pretty good indication that it's not another machine.

Re: Connection refused or ports closed problem 80 80

So what else can I do, also I know that this problem occours day after I setup server, for example I made server on Monday, and it worked only till Tuesday, then I reinstalled everything and restarted modem like week after, and again it worked only for one day straight.

Re: Connection refused or ports closed problem 80 80

That makes no sense. Unless something else inside the network is trying to upnp a port on the router automatically but somehow the host is receiving the traffic... ??

Re: Connection refused or ports closed problem 80 80

I don't know what else I can try, I will wait for new modem to arive, and new PC, and if problems continue, it has something to do with either internet provider, or appache itself, but I am not changing anything inside config anyway, and its strange how one day can work and other cant with same setup

Re: Connection refused or ports closed problem 80 80

Is upnp enabled on the router? Try turning it off as a sanity check.
DO you run any virtual hosts on the same server? Perhaps a virtual host is grabbing the port somehow.

Re: Connection refused or ports closed problem 80 80

Click Here This is upnp in my router, and I never changed that.

I turn everything off while running apache, and port 80 is always used by apache

Re: Connection refused or ports closed problem 80 80

Should I setup ipv6 also, I did it only for ipv4

Re: Connection refused or ports closed problem 80 80

I am still looking for answer, thanks in advance.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.19 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.