0

Hello, everyone.

Right now, I'm having a problem with my desktop's internet connection. Whenever I turn it on, I get a message saying "Limited or no connectivity." This has been going on since I tried to fix my System Restore. Here is everything that I did that led up to this issue:

My system restore was not working. Due to a few things I saw on the internet, I had a plan of action. I disabled System Restore, and then rebooted my computer. Before I rebooted, my internet connection was fine.

Upon rebooting, I got a message saying that I had limited or no connectivity on my internet connection. In addition, csrss.exe was now running overtime, taking up 25-50% of the CPU. This has never happened before, so I believe that it may be part of the problem. Other processes I've noted that haven't been running so long is winlogon.exe and System.

I have tried everything I could find to fix the issue. I've flushed the DNS, renewed the IP, even uninstalled the adapter and reinstalled it. Nothing's worked. I know the adapter is not to blame, because it's the same one I have plugged into my laptop (which I am using right now) to connect to the internet, and I know it's not the router, because I'm connected to the same connection I've always used. This problem is extremely annoying, because all of my files are on my desktop.

Thanks in advance for any help.

3
Contributors
6
Replies
7
Views
10 Years
Discussion Span
Last Post by Monte
0

when uninstalling and reinstalling devices, in some cases the settings of the device are still stored on the computer. It seems as if your adapter isn't connecting to the DHCP server address. Go into network connections and check your TCP/IP Properties and ensure that it is infact using DHCP. Paste me your ipconfig information (ipconfig /all) and let me check out your network ips (ip, dns, gateway)

0

Here's what ipconfig /all says:

Windows IP Configuration

Host Name ..... pepe
Primary DNS suffix ........ :
Node Type .......: Hybrid
IP Routing Enabled ......: No
WINS Proxy Enabled......: No

Ethernet Adapter Wireless Network Connection

Connection-specific DNS Suffix .:
Description......: Dell Wireless 1450 Dual-band (802.11a/b/g) USB2.0 Adapter #2
Physical Adress .....: 00-14-A5-30-43-3D
dhcp Enabled.....: Yes
Autoconfiguration Enabled.....: Yes
Autoconfiguration IP Address.....: 169.254.0.14
Subnet Mask.......: 255.255.0.0
Default Gateway ........:


I wasn't sure how to check my TCP/IP settings, though. Thanks for the help.

0

To clarify, any ip starting with 169.*.*.* is an auto configuration IP address which is assigned by Windows when the network adapter can not find a DHCP server. This means it can't find the server that assigns it an IP address on your cable/dsl connection. Follow these steps and it should work flawlessly:

1. Shut all PCs down.

2. Unplug the router.

3. Unplug the modem. Wait a minute or two.

4. Plug the modem back in and wait until all lights are green.

5 .Plug router back in. Wait a minute.

Reboot the PCs, one at a time.

0

In addition to monte's reply...

Also check the Services snap-in and make sure DHCP and DNS client service are started and set to automatic

0

That didn't work, unfortunately. I have no idea what's going on. Is it possible that there's something going on in the computer? I still think it's got something to do with that csrss.exe and winlogon.exe, since they've never used this much CPU before.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.