I always seem to get 0 kbps upload/download on my Bittorrent. It also seems to be unusually slow and gradually slows down over time. It also hangs around for ages finding a port?

Any ideas why it isnt working as I really need it to download a new OS for my laptop as the old one was very outdated.

Recommended Answers

All 16 Replies

>I really need it to download a new OS for my laptop
Most Linux distributions offer HTTP or FTP as an alternative to BitTorrent. Although the servers tend to have a lot of traffic, chances are you can find a mirror close enough to you to make the downloading go speedier.

I need the Alpha version of it and its only available with bittorrent.

Ive shut down my software firewall and it makes no difference.

My router has UpNp and i am behind it using NAT, with IP adresses assigned by DHCP. I think i maybe need to opena port on the router?

You need to make sure that your router isn't blocking WAN requests, and that any requests on ports 6881-6999 are forwarded to your computer's IP address (assigned by your router). Other than that I don't know.

commented: good post - like the new pic +12

hmm i enabled port forwarding to that range. It works now but is very slow. I think my router is doing something to make sure i dont take up all the bandwidth ;(

I know some ISPs will block or bog down torrent connections.

commented: thanks +12

mine probably does then. i know it blocks incoming ftp, ssh and http so maybe you are right.

Your router is causing the issue.
BitTorrent opens ports on your machine and listens for connections from peers/seeders.

You're looking to use, not the offical BitTorrent client, but something like BitLord or BitComet. (stay away from Azureus).

So if your trying to torrent, you're going to experience slow speeds and intermittent performance, as the router is blocking 90% of the ports the Torrent client is wanting to open/use.

Temp Fix.. Don't use router for Torrenting.

commented: thanks, tried it but to no avail :( why stay away from azerous anyway? +12

no, i tried direct connection to the modem. I think its my ISP. :(

ill just have to do it round my friends house ;)

If all ports needed are open and forwarding and the problem is still present, I say the ISP is blocking or bogging it.

Sounds about right, i was unaware that you tried a direct connection.

Jbnnnet, have you tried to make the outgoing port be 80 (which is always unblocked, because it's the port normal web traffic is moved on) and the outgoing be something like 27960 (which is used for quake 3, be creative, because that may not work) for outgoing?

yeah, i checked the terms of service of my ISP. They block all ports apart from mail, web and ftp (outgoing, all incoming is banned) :( i suppose thats to stop people abusing it (im on the top speed so i suppose they would have to do that or else people would all start running servers)

Have you tried downloading it at work or school, using their network?

cant, they have filters to :(

the distro i want gets released in like 12 days so i may just wait and order myself a cd for a few £

WarDriving time folks ~

Azureus is a good client but it opens too many listening ports.. specially with public tracker.

I used Bit torrent in this scenario and its look good for up/down spead concers.

Bxperts

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.