0

Well first off ima newb... =) i came across your forums while surfing for a solution for my dead laptop issue and your site seemed promising. the laptop is a 4 year old compaq presario 2100 and from what i understand just stopped working one day about a year ago.

the laptop was given to me so i do not know its past. the prob im having is i plug the charger in and the light on the front turns amber as if its charging. once you turn the power button on the amber light goes off. oh also the machine dosnt make any sounds and the hard-drive dosnt spin. its like no power is getting into it. i had the battery and the charger tested and they both were fine according to the man. however they wanted like 100 bucks to go inside and troubleshoot the machine. maybe its cause ima girl i dunno but it seemed steep to me.

i tried to remove partial ram to see if it was that but it still was a no go. i also tried a few other things like reset and hold the power button for 30 seconds with no charger or battery and vice versa. my friend at radio shack said he will check it out for 25 bucks but he is really busy and im really impatient =P so if anyone can give me some pointers or info maybe i can fix it on my own.

4
Contributors
4
Replies
5
Views
9 Years
Discussion Span
Last Post by caperjack
0

Battery should not be a problem. If it is plugged with the charger, it should work, even if battery is dead.
Check the mainboard.

0

It sounds like you have a bad motherboard, in which case you can try to get a new one from the manufacturer, but you're probably better off just using it for parts.

0

ty so much for response. that was what i was afraid of. i guess you cant expect much for free =)

0

Free is good!! sometimes,$100.00 is not bad if they actuall fix it for that ,and that 100 dollars isn't just for looking and then the bill gets bigger and bigger . .anyway it stopped working a year ago for a reason ,hard to jump to conclusions with out having it front of me!,did you try starting it with the battery out ,just use the power cord .also did you leave it plugged in overnight to charge and then try it .if i had it here i would take out the hard drive and try booting it without it in.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.