0

I can't, for the life of me, figure this one out. I have a 2 1/2 year old Gateway PC, which I just upgraded the RAM on. First I went from 1GB to 2GB, which was fine. Then, a few weeks later, I upped again to 4GB. This is when I lost my sound.

Everything else worked fine, but my PC went mute. I found that it was fine when I used the front headphone jack, but the rear speaker output was a no-go. And to make things even more confusing, the rear line-in jack suddenly changed itself into the speaker out, and the mic ports stopped working completely! I checked the sound settings, and even the device listings were different.

When I took the newer 2 GB out, it was fine again. I thought maybe this was a Vista problem, and I was getting fed up with Vista anyway, so I blasted it and installed Ubuntu 9.04. I found I had the same exact problem with the sound, so I know it's a hardware problem, not software. Also, I took turns with the two RAM modules, just to see if one was faulty, but they both worked fine on their own. They just don't play nice in the sandbox!

Has anyone else come across this? I've Googled the hell out of it, with no results.

2
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by Josh Connerty
0

Wich version of Vista and Ubuntu did you install x86 or x64? (32 bit or 64 bit)

If they were 32bit versions then you are likely to come across issues like this as the 32bit architecture can not utilise the full 4GB it is advised to use a 64 bit version of any operating system to accept more then the 3GB of RAM.

The other thing I was going to ask is do you know the Manafacturer and Model of your motherboard as this may be the motherboard not supporting the 4GB of RAM.

0

I found a workaround in the meantime, by putting in an old sound card I've had sitting around and disabling the onboard sound from BIOS.

Both OS's are 32-bit versions, and my MoBo can supposedly take at least 8GB of RAM. But I'll have to double check, since I'm going by memory, and my memory is awful! (Do they sell RAM upgrades for humans??)

And, you're right, although I do have things working okay, my OS is only displaying 3GB of the RAM.

0

Try putting the sound card back in (the one you had the problem with) and clear your CMOS. This may help your system identify the two together.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.