0

i have a vgn-fe25gp and developed this problem yesterday after updating the VAIO Event Service to Ver.2.3.00.05310 from version 2.2.01.11040, which came preinstalled on the laptop.

i uninstalled this program from add/remove programs, and then reinstalled version 2.2.01.11040 from the system recovery dvd i had previosuly made, and this resolved the problem.

hope this helps others.:p

0

just keep trying... in my case i had to upload the drivers and updates many times, and another guy who asked me for help did the same thing and no he could resolver the problem as me.

good luck and be patient.

0

Wow, you silly silly person..Well I read all of that, tried all of that, I have a new sony vaio FJ series laptop, and my FN keys do not work. I am bringing this in to sony, either for an answer or a refund, lol

0

:p Simple Solution:p

Go to the Sony website of your relevent country.
Go to Support
And then to the Drivers page

somewhere along the way you will have to enter your vaio's model\serial no., etc.

Then look for PREINSTALLED UTILITIES

download the PREINSTALLED utilities and install all of them (they should all be included in one zipped folder)
I am not sure which one fixes the problem
I had 11 to install

I hope this helps. I have been trying to fix this for about 2 hours and this finally did the trick. It may be different for other countries but this is how the UK sony site works.

I have a VGN-FS415M by the way

Good luck

0

I have PC vaio PCG-R505GC.
My PC loss all hotkey so can not use the Jog dial also, My PC' supply disks were damaged,
Where can i get : 1/ Sony Utilities Dll, 2/ Hotkeyutility, 3/ Sony shared libary
What can i do now?
Please help me! :sad:

0

I posted this in the other fn key thread but figure i would put it here too.

I have the same problem...my fn keys do not work on my VGN-FS640/W and unlick you I am unable to get the hkserv.exe process to run.

I installed the Sony Shared Library then the Sony Utils and lastly the Hotkey Utility which installed the hkserv.exe and hkwnd.exe files in \program files\sony\hotkey utility.

But when I double click the hkserv.exe file all I get is an hour glass for a second and then nothing. The task manager shows the process is not running. I have local administrator rights and stopped hkcmd.exe from running thinking it might be preventing hkserv.exe from starting.

Any ideas? I would really like to get these fn keys working without having to reinstall my operating system and lose all my data and installed programs.

Also, the microsoft intellitype software was installed and would activate a favorite key wizard when trying to use the fn keys so I know they work. I removed the software hoping the fn keys would work but they still do not. I can turn on scroll lock but not adjust the brightness, sounds, or external video.

I have tried everything posted thus far and am quite stumped and disappointed in SONY for letting a bug like this get by them without publishing some sort of official fix besides "buy our restore dvd and restore your computer"

0

go to sony.com, and then to support and u have to select your pc model, then u go to drivers and software and look for the things u wanna.

0

I have bought a VAIO VGN-tx50b/b and the problem started when I installed windows xp professional and now I dont have the drivers for ethernet, red, usb device and modem device on high definition can someone help me to find this drivers pleaaaaasssssseeeeeeee

0

Hi Guys,
I just bought a new VAIO VGN-S55B with Japanese OS. Now, I want to install English OS but I am afraid that the hothey will not work as you have experienced. I can make backup disks before I format my JP-OS. Could someone please help me how to fix the hotkey problem before I reinstall my computer hic hic hic....
Thanks in advance!

0

Hi ,I've spent a lot of time with this problem ,but I fixed it already ..Visit my site and follow the instruction ..Please let me know if you will be successful,send me a message which model you fixed..Good luck everyone ....

http://www.djvagon.co.uk/sonyhotkeyutility.html

VAGON

i've just registered to thank you, Vagon! Best solution for dummies like me

0

I have a Sony Vaio laptop. My keyboard problem is that when I use the "t" key the cursor jumps to another spot, it happens most notably with Word but it has also happened in my email but it doesn't happen all the time and it is not happening as I type this. I don't know if it is a keyboard malfunction or a software problem.

Anyone else have a similar problem or ideas how to fix it.
Thanks.

0

Hi Vartotojas,

Thank you so much for your help. I have a VAIO laptop FJ180P and after downloading an iexplorer fix, the FN keys stopped working altogether. Following your instructions, I downloaded the BIOS files and the Utilities files, rebooted and Voila, my FN keys were working again. I have registered just to be able to thank you. You rock!

:)

Ooh, you're all very silly. You silly, silly people.

Just kidding. It just so happens that I have the knowledge you desire. So here we go, kids.

THE NOT-SO-OFFICIAL OVERLY LONG POST ON GETTING YOUR KEYBOARD TO WORK ON A SONY VAIO LAPTOP.

To begin with, on more recent sony laptops (such as the VGN FS line), the service is called 'hkcmd' or something to that effect. So if you are using a sony-made computer, and your hotkeys (like 'Fn' or the 'S1' and 'S2' keys) are working, and you go into the 'Processes' section of the Windows task manager, and you see 'hkserv' or 'hksrv' or 'hkcmd' or any of those in uppercase, it means your hot keys are functioning well and good and fine and everything will be okay, and you can sit back and enjoy a chocolate milkshake at your kitchen table while sifting through your mail or reading the newspaper and everything will be alright.

But there can be problems. Yes indeed. And if you are having problems, read on.

There are two kinds of problems which crop up on Sony Vaio Laptops, one where your computer's hotkeys simply aren't working. Another, which I discovered while visiting a friend's house, is that they have the tendency to make it so occasionally when you type some letters, they come out like numbers, or numbers come out the wrong way, and all that such. Both of these problems are covered in this post.

POSSIBLE PROBLEM #1- I'm using a Sony Computer, and for some reason, my hot keys aren't working, or I don't have the driver for them installed. How do I fix that? (A driver is the software necessary for your computer to be able to 'understand' or 'communicate' with the hardware attached to it.)

LONG, LONG, ANSWER.
If at any point in this answer, you feel that you can 'take it from here' than by all means do so. A lot of this guide is just walking through the process step-by-step and explaining stuff along the way.

You can get the driver for making your hotkeys work by going to
http://esupport.sony.com/perl/select-system.pl?PRODTYPE=24&NAVDISP=pc and entering in your model number, so you can access sony driver downloads, user guides, Frequently asked questions, technical specs, product alerts, and other stuff about your laptop.

Most of you people already seem to have cleverly decided to figure out your series and model number before asking for help, so you probably won't need to download the 'detect my model' thing, and you can skip the rest of this paragraph. If you don't know your model number, you can find it out by downloading their program, or, if you still have your 'vaio control center' on your computer (which is, don't worry, a helpful thing), you can just go to that. Now I'm not sure how older versions of this were designed, but in mine, you can just click the 'system information' category, and click the little gear icon with 'system information' next to it. And under 'Product information' and 'Model' will be your series and model. Select that on the esupport.sony.com website using their dropdown menus or such.

Anyway, to get the sony-specific drivers for your computer, or for your hotkeys in general, click the 'Drivers/Software' tab on their page. From there you can get the drivers which came with your computer, drivers which are updates for the ones you already had, or get all the drivers ever for that computer in one 'everything' list page.

Windows can typically use your laptop fine without your manufacturers drivers on it, but it greatly helps to have the actual drivers and hardware management programs which came with the computer, as that usually allows you much greater control and ease-of-use when it comes to using your computer, and much less bugs and errors. So if you erased your computer and reinstalled windows or something, or if you updated to XP from an earlier version (such as with the PCG-FX case listed in this thread) now would be a good opportunity to download all of the drivers. Sony will have a guide on doing that, and plaease do so.

Specifically, if your computer came with something earlier than windows xp, Sony will have a specific page on there for drivers for people who upgraded to windows xp. Sony will have a guide to help you along with this, I don't need to tell you about it, the instructions exist, follow them as if they were the bible, the Qu'ran, and the sacred scrolls of Boshmop the great all put together. In other words, if you updated to, or reinstalled windows, stop reading this post, go to Sony's page for downloading drivers for your computer, and read sony's instructions for 'Windows XP Clean Install' and listen to them.

If you've gotten to this point, it means that:
-You are still using your computer with the Operating System it came with. You did not update to windows, nor did you reformat your computer and reinstall windows via a Windows XP install disk. You're using the computer the way it came.
-Yet for some your hotkeys are NOT working.
If either of these are not true, reread the above half of this post, because you must have missed something.

Anyway, here's how to get the driver for your hotkeys: Now, remember, if you upgraded to windows xp, go to the 'OS migration' page, if not, go to the 'everything' page, and find the ORIGINAL driver that came with the computer for hotkeys, and then the UPDATED version if there is one. The drivers will normally not be specifically called 'Sony Hotkeys' but rather, they will be under a more general, wider-ranging driver, such as 'Sony Shared Library'. If there is a 'Notebook Control Device Driver', than get that instead, because we are assuming that you already have the sony shared library, because we are assuming you did not install windows from scratch or pointlessly delete a bunch of your files. If you are pretty sure that for one of these reasons you do not have the sony shared library, get that first and install that first, and then install any 'Notebook Control' drivers.

After you're done with all of this, restart your computer (if you haven't already) and try your hotkeys out.

Alright??? Are we good? Are we good? We're good? Good!

POSSIBLE PROBLEM #2- I'm using the normal keyboard that's part of my laptop, but whenever I try to type on the right side of my keyboard, (or sometimes) the letter that should come out on the screen (such as 'm') is not there, and instead there's something different! (Like 0 for 'm', or 2 for 'k', or 3 for 'j') I've tried installing new drivers and other stuff, and it's still not working! WHAT'S GOING ON???

ANSWER!
Here's yer problem, buddy. Your computer thinks you have the 'Fn' key (otherwise known as the function key) held down right now, even though you don't! You can tell that this is the problem if the letters/numbers which come out on the screen are the ones which are noted on the lower part of the keys you're pressing. And you'll notice that if you actually hold down the 'Fn' key, your computer's keyboard acts as it normally does.

So why does the computer think the 'Fn' key is being held down, even when it's not? Because you have 'Num Lock' on! When you have the 'Num Lock' key on, your computer perpetually thinks that the Fn key is held down.

Here's how to turn 'Num Lk' off if you want your keyboard acting normal again: hold 'Fn' and hit the 'Num Lk' button. (You have to hold Fn while doing this, because otherwise, the computer would think you were trying to press 'Scr Lk', or scroll lock. I don't know the layout of every keyboard of every computer sony has ever made, so it might be different for you.), after that, everything should work normal again. For some reason, Sony Vaio laptops, on the rare occasion turn their 'num lock' on by themselves. It's easy as it can be to turn it back off, it's just that it can be very confusing for someone who doesn't understand the problem.

Alright! We all good? Thanks. Awesome. I gotta fly.

*Vartotojas jumps into a small electric-blue-colored skycar. He flips the top over his head and onto the front, and presses the big green 'AGOGO!' button in the center of the dashboard, which then results in a large "ding dong!" sound. His ship lifts up for a second, hovers, and then vanishes into the endless intracacies of time and space. Left behind is but a vapor trail of light-gray fog, which soon dissapates.*

0

well i have vgn-fj170....this has been happening to me for about 2 months, i was so sick of it that i reformatted my whole computer...lost all data, yet still had the same problem. ive tried a countless number of things...i even used the 3 step method one of hte posters recommended...that didnt work! right now im reinstalling the original drivers that cme with my laptop...im gonna install the ones that have to do with the utilities dll....i dont know if itll work!

please PLEASE PLEASE HELP.

0

Hi ,I've spent a lot of time with this problem ,but I fixed it already ..Visit my site and follow the instruction ..Please let me know if you will be successful,send me a message which model you fixed..Good luck everyone ....

http://www.djvagon.co.uk/sonyhotkeyutility.html

VAGON

I have a PCG-Z1VGP and I actually never thought my function keys would work again. My function keys work perfectly now. I can't thank you enough for this tip.

0

Thank you for your information on loading the hotkey driver.
Unfortunately Sony did not recognise my model number which is PCG-N505SN. They offer me PCG-N505 with VE or VX or X after it.
Is there any way I can decide which of these will have the correct hotkeys driver for my old Vaio?

0

I have tried everything from every forum but was not able to make it work. I have found one simple thing that fixed my problem. My laptop model is sony vaio fs742/w

Vaio event service was not running. I went to start-run and typed in msconfig- under services i placed a check mark against "vaio event Service" and rebooted.

Hope this helps

I too signed up just to thank this poster! In my case (Sony VGN-FS660) the process was running and I was experiencing these problems suddenly ... I just stopped and restarted the service and the Fn key worked again! Thank you!

0

Hi ,I've spent a lot of time with this problem ,but I fixed it already ..Visit my site and follow the instruction ..Please let me know if you will be successful,send me a message which model you fixed..Good luck everyone ....

http://www.djvagon.co.uk/sonyhotkeyutility.html

VAGON

Works for me! Add me to the list of people who registered just to thank vagon

PCG-V505GTP purchased in Taiwan (I can't believe I am still using the same laptop over 3.5 years later)

I used the setup files on my recovery disk (disk 3, SONY folder) and installed things in this order:
-HotKey folder
-Utilities DLL folder
-Sony Shared Library folder
and then restarted. So I'm not sure if order matters. (I wasn't deliberately going against vagon's recommendations, but I'd already installed the HotKey apps and Utilities before reading the post.)

0

Thanks for the post including those three apps.
I have NEARLY the same problem ( mine is a PCG-881M 3/4 years old second hand) My Fn key works fine, as do the F keys, but for no reason at all ( often when on Yahoo) about half the keys start to type not only different symbols, but often 2 or even 3 instead( exampe the word "Tigger" comes out as "st.ighgh.e9r". Sometimes the space bar gives a + sign. for three weeks after my last re-format everything was perfect, then all at once---grrrr!

I installed the three apps as advised in the post, but the last one only showed a progress bar for about 5 seconds-part way- then it seemed to close.Not sure if this is normal behaviour?
Am running XP Pro with SP2. I have never discovered what the roller and button at the side are supposed to do. Should these actually serve some purpose? Is the problem connected?
Anyone suggest any more ideas( i. e. IF I can install a new keyboard will that cure the problem or not?) Parts are virtually impossible as the machine came from UK and where I live the agents won't touch it because it "was not bought here". Help anyone?? ( pleeeeese!)

0

Hi, I join the list of people who registered just to thank vagon

I spent so much time trying to make the hotkeys work!!!!! im sooooo happy thanx so much.. it worked exactly as you said!!!!!

by the way my lap model is PCG-Z1FP

0

My problem was that when I reinstalled windows on my laptop I didnt use the recovery disk but I used an XP pro disk instead, this rendered the function keys useless.

I spent months trying to find the function key drivers for my pcg-k115s and I am pleased to tell you that I have found them eventually on the Sony site, they were well hidden, I have the file if anyone should want me to share it with them or can someone give me a url to upload the file to. Please email me should you want these drivers cruella133@hotmail.com

0

I have a Sony VGN-C15GP, and the function keys stopped working randomly one day. I tried downloading SonyUtils_Hotkey_10_ENG.zip from ftp://ftp.vaio-link.com/pub/Vaio/Hotkey. However, once I unzipped the file and ran all the setup programs, HKServ.exe still didn't appear in the task manager. Instead a similarly named program was running, but didn't fix my problem.

I simply restarted my computer and the function keys worked again. I had tried restarting before running the setups but nothing had happened. Bizarre - maybe it will work for others?

0

Hi ,I've spent a lot of time with this problem ,but I fixed it already ..Visit my site and follow the instruction ..Please let me know if you will be successful,send me a message which model you fixed..Good luck everyone ....

http://www.djvagon.co.uk/sonyhotkeyutility.html

VAGON

Dear Vagon,

It worked for me, thanks to your message. This time supposing there is something out there, I only wasted 2-3 hours with the offical Vaio CD support. My FN key now works, my laptop is a PCG-Z1XSP.

Great, thanks again
BR

Alex Matthey

0

Hi everyone,
I have the same problem with some persons here. Funtion key of my notbook VAIO PCG-661N is not working. I have try but i dont know how to fix this. Could anybody who have more experient give me suggesiton?

Thanks
Andy

0

I have a VAIO VGN-FJ270 and my Fn keys no longer worked once I got my laptop back after getting it fixed. I've been reading several of the posts in this thread, downloading and re-installing several drivers, but nothing seems to work--I'm not super great with computers, so maybe I'm just making a really simple mistake that is causing all this headache. Any suggestions for my specific model or anything else I can possibly try that doesn't involve having to take it in somewhere? Thank you!

0

I don't know if anyone has noticed, but you should not have the numlock light on, on a laptop, unless you want to use the keyboard as a numpad

0

I had the same problem with my Sony VAIO VGN FS640/W and I was finally able to find a quick fix for the problem. To begin with my computer got hit with a virus that turned off all of the services YUKK! I had to figure out what services to start in order to make my system work properly. I then decided to leave all of the Sony VAIO services turned off (I didn't know what they did and they took up memory BIG MISTAKE!). Anyway, you need to first make sure that the VAIO Event Service is running.

Click Start, right click My Computer, select Manage, click Services and Applications, click Services and look for VAIO Event Service. Is it enabled and started? If not, click it, select Automatic for the start up type and then start the service. VOILA, my Fn keys started working again. Do this before you even try downloading drivers, reinstalling Event Service, etc. If the service is already set to automatic and it is started, then try drivers, etc. But do this first!!!

When the Event Service is started, it starts VESMgr.exe which is in the Program Files > Sony >VAIO Event Service folder. Before you do the above steps, you can use Task Manager or Process Explorer to see if it is currently running. Since it is automatically started as a service, you won't see it listed as a start up program if you use MSCONFIG to show the programs that load during start up.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.