0

Recently I was contacted to service a family member's computer as it was faulty. I was hoping the cause of the fault would be fairly obvious. I've serviced a number of PCs over the years and usually found it to be relatively easy, or at least the problem would present itself more clearly over time and a few tests...

I'm in the testing stage at the moment. The problem comes apparent during games when the computer will return to the desktop suddenly, hang [freeze completely], or reboot. These things seem to happen without any particular reason - as in... It's never when the system is stressed or has much to do. Yes the game 'War of the Rings' is using system resources, but when the error occurs there's generally not much going on in the game - and it can be okay sometimes for over an hour!

The very first area I looked into was the system heat. But the system has been fitted with fantastic fan cooling which keeps the processor at around 40 degrees C and the system at about 30 degrees C. I know these to be perfectly normal, and optimum temperature ranges.

So then I decided to replace the system RAM; and used my own RAM since the systems are so very similar. My RAM is a bit more branded and I love it dearly so I was confident it would work fine. But alas, there were still crashes. The game ran perfectly for 20 minutes and then the game returned the desktop suddenly... Rebooted the machine and started the game again and it ran for over an hour...

I then put the old RAM in and took the computer home with me and ran a program to test the ram called memtest86... This actually found an a single error during the forth test on the initial pass. On the second pass the error did not reoccur.

I then swapped the RAM in the machines, so now the test machine has my known good RAM and my own machine has the test machine's RAM.

I then decided to run more diagnostic tools, and ran 3DMark 2003... This ran through most the tests fine... But then crashed on the ragtroll; it just hang and forced a power-off. I ran it three times afterwards, same result each time.

Right now I think it could be the motherboard, or the graphics card. I'm ruling out the RAM in all honesty... I know memtest86 had that error, but I'm thinking that perhaps the Motherboard's bus could have an error, and not the RAM itself. I will run more tests on the test machine's RAM whilst it's in my machine - I will run memtest86 whilst I'm asleep, I'm confident the tests will run fine.

So now I guess I'll try drivers and software stuff...

I was wondering... Why Ragtroll in particular? Someone else had a post saying the system would crash during Ragtroll... Read it here . That person had to replace their CPU. I've never had to replace a CPU due to intermittent errors. I've always found a processor is either dead or alive, and nothing in-between.

Any advice or help apperciated :)

--
Also note:
I ran 3DMark with the test machine's RAM on my computer, and it actually ran through all of Ragtrolls perfectly - allbeit a bit slow :-S!

Whlist running a CPU check utility I recieved an access violation error.

I saw a drawing error when running the second CPU test in 3DMark 2003.

So... CPU/Motherboard/Graphics card???

2
Contributors
5
Replies
6
Views
11 Years
Discussion Span
Last Post by J_Search
0

Yeah update on the situation; I've now switched the graphics card and reinstalled the nvidia drivers on both machines. Then I ran 3DMark 2003 on both of them. My machine with the test machine's graphics card worked fine and I ran all the tests. The test machine with my graphics card crashed and rebooted.

So... I might try switching the PSU's and see if that gets me anywhere. Just to rule out any power problems. But at the moment I'm looking at it being the motherboard, if I'm wrong then it'll be the processor.

0

I don't think it's a software issue, it's occured on two different operating systems in a multitude of games. It also reboots and returns straight to windows during running games... I've even now had it reboot suddenly whilst just in windows. Given these facts; I'd say it's unlikely to be a driver problem.

I've now replaced the motherboard; taking a big chance on it might being the CPU.

Still get problems... And I feel I know what they are... I think it's referencing the wrong memory somehow, losing bits in its address - asking for memory that doesn't have the right information or none at all. And perhaps some other errors. I've ruled out the Motherboard BUS itself by changing the motherboard, just switching the RAM and trying different slots at the moment. But this all doesn't sound too healthy :-S

0

tentuxius,

No, but good effort though. Well you said you swapped the memory, so what's left? Only you know what you've done. I would run a diagnostic utility (outside of windows) to check the stability of the ram.

J_

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.