I Have a Packard Bell Imedia 2215. I have been running this with 2X1gb RAM for the past 2 years when all of a sudden I had the blue screen of death. I had a computer expert come out and told me that it had blown one of the RAM. He got the computer working again but only with 1gb as we had no replacement memory. Since then I have bought 2X2gb RAM to upgrade it, however, this is where I have lost it! If I put both 2gb sticks in it will not start (no BIOS beep). If I put 1X2gb and 1X1gb in it will not start either. If I put the 1gb stick in either slot (it has 2) then it will start. I then bought another 1gb stick to put in as before with the eisting 1gb stick, however when I put these in together to make 2gb in total I get the blue screen again. So in summary 2X1gb produces blue screen, 1X1gb works, any other combination it does not work at all. I have checked the RAM is all of the same type etc so should be fine. I have checked the maximum RAM allowable and this should be 4gb so no issues there.
I am at a total loss, if anyone has any suggestions I would be grateful to hear them. Be gentle I am not that technical! Thanks Mark.

What type and speed ram did you get? It will be on the labels on the sticks.

the 2gb was kingston pc2 5300 667 and the 1gb was samsung pc2 5300 667. I also bought a 2gb from pc world the same spec as above (their own brand) which was one of the ones that didnt work, but have taken this back today and got a refund.

Do the sticks have their ras to cas timings on them? Should be 4 numbers with a dash in between each. Example 2-3-3-5.

I do not see anything like the numbers you suggest. Anything else that might help?

What version of windows are you using on it?

Does it boot as far as to get into the POST (power-on self test) so you can access the BIOS settings when you have either 2gb or 2x1gb sticks installed (when you get the BSOD)? If so, then go into the BIOS and set it for full self-test, and verbose mode so you can see if there are any errors. If that works OK and you get no errors, then boot a memtest86 disc and run a full scan of the memory. If that succeeds, then there is something wrong with Windows and this memory. If not, then you will at least get some diagnostics as to what is wrong with the memory (hopefully).

Here is a link to memtest86 if it isn't already on your system: http://www.memtest86.com/

Hi both,
thank you for your interest.
Rik, I am using vista.
Rubberman, no it does not go as far as POST (as i understand it). I powers on, fan goes on, black screen, no chance of getting into bios etc.
Thinking of beating it with a hammer or throwing it through the window....I hate packard bellat the moment lol

How many RAM slots does your system have? If 4 or more, in which slots did you install the RAM sticks?

Remove the motherboard battery for a couple of minutes then place it back again. Make sure to have the main power off and hit the power button to allow any power in the caps to discharge.
Touch one hand to the case (to earth yourself) to prevent a static discharge that may damage electronic parts.
Power back up again and see what happens.

In answer to the above & update.
The machine has 2 slots and I installed it in both slots.
I took out the battery, left it for half an hour put it back in ...now when i switch it on the fan goes at full pelt, it beeps once to go to POST (believe thats the tecky word) then i get 3 fast beeps then nothing...just a black screen and the fan whizzing round.

Any other suggestions as now it is worse than it was before?

The three beeps are a code, which you need to check with the manufacturer for what they may mean. It's possible that one of the slots has a problem. Check for anything like detritus that may be sitting in the bottom of the slot that may be either interfering with the card making full contact, or if metal may be shorting out a couple of pins. Sometimes, blowing out the slot with compressed air can remove such, but sometimes they get lodged there in the process of seating the SIMM. If such is the case, then you may need to get a pick or something to prise it out. Anyway, it's possibly worth a check.

OK I have cleaned the slots and pt one stick in. I can now get to the CMOS set up utility (the fan is still running overtime). What should i do from here to test or set up the bios etc? On start up it shows mouse not found, CMOS checksum bad CMOS date/time not set press F2 to run set up. When i press f2 get blue screen with options but do not know what to do!

Have you tried to download and install an updated BIOS? Also, it may be that the CMOS backup battery has died - that's one of those round wafer batteries, that should be on the motherboard somewhere. You will lose your CMOS settings if the battery has run down, which will happen after a few years.

Hi Rubberman, I cannot download anything as I cannot get the computer running to get on the internet. Also I took out the battery as someone suggested and put it back in again (see earlier post) and this mad the computer worse so the battey must be working otherwise there would have been no difference i guess? I am now stuck on the blue bios F2 screen and need help from here. Any iseas appreciated.

If the battery is dying, then just pulling and putting it back is not likely to help. You need to replace it with a new one, and then do whatever the manufacturer says to reset the BIOS to its default settings.

What you need to do is go into the bios setup and set the time and date correctly. You then need to look for a section called Boot or Boot Options or Startup Options. What it's called will depend on what type of bios you have.

It's usually best to set the CD/DVD to first and the hard drive to second.

If you need any further help then I will need to know the make and model of your computer.

Ok I have gone into CMOS set up and tried to adjust the date and time. It will let me adjust the time, the year and the month but when i try to adjust the date it will only go up until the 12th (not much help being the 20th lol). for some reason it will not go past 12. I did note below that it states primary IDE master and primary IDE slave are not detected.
Make is Packard Bell, model is imedia 2215. Intel celeron E1200@1.6ghz. FSB 800MHz extended memory 1024mb base memory 640kb BIOS version PBDV10.P17 Bios release date 04/08/08.

Is this any help?

Doh just realised that the reason for the 12th may be the month is first ! will try again.

Right I have set the date an time in Bios and the computer worked. I have now put another stick of 1gbRAM in as before and this now works. I am really confused by this (but thankful that it is working). I am worried to death that the fix is only temporary as there seems no reason for the sudden not working/working? Will just back everything up in, and see how it goes. Thank you all very much for your help/ideas. If you think of anything that I may need to test / check following this problem then please let me know, otherwise I will close this thread off.Thank you once again, Mark.

Removal of the motherboard battery has allowed the bios to detect the newly installed RAM and set all the RAM timing parameters correctly.
You should not have any further problems.

Its mean your new ram's permeter not good and check the ram and put it in correct way