0

Alright, so I've spent nearly a week trying to solve this problem with almost no success. I need some third party input before I continue with my plans for this drive. So here's the story.

I have a Seagate FreeAgent 2TB external hard drive, I filled it about halfway with data, important data, which I REALLY need to save. No joke. The external was on the ground and someone accidentally stepped on the usb cord, which broke the input into the external. Having already broken one like this before, I did what I did before. I took the HDD out and hooked it to the computer, the problem was that it showed up as RAW format. It worked fine, now it's RAW and asking me to reformat. So I spent several days using Photorec to recover the files, which barley recovered anything. I tried several other programs to no avail. Once it asked me to reinitialize the HDD, probably my biggest mistake, as after doing that in windows the drive shows up as "Unallocated Space" and I can't used tools such as Redcuva or NTFS Undelete to recover it, because I can't select the HDD and in linux it says it doesn't support the GUID File System.

I really need to save this data on the external and I was thinking of creating an NTFS partition on the external and trying to use RECUVA or NTFS Undelete to try to recover the data, or even iCare Data Recovery or EASEUS Data Recovery.

Anyone got any input on this? What's the best course of action to ensure I can successfully recover all my data?

Thanks,
PcPro12

4
Contributors
3
Replies
5
Views
6 Years
Discussion Span
Last Post by rahimhd
0

Have you tried running chkdsk on the volume? Or does Windows not see the partitions? What does it look like when you run the disk manager tool?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.