this has been bothering me forever,
whenever i open a game,

ex: madden 07, age of empires, cs:source...etc

my mouse flickers/blinks when i move it.

when i dont move my cursor, i cant see anything
but when i do move my mouse, the cursor on the
screen flickers and it looks like theres a little square
around it when i move it.

this only happens during games
and nothing happens when im doing stuff outside of games



Your cursor image library might be corrupt or nonexistant; try downloading a (regular) cursor set and see if it changes anything...

Another possibility is that there's something wrong with your video card drivers. Consider reinstalling/updating them.

Hey Joe, thanks for all the help.

However, I've tried updating my video card drivers with every update that has come out with nvidia, but with no luck. I have also tried downloading a regular cursor set... but I cannot seem to find a "normal" or "regular"
one, even from microsoft itself =-/.

If it is any help at all, the cursor blinks (just as the original poster described) only during games which use 3d accelerators and that cannot be played in windowed mode. (I.E. it blinks during Fury, Battlefield 2, and Universe at War: Earth Assault, but not during Everquest 2, Warcraft 3: TFT, or Bioshock)

Although Bioshock doesn't fit the bill (thought i stumbled onto an answer there, shucks) There seems to be a trend with what makes cursors blink.

If you have any sources with normal cursor sets please let all of us with this problem know! =)

Also, here's my specs (in case that will help)

Windows XP home edition.
1gb Ram
Intel Viiv dual core 3.0ghz processor
creative x-fi soundblaster
nvidia GeForce 7900gs (recent driver as of Dec 29 2007) (it's the stock video card that comes with the Dell xps series)

Hope this helps! Thanks again

I realize that this thread is an old thread but I am posting here incase other people have the same problem and find this by searching. I tried the whole driver and cursor image thing. Didn't work. Thought my card was going bad.
Finally went into display properties ->Settings -> Advanced -> Troubleshoot and there it was. Hardware Acceleration
It was set one rung lower then full, disabling Cursor and Bitmap accelerations. I set it up to full acceleration and then hopped onto warhammer online. It runs like a dream now. No cursor/ mouse flickering in sight. I soooooo want to kick myself for not finding that sooner.

This happens because the game is using so much of the CPU time that the mouse pointer doesn't get refreshed often enough.

In some games you can toggle an option between software rendering the mouse and hardware rendering it. For some people this helps.

Member Avatar for Michael_49

Disable mouse trails in Control Panel.

Try to run ur games in window fullscreens

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.