I have Lotus 1-2-3 for Macintosh Version 1.0 that I originally used on an LC II, then a Performa with O S Systems 7.6,8.0,8.1,8.5 and finally 9.0. My first problem occurred when my desktop icon for Lotus would not open Lotus, that is it would not launch, Lotus 1-2-3 would flash across the top of window but no spread sheet would appear. I was able to launch Lotus by going to my files and opening an old Lotus spread sheet. This worked for probably a year, but now I can't get Lotus to launch except from an old Zip disk where I backed up my Lotus files a couple of years ago. The program works fine once it is launced but what have I done to make it behave this way. The original program is on floppies and uses an expander from 1992 or 1993. Anyone else have this kind of problem? How did you solve? Or did you just go on to Excel or some other spreadsheet?

Discovered that I was trying to launch from a copy of Lotus on an external hard drive. Have now gone to original program and Lotus operates just fine in OS 9.0..But now have tried to move program to another machine with OS 9.2.2 and have the same problem as before. I'm sure there is an extension or something that I haven't moved yet. Thanks for your looking at my problem. Maybe someone will know how to move my favorite Lotus program to my new machine (not new ,but new to me).


I have not *known* anyone to be using 1-2-3 anymore, especially on a Mac. Pleasure to meet you.

TO be honest, the best way is to get ahold of the installer, and re-install the software. Or, it might be time to bite the bullet, and go after a new program, such as Open Office.


Thanks for replying. You are not the first to suggest it is time to move on, in other words join the 21st.century. I have Excel, but after using Lotus for the last 12 or 13 years, for me Excel is clumsy. Besides all my files are in Lotus and it is time consuming to move to Excel, edit and then save as Excel document. There may be an easier way but don't know it.
I have gone back to original floppies and installed on my upgraded G-3. But when I try to launch the program, Lotus 1-2-3 just flashes across top of screen but does not open. I still believe there is a conflict or a missing extension or preference but don't know how to find problem.
Thanks again.



Without having a copy around, it would be difficult for me to bugshoot it. Yes, it is possible there is an extension conflict running around somewhere.

I wonder if the Lotus website has any updated information the the program.

You might have to track down an older system, and run it there. Perhaps consider getting a Mac LC / Performa and keeping an OS of the day (7.5, 8.1) and just running Lotus on it.

Rememeber that since 1 - 2 - 3 was written, that advances in processor, memory size, and chipsets have occurred. The LC / Performa were running on 680x0 hardware... and the PPC chips have to *emulate* those instructions in order for today's machines to work with it. This is where the terms "Classic App, Fat App, Native App" come into play. Most likely, 1-2-3 is a Classic App, meaning that it was compiled with 680x0 code only, and the G3 / G4 is needing to emulate all those instructions.

If your investment in Lotus 1-2-3 is that critical, it might be time to find a secondhand Mac store, and purchase another Mac, such as an LC, or a Pre 6100/7100 machine, (such as a Quadra) and use it for 1-2-3 only. You can network such machines over ethernet, and remote control them with VNC if you would so desire, so that you can save on monitor power and desk space.



True, I first had my Lotus 1-2-3 on an LC II but was moved to a Performa 6360 in 1997 and has run under 8.0, 8.1, 8.5 and now runs under 9.0 on the Performa with a 400MHZ upgrade. I'm trying to move to a Beige G-3 with a 800 MHZ upgrade. The only reason I'm changing machines is to get more Video memory. Since it runs under 9.0 on the Performa one would think it should run on the G3.
I thought Lotus as in spreadsheets was gone. I have heard of Lotus Notes or something of sort. I'll look on their website to see if there is some help.

Thanks again


Just came across this thread - if it is any help, I use Lotus 123 extensively on my Mac G3 and have had the same prob. I have found that if I open - bear with me here - Outlook Express, Quicktime and IE I can then open 123......it wasn't always like this but this is the only way I know now....I suspect I have lost an extension or something.....

I'm in the same boat. I have an extensive amount of files is lotus 123 v1.0 running on a G3 powerbook OS9.2.2. I would like to take it to present decade. The problem really revolves around the macros. I haven't found a program which can translate these. I've even considered a windows machine (but hoping not) if it could make the transition. Any advice is welcome.

In trying to find answers for myself, I came across this thread re lotus.

To nedkelly05:
The reason you can launch lotus after opening various programs is because Lotus can have only so much memory available. Once memory surpassed ??? (I forget the exact amount), launching became a problem. My solution was to assign a lot of memory to one program and then just open that first when I wanted to use Lotus.

The remarkable thing was once OS 10 came out, Lotus magically worked in classic mode. Until 10.2, that is. So my husband is stuck with 10.1 and I keep testing every new versions, hoping that someday it will start working again.
Bottom line - it's not missing extensions or anything wrong with the program. The problem is memory and how the OS handles and distributes it.

For anyone who is still working on this thread:

I am running the latest version of Mac OSX (10.4.8) and I just got my old version of Lotus 1-2-3 (1.10.00) to run on my powerbook. All I had to do was put 500000 KB (yes you read it right) in the memory drop down menu in the GET INFO dialog (you can access this by clicking once on the 1-2-3 application icon with command I or going in the finder's File drop down menu). My Lotus has returned!

Hope you folks are still keeping an eye on this thread.

I think your problem is the amount of ram available. I have found Lotus 123 will not launch if there is too much ram !!! weird ..hence the reason it will launch when other app are running.

Lotus 1-2-3 for the Mac was not a 32-bit clean application, meaning that it used some of the high 8 bits of memory pointers for its own purposes. At the time, no Macs more than 64 MB of RAM, so the program could get away with it. As a safety measure, the program would check to see that it was runnning in the first 128MB on the system (so that none of the highest bits would be set by just landing in memory), and quit immediately. Starting in Mac OS 9.2-ish, the Mac OS started loading applications high in memory. That, combined with systems having lots of RAM, made 1-2-3 for the Mac detect the pointer problem and quit.

It is possible to still run even on 10.4's Classic environment. The trick is to simply run another classic app (e.g. SimpleText), with its memory partition set to something enormous, like 256MB. This will cause SimpleText to occupy the "high" memory region, 1-2-3 will load low, and its address sniffer will be placated.

At last I'm getting closer.
Forgive me for going a bit off topic, but this is the first anything I've found which comes even close to what I'm seeking. . I'm a brand new Mac user (MacBook Pro 17) but a very old Lotus 123 user since 1986, currently on a Windows XP Pro desktop PC. I have long known about the wonders of Mac, but always constrained to PC by employment. I'm retired and my own boss, with long term 123 experience and the last 7 years of self employed stuff in 123. So I really would like to have 123 on my MacBook.
I'm totally ignorant and struggling with Mac, but I think it's a glorious machine. I had a try with "Crossover" today, but it wouldn't install 123 or Microsoft Autoroute, both of which on the MacBook would make my life complete. I've heard of Parallels and Bootcamp. Can anybody set me in the right direction to get productive, please? Please remember I'm a Mac ignoramus - I've already got the desktop looking like a disaster area simply because I don't know how to look after it - my PC knowledge is no help.

Where did the number 500000 come from? Is is in any way related to the RAM on your system? If I use a different number what might be the result?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.