Start New Discussion within our Microsoft Windows Community

Hi

I'm running Windows XP Pro. SP3. RDP used to work fine but following the SP3 patch (I think) I noticed that the RDP icon had changed in appearence. When I try and use Remote Desktop it launches and then displays an error box saying

"Remote Desktop Connection has encountered a problem and needs to close."

If I leave the error message on the screen I can use remote desktop but the error always stays on top. If I click the close button on the message box it closes remote desktop.

Event viewer shows the following:

Faulting application mstsc.exe, version 6.0.6001.18000, faulting module unknown, version 0.0.0.0, fault address 0x010f7390.


It's very frustrating. Can anyone point me in the direction of a fix for this?

Regards

Alistair

In XP SP3 a change has been made to the RDP client in regards to how to connect to a console session, previously it was nessesary to use the "console" parameter, but now the parameter has changed name to "admin".

A possible solution is

- Stop the process mstsc.exe
- Created a new folder "RDP" in %windir%
- Copy "mstsc.exe" and "mstscax.dll" from "C:\Windows\
$NtServicePackUninstall$" to this folder
- Copy the folder "en-US" "from C:\Windows\System32" to this folder
- Copy the "mstsc.exe.mui" and "mstscax.dll.mui" from "C:\Windows\
$NtServicePackUninstall$" to "C:\Windows\RDP\en-US"
- Change RDP shortcut to ""C:\Windows\RDP\mstsc.exe"

Let me know if it works.
Mikey

magic_mikey, thanks for your solution.

I have Win SP3 for a few months, but few days ago my remote desktop connection stopped to work, ending with error :
Faulting application mstsc.exe, ....... .

I've followed your solution and it WORKS !

Thanks !

In XP SP3 a change has been made to the RDP client in regards to how to connect to a console session, previously it was nessesary to use the "console" parameter, but now the parameter has changed name to "admin".

A possible solution is

- Stop the process mstsc.exe
- Created a new folder "RDP" in %windir%
- Copy "mstsc.exe" and "mstscax.dll" from "C:\Windows\
$NtServicePackUninstall$" to this folder
- Copy the folder "en-US" "from C:\Windows\System32" to this folder
- Copy the "mstsc.exe.mui" and "mstscax.dll.mui" from "C:\Windows\
$NtServicePackUninstall$" to "C:\Windows\RDP\en-US"
- Change RDP shortcut to ""C:\Windows\RDP\mstsc.exe"

Let me know if it works.
Mikey

Hi Mikey

Thanks for the tip my RDP now works without any problem. I had trouble finding the "mstsc.exe.mui" and "mstscax.dll.mui" files but it turned out that they were already in the en-US directory!

Thanks again for the help.

Alistair

Thanks Mikey - that worked for me too.

I have XP Pro SP2. I recently updated to XP SP3 but the Windows Installer stopped working so I rolled it back. After the rollback mstsc.exe stopped working (process showed in Tasl Mgr but no window appeared). I used your fix and mstsc is working OK.

Thanks again,
Andy

Will this also work if running into the same problems with Windows XP and RDC coming up with error 6.0.6001.18000 but a different offset number?

I upgraded to 6.1 and since get an error that RDC has to close due to error. And uninstalling does not help. I need 6.1 in order to utilize some terminal services.

Thank you in advance.

Mike - gret solution, many thanks! Works fine for me. I guess it amounts to rolling back that part of SP3...

In XP SP3 a change has been made to the RDP client in regards to how to connect to a console session, previously it was nessesary to use the "console" parameter, but now the parameter has changed name to "admin".

A possible solution is

- Stop the process mstsc.exe
- Created a new folder "RDP" in %windir%
- Copy "mstsc.exe" and "mstscax.dll" from "C:\Windows\
$NtServicePackUninstall$" to this folder
- Copy the folder "en-US" "from C:\Windows\System32" to this folder
- Copy the "mstsc.exe.mui" and "mstscax.dll.mui" from "C:\Windows\
$NtServicePackUninstall$" to "C:\Windows\RDP\en-US"
- Change RDP shortcut to ""C:\Windows\RDP\mstsc.exe"

Let me know if it works.
Mikey

This article has been dead for over six months. Start a new discussion instead.