0

whenever i try to run windows update i get this message

Windows Update cannot continue because a required service application is disabled. Windows Update requires the following services:
Automatic Updates enables detection, downloading, and installation of critical updates for your computer.
Background Intelligent Transfer Service (BITS) enables faster, restartable downloading of updates.
Event Log logs Windows Update events for troubleshooting. To ensure that these services are enabled:

1. Click Start, and then click Run.
2. Type services.msc and then click OK.
3. In the list of services, right-click the service name, and then click Properties.
4. In the Startup type list, select Automatic.
5. Verify that the service status is started.

I tried the steps but nothing happened could someone make it more clear as to what i need to do.

5
Contributors
4
Replies
5
Views
13 Years
Discussion Span
Last Post by deborama
0

Yeah, its really annoying that Windows Update requires those services. Here's what to do:

Click Start > Run... then type services.msc into the box, and click OK. The services window should now be open. Look down the list, and find Automatic Updates. Right-click on it, select properties, and then set the startup type to Automatic. Do the same for the Background Intelligent Transfer Service and also the Event Log service. You can disable all three of these services (if you wish to do so) after you get your updates. Of course you'll need to re-enable them if you want to check for updates again later ;)

Let us know if it works now :D

P.S I've also heard that you need to have the Cryptographic Service running in order to use Windows Update. Try it and see if it makes a difference.

0

I am having a similar problem but can't seem to figure out what happened. i recently had to do a system restore on my dell computer. now that i'm having to start from scratch again, i am trying to update all my windows upadates but to no avail. attached is the message i get. please help me with this problem. has anyone else ever had this problem.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.