0

This is a follow up issue after recreating my domain from this thread.

http://www.daniweb.com/techtalkforums/thread16249.html

I was able to add all computers back into the domain by changing them to a workgroup, rebooting, changing back to the domain, rebooting...

except for two computers. Oddly enough both are laptops that connect to the network wirelessly.

On both when I try to rejoin the domain I get the error "server cannot perform the requested operation".

When I check the server I see the computer is listed in active directory computers, however it is disabled.

Both laptops are using the correct dns (and it worked for every computer other than the two laptops).

I have also tried running mmc and adding the "Security Configuration and Analysis" and "Security Templates" snap-ins, created a new database and imported the security setup template, applied the templated, rebooted and retried to join the domain and got the same error.

I can ping the dnc, and the dns is functioning properly (I can browse sites by both name and IP).

I'm running out of ideas and any help is greatly appreciated.

4
Contributors
7
Replies
8
Views
12 Years
Discussion Span
Last Post by jeffm
0

I have tried that.

I have also connected each of the laptops to the network with cables to remove the linsys wap from the equation.

Still no luck.

0

PLEASE let me know if any has resolved this issue. To me, this seems simple, BUT I am having the SAME problem. Moved to a new DC, demoted, took out the old DC. I inadvertently removed one workstation from domain, now get the "server cannot perform the requested operation" when I try to re-join the domain. It is Windows 2000 server, and XP workstations. All other workstations remained "joined," but since I messed up and "removed" this one, i.e., moved it to a workgroup, now it will not let me re-join. I've deleted computer acct and tried to re-join, but get same error. XP Professional workstation, Windows 2000 Server (Advanced Server actually).

Only thing I can recall is that at some time in the past, we had to MANUALLY put in the DC in an LMHOSTS file to get this to work. I HAVE NOT TRIED THAT YET, BUT WILL TRY IT THIS WEEKEND. ANY HELP WILL BE APPRECIATED!

Thanks,
jeffm

0

Forgot to also say that, YES, I get "disabled" on the computer account on the DC. If I enable it, it still does not work, letting him join the domain. Again, I have not yet tried manually putting info in LMHOSTS, but I remember that helping fix this problem in the past. Should NOT have to do that, but, oh, well, this is a Microsoft BUG, because re-joining the domain should NOT be this difficult! Oh, well. :(

Tried applying Windows Server 2003 SP3, because that was also recommended, but to no avail.

Used to be we could DELETE the computer account from AD, then reboot the workstation, let the DC have time enough to realize the account is gone, then... have the workstation re-join.

Help!
jeffm

0

These new servers on new IP's. Have you checked that the laptops, have the new DNS (assuming this is through the DC) IP Address, try switching to DHCP on your laptops if they are Statically assigned, as laptops usually are.

On computer name page, of System (control panel), use the Network ID wizard, not "change".

When you try to join a domain, use DOMAIN\username - not just username (switch to domain name and username)

Also try to access drives on the server, first \\ipaddress then by \\ipaddress\C$ (for example) and authenticate with domain account as prescribed above. Any results?

I'll try to think of some other things.

0

Yep, they are all dhcp. maybe i should make this one static?
i noticed DNS did not fully move over from the old domain controller. I found an A record still pointing at the old box as parent. I changed that - and I 'think' I rebooted the new DC after I changed that.

So... what I did is move from an old DC to a new DC. Just small office - ony ONE server with all FSMO roles.

Hmm... Yep i use network wizard, not 'change.' Yep, i mapped C$ using the IP address. These are all things I normally do, so this is a good exercise, just very frustrating.

You know what? ORIGINALLY, when I first set up this whole office and domain, i had the exact same problem, mainly with this one workstation, but also with some others. Originally they were on XP Home, and I upgraded thema all to XP Pro.

Yes, I think maybe partly DNS may be at fault, but I think it is finding the dns, i have double-checked the ipconfig/all already.
hmm....

i am at
computerz4u(TAKE THIS OUT)@(ALSO REMOVE)yahoo.com -
if you can think of other things to try.

Thanks,
Jeff

0

OH yeah, so maybe initially I did the manual LMHOSTS file, and FORCED it to see where the domain controller was, but it seems it is finding the DC this time, just saying the server cannot perform the requested operation. This is definitely a MICROSOFT problem. And it has NOTHING to do with the Microsoft suggestion in their KB article about something with DNS or whatever - I tried their suggestions, and it did not help at all. And note I have had this problem at other sites, too - with Windows 2000 at another client, we played hell trying to get some of the Windows 2000 Professional laptops to join the domain.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.