0

Dimension XPS 4500 WinXP, Raid 0 striping shows Normal, but it gives error message Primary IDE...exceeded parameters.....F1 or F2, When it does get to Windows logo screen it just hangs as if trying to boot.
Help.
Two WD hard drives are apparent in BIOS, SATA Raid is set ON.
I have no idea what to do first. I tried to run Data Lifeguard Tools, and it wants me to do so, inside Windows...which I can't get booted into !!
They are worried about data loss and I am currently doing a full back up by way of a USB device and placing their data on another media.

Someone please lead me to step One, and so on, but I know enough to allow that you can be brief, and use abbreviations. I just dont' work with RAID that often !!

Thanks in advance.
Nanci

2
Contributors
4
Replies
5
Views
8 Years
Discussion Span
Last Post by Nanci252
0

Why was raid 0 setup on a xp machine? It sounds like the raid was broken or a drive dropped offline, and with a raid 0 data is spread over the 2 drives. So basically half a file can exist on 1 and the other half on another. I'm not familiar with dell bios but does it have any raid tools in it? I would not run and data recovery tools like chkdsk. chkdsk tries to re-align the files system and if the raid is broken it may only work on 1 drive and corrupt the data even more. You can search and see if Hiren boot cd has a raid tools in it. You will need a tool that will check the entire raid for bad sectors and fix. But this can be risky like I said if 1 drive is completely offline it will further corrupt the data.

0

Thank you for your reply. It was set on this Dell BY Dell when the kids bought it ! And yes, they knew nothing when they ordered it except that their income tax would cover buying it - so pretty much since they wanted a ton of space, and keep thousands of songs and pix the dell folks sold 'em an array so that supposedly they'd always have space and always have speed loading -

Well. That has Never been the case, and then a neighbor of theirs tried to play with it about two years ago, before I got my certification, and I'm looking at his bad actions playing into it as well.

The Master connected to the master on the cable is loaded full, but the secondary on the cable is empty but for a couple songs he must have told to 'save' to it.......NO redundant backup of data, no data is 'spread' over the array, but RAID is still trying to control the machine.
Which is why I'm stuck to figure how to approach this.

I did disconnect each drive, USB patched them onto my service machine as 'slave' position and getting the data onto a third empty/open hard drive just using file settings and data transfer - not cloning......so that if we end up with one 200GB hd and I have to disable RAID - period .........a new install of win Xp and move the transfers back onto a fresh clean drive without raid involved. It appears that songs transfered are playable (random tested), and pix are showing by reading them off the third drive I got involved in it. So, hopefully, short of a few corruptions, they won't lose everything entirely.
Does THAT sound like a plan ??
Now I gotta research how to disable Raid entirely, so this all don't happen again. And I'm pretty sure raid is mobo based, so I'm starting also in the website of the mobo manfr.

Nan

0

You have me very confused so by your description of the cables hard drive 1 is plugged in hard drive 2 is not? but in bios the raid is turned on to 0 with no 2nd drive? If that's the case and the computer has been operating on 1 hard disk then just run chkdsk /f on the 1 hard disk it may fix the corruption and boot. From here out if you have 2 hard disks and a raid controller set it up as raid 1 hard drive mirroring this will create a data redundancy scenario. with a raid 1 the first hard drive is a mirror image of the second in case of drive loss you can still operate on 1 drive.

0

Yep that's what I probably shoulda been able to put it in those words, but - I do not have that much raid experience outta 347 machines, I've only done 3 raid arrays for anyone.

the second hard drive appeared when it was booted, but like I said, nothing on it - but a couple songs. It WAS cabled and appearing...and operational or he wouldn't have gotten the music on it.

I can't find the guy who did work on it before to plug into what his actions taken had been, but when I go into bios it appears as two drives, but the second one is 'listed' in the boot seq. category as unknown device.
Oh it's a heck of a mess back-walking this thru past actions and why the bios doesn't say and look like the dell guy on the phone told me.
And, believe it or not, even the dell phone support couldn't help me walk outta this !!!!!! wow.

I'll keep posting as I incur things, and hopefully, it's not going to turn into a 24 or 48 actual hours of working on it. I just don't have that kinda time to simply sit with it doing check this, check that.
Now that I have what appears to be all their personal crap - elsewhere for the moment - I'll try what you said and run ckdsk/f - and see what that reports, if it reports a horror movie at least I ain't worryin' about folks' pix !!

Thanks I appreciate you chkg back to see what I've said.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.