0

I am trying to fix a HP Pavillion 521N computer. It was working fine until one day the computer said that there was no boot device. Fine, I removed the hard drive and put it on USB controller and ran check disk on another computer. It found several problems and fixed them. The drive is accessible on another computer. I put it back in the HP and the bios doesn't recognize the HDD. The drive jumper is set to Cable Select. Fine, I replaced the Hard Drive with a known working drive. Bios still doesn't recognize a hard drive. I switched the jumper to Master, Slave and back to CS. No Joy. There is a CD-RW drive in the Secondary Master position and a DVD drive on the Secondary Slave position. Only the DVD drive in the Slave position is being recognized. I tried various hard drives in various jumper positions, with various IDE cables. I put a Lite-On DVD-RW on the Primary Master position and it is recognized, but not the original HP CD-RW, which is recognized on another computer.. I then updated the bios, successful but the first bios screen shows the same bios #. I tried running the HDD on the Secondary cable as Master and as a Secondary Slave. No Joy I am stumped, in my 10 years of computer repair, I haven't seen this one. Any other ideas??

5
Contributors
10
Replies
11
Views
8 Years
Discussion Span
Last Post by Rik_
0

Bad IDE controller on the motherboard?

I had the whole usb controller die on a motherboard once, so its indeed possible for such things to just go...

0

I thought that too, but the Lite-on DVDRW set to master on the Primary Master channel is recognized. No HDD's in any configuration

0

Hello There:
Most likely you have a bad IDE controller. I had a similar problem with a dell and i ended up replacing the motherboard. Try to disable the CD\DVD and the Floppy Disk from Bios, Reboot and hopefully it'll work. It worked for me. But you will not be able to use them until you replace the motherboard.

0

If you read my posts, the Primary IDE controller recognizes a Lite-On DVD-RW in the Master Jumper pin Setting. Just no HDD's. Removing all IDE drives except for.a HDD does nothing either.

0

Any possibility of a lightning strike damaging the system?

Check the power supply; +5VDC or +12VDC could be low on one of the outputs. Even a bad ground could cause problems. Or just try a different PS in the system.

Try unplugging and reseating every connector you can find (with the system unpowered and PS drained, of course).

There's a slim possibility that, in a moment of madness, it overwrote some key values in NVRAM. Write down the BIOS settings, shut it down, pull the NVRAM battery and clear the settings. Then reset them to the recorded values.

The last possibility is a stray neutron blasted through something in the IDE subsystem causing the failure.

0

No lightning (no rain in LA!!) I replaced the power supply a few months ago, voltages and temps are normal. I have Updated the bios but I haven't cleared the bios yet. I will let you know if that worked.

0

OK, I'm done. I reset the jumper from 2-3 to 1-2 and restarted the computer. Oddly enough, the computer started and reset the bios. I pressed F5 to set bios to defaults. It did not recognize a hdd. I reset jumper pin from 1-2 to 2-3. Reset bios again, same results. Removed CMOS battery changed it with another known good one. change power plugs. HDD's Jumpers etc. Only thing that will recognize in the Primary Master position is a Lite-On DVD-RW no HDD's. I give up, mobo must be bad.

0

Well, I will be a Monkeys Uncle! I switched out the power supply and it recognized the HDD!! amazing and it was brand new 2 months ago.

0

Just for grins, try booting a live Linux CD. See if Linux sees the drive(s).

What's the possibility the BIOS Flash memory went south?

(True, it's really time to give up. It's now cheaper to buy a new computer than to fix this one. However, it's still worth looking further if you simply want to learn even more about how PCs can fail and how to more quickly recognize 'lost causes'.)

[edit]Never mind. You slipped in whilst I wrote this. :) :)

Marginal power supplies and marginal memory are known to cause computers to be flaky.

And I need to remember I have a silly scope; it can be useful for viewing power supplies under load.)
[/edit]

0

Does it have different speed ram sticks in it by any chance?
I have encountered many old Pavilions in the past with a mismatch of ram. Usually 256meg of PC100 and 256meg of PC133.

Putting all PC100 or all PC133 can sometimes fix the problem. In some cases, the second ram slot was beyond repair tho.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.