0

Hi All,

My XP Pro with SP2 is an upgrade from 98.
I can not Right Click on the Desktop. The system just crashes.

DrWatsn32.exe will generate a PostMortem and submitting to MS doesn't help.

I run up TaskManager and Kill off DrWatsn32 to get Explorer to reload.......

I've scanned for Viruses, Trojans, Spyware etc.... AdAware, SpyBot etc....

Any ideas of the Reg Keys for the Right Click Desktop Context Menu ???

I've performed a Repair install and the problem still exists.

I've performed a full Windows Update ( no surprise - didn't help).

Any pointers would be GLADLY accepted.

Regards
G

4
Contributors
10
Replies
11
Views
12 Years
Discussion Span
Last Post by caperjack
0

Further to this.... :-)

Have relocated Disk (i.e. XP system) to replacement motherboard running Intel 815 chipset. All BIOS and drivers are the latest as per Manufacturer (MSI) and Intel.

This PC previously had TNT2 Nvidia Card on a VIA based Motherboard (Soltek). Now has Intel 815 video on Intel based board i.e. MSI as the Soltek was freezing at random times (suspect Dust/Static damage as was sitting on floor at local school for 4 years, mmmm yummy lots of dust) .

Originally the disk image (on Soltek M/b) was from Win98 SE.
Original Upgrade to XP went 100%.

I did a Repair Rebuild of XP over top on the replacement Motherboard unit (NO Freezes on this board, so CPU is ok or at least has been running for 18hrs+ with no issues) .....

I found links elsewhere indicating similar probs where they said to turn of DEP in Boot.INI. eg. /Execute or /NoExecute=AlwaysOff

Have tried this and the only difference is that Explorer reloads itself without having to use Task Manager to kill of DrWatsn32...... Still no Right Click Desktop as yet.....

Also, made sure that there is ONLY one Video Adapter in the system and in Registry, so Explorer isn't getting messed up - as per another web link..... Not 100% certain Reg is that sure of itself......

I'm trying to re-use the original 98 base as it has software in it that works fine in upgrade, however not when installed over top of fresh XP install (yep older 9x software, and yes have tried compatibility modes etc... so am forced to persevere).....

If you have ideas I'm open to suggestions.
Thx in advance.... ;-)

0

Format. Install fresh.

Sorry to throw that blunt old tired cliche at you, but the path you've undertaken is a recipe for disaster, which can really only pile problem upon problem.

If you have an XP 'upgrade' CD, then you can use it to perform a fresh install, and need only to have the Win98 CD for verification during the process. If you have a 'Recovery CD' for that PC, rather than a Win98 CD, then the problem can most likely be worked around as well.

0

Thanks CatWeazle.

Agreed.... however....that would be like giving in and following the path to the dark side....

I'm helping out a rural school (freebie) who don't have skills or budget to work this through...

It's a path I tread very gingerly, as I too am an MS exponent of "GreenFields" where one can.

As such, I have already performed a fresh install to confirm issue isn't in XP itself with the H/w I am using.

Not surprisingly Fresh install works fine.

Alas, I am forced to persist in my lunacy to see if we can move forward with the old stuff.......

I've restarted with Win98 stripped of Hardware eg. NVidia s/w, AV and other 9x specific configured S/w..... will see how that goes on this machine.

Probably should've "SysPrep"d the machine when was already in XP and seen what happened.

I now think issue is probably from confusion with NVidia driver and s/w suite lurking somewhere in Reg. I've seen similar issues before, however this time hasn't been so straigh forward to resolve.

Hey, thanks again for your words of encouragement....

0

Further again....

I reimaged the Disk with School's Win98 image i.e. legacy software installed etc... then stripped out 9x specific drivers and associated software e.g. NVidia Display suite along with any other Win9x specifically configured software and performed inplace upgrade again....

I ended up copying the I386 dir onto disk as the DOS CD Driver ( remember I'd stripped out hardware) had an issue with Directory depth/length so ONE particular set of folders ( i.e. ASMS\....\52\....Networking) contents didn't copy down properly.. so repoplated that folder ( from good ole floppy) and performed the upgrade .... Bingo !
All works fine.
Obviously also had to perform a few tweaks here and there as XP doesn't migrate users (other than the upgrade user).

I now think issue is Reg corruption/confusion with hanger on drivers/settings around different Video cards that had Windows/Explorer confused as to which Video to output the Right Click Desktop dialog to..... Probably a bug, but hey I don't expect MS is likely to ever address.

I'd love to find the reg fix. It'll be a simple fix too no doubt.

I've kept a copy of the image for those of you out there brave to suggest a fix ;-)

Anyway to anyone out there who has this issue, simple reminder.....
Have backups to be able to go back a few steps !!! Invaluable.

0

I am having this same problem. However i have a fresh install of Winxp with SP2, my research has led me t belive that there is a shell problem with my right click menu. but any advice from you guys would be a great help.

0

create another user account ,see if it works there .

thanks for the help guys, i managed to fix the problem using "Shellexview" an intel graphics shell was causing explorer to crash when the right click menu came up. i used to program to disable all non microsoft shell's then re-enabled them one at a time until i found what one was causing the problem.

0

thanks for the help guys, i managed to fix the problem using "Shellexview" an intel graphics shell was causing explorer to crash when the right click menu came up. i used to program to disable all non microsoft shell's then re-enabled them one at a time until i found what one was causing the problem.

Interesting ,never see that program before ,I scaned and have 230 different one in list ,how did you ever figure out what one was causing the problem

0

I only had 10 that were not Microsoft shells, so I just disabled those 10 and re-enabled 1 at a time untill I found the one that cause the error.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.