0

I have a MX300 mouse on a Boxx Computer running WinXP32 that keeps freezing:confused:, if I just unplug and replug it in it will work again for a few minuter to a few hours! I have reinstalled the driver several times to no avail with the latest driver which used to work fine. This has been going on for a couple weeks now and it is driving me nuts! Any thoughts on what might be causing this?

4
Contributors
6
Replies
7
Views
7 Years
Discussion Span
Last Post by caperjack
0

! Any thoughts on what might be causing this?

the mouse,maybe .
get another cheap[not sure where you are located ,but here we can get them at dollar+ store for 2 dollars ] one to try, and see if comp still freezes

Edited by caperjack: n/a

0

I've had issues with the Logitech drivers before.

Uninstall the driver, shut down, unplug the mouse, boot up the computer, plug the mouse in. See if it works then.

You could also try the mouse on a different computer and see if the mouse is working properly or not.

0

This mouse has worked fine on this computer for years. I have reinstalled several times and have the same behavior which makes me think it is not really the driver but something with USB or WinXP. It seems to just loose track of the mouse, since unplugging it and replugging it back in it works again. So it is not a typical Freeze... the computer is still working!

0

Well I solved it, I plugged the mouse into a Mac and had the same exact random freezing behavior. Then I remembered dropping the mouse a few weeks ago on a hard tile floor. I opened it up and found a socketed chip with a bracket over it that was screwed down to hold it in. So, I tightened it up a bit closed up the mouse and now all is OK.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.