0

I am running Win7 pro and the Microsoft Virtual XP.
The virtual machine uses a separate VHD for it's user generated data, a small 1 Gig fixed size virtual harddisk.

I attach this VHD in read-only mode to the host while the Virtual XP is running for backup purposes. This is done via Computer management > Storage > Disk management.

Suddenly, it won't let me do this anymore with the virtual machine running. Error: the process cannot access the file because it is being used by another process.

The error makes sense, but what baffles me is that it used to work fine for weeks. I am not aware of any changes in my setup. I did use google, but it returns results about interfering virtual DVD drives (I have none) or too big VHDs (mine is just a gig in size).

So, I wonder if mounting a VHD in use by the virtual machine is actually supported, and why the h*ll it used to let me do this?

Thanks,

3
Contributors
3
Replies
4
Views
7 Years
Discussion Span
Last Post by johanb
0

simple things first, reboot the pc
(dumps all running processes hence releases them for use...)

0

Thanks Temmu and avadhraj, but naturally I have rebooted both the VM and the host machine; even twice. Same result, just won't let me attach anymore.

The problem is, I cannot attach the VHD with the Virtual PC running, the vdh file is opened with two handles by vpc.exe, which makes sense of course.

But the surprising thing is, this USED TO WORK for several weeks!
Still not sure if this is by design, or an error.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.