0

Yesterday I started experiencing a very irritating problem on my Windows 7 Enterprise x64 machine. Somehow, and I don't know how, I've lost permission to download .exe files to my Desktop (if I create a new folder on the Desktop I can successfully download into that). I've tried using both Firefox and Internet Explorer to do so and both give an error as soon as the download reaches 100%. The Firefox error is:

C:\Users\<Username>\Desktop\<filename>.exe could not be saved, because you cannot change the contents of that folder.

Change the folder properties and try again, or try saving in a different location.

The Internet Explorer error is simply:

You need permission to perform this action.

Weirdly, FlashGet (a download manager) can download the files without any problem, and I can download all other filetypes, just not .exe files (even .msi files download fine). I can move .exe files to the Desktop from other folders with no problems, the issue just seems to be when I download them from the net.

I have tried everything I can think of to rectify the problem, but nothing has worked. I've tried:

1. Setting maximum permissions for everyone in the Security tab of the Desktop folder properties.
2. Running both Firefox and Internet Explorer as admin.
3. Completely uninstalling Comodo Internet Security (which includes a firewall and antivirus) to see if that was causing the problem; it wasn't.
4. Using cacls via an elevated command prompt to take ownership of the Desktop folder, and the entire C:\ drive too.
5. System Restore - it failed because it couldn't extract a single useless file I didn't even need haha.
6. Running Firefox Safe Mode, which disables all customisations and basically runs it in its most vanilla form.
7. Reset my Internet Explorer settings using a specialised tool from Microsoft which does just that.
8. Disabling the Firefox antivirus scan, via the about:config screen, which is invoked when files are downloaded.
9. Cleared the history and temporary internet files/cache from each browser.
10. Head-butting the monitor.

I've run several scans (one antivirus and three antispyware) which showed nothing, and I created a HijackThis! log which showed nothing, so I doubt it's a malware issue.

UAC is disabled, and it's been disabled since I reinstalled Windows a month or two ago. I've installed the latest Windows updates as well. The Windows Firewall is disabled, as is Windows Defender.

I have an inkling that a certain program I installed yesterday may have done something to my system. It's called Install-Block, and it's a program which prompts users for a password before it allows them to install software. I only installed the demo, immediately didn't like the software and uninstalled it again. I'm guessing that this program works by altering the system's handling of .exe files (or installers in general) and that it didn't reset the system's protocols back to normal when I uninstalled it. I even reinstalled it, loosened the restrictions on installers within the program hoping that doing so would set things back to their original state (if they in fact needed to be), but that hasn't helped either.

So, so annoying. Any ideas would be appreciated.

Cheers for reading.

4
Contributors
10
Replies
19
Views
6 Years
Discussion Span
Last Post by gissi.deleon
Featured Replies
  • 1

    HI Paddy It appears that the install-block have created some "local security policy" rules. I have two possible solutions for you 1. (the geek solution) If you type "gpedit.msc" in the start menu You get to a window with a huge tree-list of possible settings, in various sub's - I … Read More

0

@Rik from RCE: I've done complete system scans with SuperAntiSpyware, Malwarebytes' Anti-Malware, Spybot: Search & Destroy and Comodo Antivirus. All scanners were updated prior to each scan. HijackThis! showed nothing. There's nothing else to suggest that the system is infected.

@sanasahil: The settings were already reset, see above for details.

Cheers.

1

HI Paddy

It appears that the install-block have created some "local security policy" rules.
I have two possible solutions for you

1. (the geek solution)
If you type "gpedit.msc" in the start menu

You get to a window with a huge tree-list of possible settings, in various sub's - I can't tell you which setting, or where to find it, but this is where it is hidden.
If you are lucky, the policy might be named as an "install-block" rule, or have "install block" in the comment.
But you will very likely have to spend some time searching for it (remember to read the comments before changing these settings).

There is a lot of possible settings here, and a great opportunity to get intimate with win 7, but also an opportunity to mess it up big time, so think carefully about what you do.

2. (the easy solution, or plan B if you fail on the first)

Boot from your Win 7 dvd, and select the repair option.

Good luck :)

Edited by jak0b: n/a

Votes + Comments
Thanks for taking the time to help.
0

@jak0b: thanks for the reply!

I looked through every single option in the Local Group Policy editor and couldn't find anything which relates to my problem, and there's nothing labelled Install-Block. I looked at everything, but I was keeping my eyes especially peeled for anything relating to downloads, security, permissions, restrictions, user accounts and so on, to no avail.

All of the options were set to "Not Configured" (except for the one or two I had set myself a while ago, such as disabling balloon tips). If Install-Block had indeed messed with something would that particular option be set to Enabled/Disabled as opposed to Not Configured? If so, I could have another look and just sort each list of options by "State" and see if there is anything other than "Not Configured" in each list.

Thanks mate :)

0

Hmm, the only other possibility I can think of, is to look through the local security policies manually (run secpol.msc).

I think it might just list all the same settings in a different order, but given the fact that it is a different plugin, you also might find some different explanations to some of the settings, or maybe you will even find some specific settings, omitted from the other view.

Anyway - I am pretty sure that you are looking for some reg-setting.
Maybe you can also try to run ccleaner, and see if it can find any traces left of that crappy "install block" (just run the scan, and see what it finds).

0

I cleaned the registry using CCleaner and Eusing Registry Cleaner, and also searched the registry rather laboriously using "exe" as a search query (it took as long as you're probably imagining...), but it didn't help. However, I was able to finally do a System Restore by first uninstalling Comodo Internet Security, but despite restoring several times using increasingly early restore points - points from last week even - the problem persists, which is just weird. I'm currently making backups of my files and will be reinstalling Windows tomorrow, i.e. when I can be bothered to do it.

Thanks for your help anyway mate, much appreciated! :)

0

I reinstalled Windows and the problem has appeared again. I think the only other possibility is that a Windows Update has cocked something up, because it seemed to be working fine before I installed the latest updates, which was also true when the problem first occurred.

So, it's not Install-Block (I didn't install it after the clean Windows install), malware, my IE settings or my security software. I'm all out of ideas!

0

I forgot to mention this, but when the download fails, the partial file(s) remains on the Desktop and can't be deleted or altered. I used Microsoft Process Explorer to see if I could figure out which programs/processes were clinging onto it, and it was simply the "System" process, which wasn't very helpful but it does seem to rule out that it's a specific program causing the problem (could still be wrong about that though). After a few minutes the partial file is "released" and can be deleted.

Not sure if that sheds any more light on things.

0

I think I've cracked it. I had disabled the Application Experience service, thinking it wasn't necessary given its task, and upon enabling it again I was able to download (and delete) .exe files freely, and I've downloaded about 50 over the past 30 minutes to make sure. I didn't think this service could be the problem and was worried that it was just a coincidence and that the problem might appear again, so I searched the net for information regarding this service and how it handles .exe files, and it seems that I'm not the first to encounter this problem. Click here for an example.

Besides being unable to download .exe files I was also having great difficulty in getting freshly installed games to run, and this problem has also vanished with the enabling of this service.

So, leave the Application Experience service running if you know what's good for ya!

Edited by Paddy: Typo

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.