Hi, and I need some help...

I'm not remembered much what happened before I got this problem but now I can't access to any of the mmc files in the administrative tools folder currently. Registry Editor and Task Manager still working normally, only the tools in the Administrative Folder...

I have tried using command sfc /scannow but the problem still persist.

Before I move on to the next step like reinstalling and stuff, I just want to make sure it won't affect my system or damaged it so I need you guys help.

I'm using Windows XP SP3 on eee PC 900HA

Thanks in advance...

7 Years
Discussion Span
Last Post by flagstar
Featured Replies
  • try scan with sophos anti rootkit ' [url]http://www.sophos.com/en-us/products/free-tools/sophos-anti-rootkit.aspx[/url] Read More


Yes, I'm using admin account, not the one in safe mode. Haven't try out whether it would work in safe mode yet.

The tools works before about 2 months ago then I can't even access to any of it in the Tools folder.

I also have try reinstalling MMC 3.0 from windows support but it stated I have the newer version than the the installer and aborted.


Try creating a new account and see if you can get to the tools from it.

Also, what antivirus and antimalware software have you got and have you scanned with it recently? Often malware is the cause of problems like yours.


I did get some weird infection where my AV suddenly disable, firewall and automatic updates disable,msconfig also disable every hour or so before but my av and mbam couldn't detect what went wrong. After restart, everything went back to normal, except for the inaccessible Admin Tools.

Also tried with another account but no luck... I mean this works on all users before this and now it's like, missing or something...

MMC cannot open the file C:\WINDOWS\system32\**.msc

This may be because the file does not exist, is not an MMC console, or was created by a later version of MMC. This may also be because you do not have sufficient rights to the file.

Or so it says in the mesage popup


Yes, it does exist in the path mentioned but clicking on that too popup similar message.


In that case you have a messed up registry entry. Try updating Mbam and running it again and do a FULL scan!


I have done Full scan with MBAM before but nothing came up and I used the latest update.

Could it be possible that my computer may infected with rootkit something that couldn't be detected by anti-virus and anti-malware?


Thanks... will try it and run for a scan...
Will post the results in the next post


Sophos Anti-rootkit just found unknown hidden files which is pretty much trusted for me. I'll try another anti-rootkit just to confirm if it's was a rootkit attack...


Sophos Anti-rootkit just found unknown hidden files which is pretty much trusted for me. I'll try another anti-rootkit just to confirm if it's was a rootkit attack...

i was just going to post the same results for the scan i ran after posting the link, except for some temp file all it found for me was exe file that i had in my download folder ,sorry about that ,sophos is a good name so i thought it would work

Edited by caperjack: n/a



this is one i have used before and one suggested on most help forums
temporally disable any real time virus protection .disconnect from internet before running,does not work with 64bit windows

Edited by caperjack: n/a


I can't get it finish on the first run. It got error pop up message and need to close while it's scanning...

Now I'm more suspicious that something is hid inside my computer system somewhere...

Oh, I forgot to disable my av and disconnect the internet. Sorry my bad, I'll try again now...

Edited by flagstar: n/a


And so no rootkit was found...
I suspected first this was a rootkit or similar after MBAM and Avira can't detect any problem/infection in the computer...

And the Administrative Tools files still unable to be access...

What I've try so far

sfc /scannow = Didn't fix it, also mess up my Seven Transformation Pack files

create new account with admin access = Also the same

Safe Mode?? = Haven't try it yet

Scan for virus/malware = not found anything

Scan for rootkit = also ended up nothing

Reinstalling MMC ver. 3.0 = It say I have the latest update in my computer and aborted

I can't think of anything else to do to fix this thing. Formatting is already out of mind since the only one at fault is the Admin Tools only but I fear it'll affect other .msc files too... Can anyone give suggestion here??


I finally solved it...
After a while searching for the solution, I found this one site and at the end of the post, it tells you to do this

run Regsvr32 "C:\WINDOWS\system32\msxml3.dll"

suggested by AndyDitter in computing.net

Then I done it in run and at last, Admin Tools now is working back...
Thanks guys for helping though but I really appreciate it. Seriously...

I'll come here again if I got new unsolved problem... Thanks again...

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.