0
[Boot Loader]
Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"

This is my current boot.ini and it has some history. Once I was trying to re-install xp from desktop (while desktop is open) by clicking and running the cd. It performed necessary steps and as usual it asked for a re-start (to perform the rest of xp installation) after a restart somehow it failed.

Now I can run xp without any trouble except one thing occurs in start up. Even though CD aint inserted, in start up after POST two option comes

"Windoes XP professional"
"Windoes XP professional setup" (selected in default) and if I don't change it and press enter on Windoes XP professional within some seconds (4/5 secs) it shows "setup inspecting hardware config..." and then nothing happens and black screen remains forever. You can say, it because I didn't insert the cd, well even if cd is inserted, no luck same result. setup is inspecting the fu**ing hardware config and then it fades away and nothing else.

Right now my xp is fine so I don't want a re-installation. So I was thinking about boot.ini, and saw this. This is little usual than I saw in past or seeing possible boot.ini in microsoft website.

Any help to get rid of "Windoes XP professional"
"Windoes XP professional setup" two option? and loading just xp automatically?

2
Contributors
2
Replies
3
Views
6 Years
Discussion Span
Last Post by TechySafi
0

Safi, the default is the boot.ini of Setup, the one it makes for itself when it is organising its restart. That the default option fails with cd inserted means some of its files already copied are corrupt; don't run Setup from an existing Windows installation...
anyway, to fix your boot.ini so that you start XP Pro normally just change it to this:

[Boot Loader]
Timeout=5
Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Easiest way is CP > System > Advanced tab > Startup n Recovery Settings button, Edit.
The timeout of 5 secs is immaterial if there is only one option - you won't see the menu screen.
Oh, and delete that folder, C:\$WIN_NT$.~BT if it exists... it's the temp files for installation.

Edited by gerbil: n/a

0

Thanks @gerbil :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.