0

My computer crashed and when I restarted it all my files were gone. So I'm not doumb, I did a system restore to earlier that morning and most of my stuff was there. There were a few files missing off the desktop, the same with all my Hard Drives. I can still see all these files with "Search Everything" an when I go to folders that are empty, I can check the size and it tells me there are serveral files in there. Also, I checked and realised that all my files and folders are now read only. This was OK for a few days, until I tried to play some more modern games than MM2. But I kept getting errors of programs "Not being able to create files". This is most annoying with Firefox, as everytime I restart (which is rarley) I have to delete it and uninstall it to get past the "Firefox is already running..." message. I've tried going into to folders and un-checking the read only box and clicking apply, but with or without leaving the folder, I can go straight back into the propities and the box is selected again. So is there a command or program I can use to make all my files un-hidden and read only? Also, why those files that disapperaed have done just that. And why can I see all these files myself? Thanks,

3
Contributors
13
Replies
14
Views
5 Years
Discussion Span
Last Post by supercomputer
0

Annoying... Try this: open a cmd.exe window alongside a downsized explorer window, drag an affected folder into the cmd window and:
-at the end type: /s /d
-press Home, and in front type: attrib -r -h
...and press Enter. Did that make the change stick to files in that folder?
If so, repeat with other folders. Or use H:\* as your folder to process all folders and files in H: drive in one command.

Edited by gerbil

0

I get this message:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Liam>attrib -r -h"C:\Program Files\Microsoft Games\Ris
e of Nations"/s/d
Invalid switch - -h"C:\Program Files\Microsoft Games\Rise of Nations"/s/d

C:\Documents and Settings\Liam>

Any Ideas?

0

Yes, it thinks that this is a switch: -h"C:\Program Files\Microsoft Games\Rise of Nations" because of missing spaces. Place a space before the opening " and one after the closing ". And that should do it.
attrib -r -h "C:\Program Files\Microsoft Games\Rise of Nations" /s /d

cmd is a bit unpredictable, sometimes spaces are important, sometimes not. It rarely hurts to add one between parts of a command, there are spaces between switches and targets in the above line. -h, -r, /s, /d are all switches. A space terminates a switch, but strangely, some commands will accept a series of switches with no intervening spaces. attrib is not one of those. There is no discernible system.

Edited by gerbil

0

Also keep in mind that some switches are case sensitive as well. If you get help from the command.. by using a /?, you can see if there are switches in lower and upper case.

0

when i do that it justs sits there, with the command i just typed in the heading thing, and is unresponsive.

0

Hi, super c, if you entered....
attrib -r -h "C:\Program Files\Microsoft Games\Rise of Nations" /s /d
you would merely see the prompt reappear after a pause. The job is done, all files in that folder and sub-folders will have had their read-only [and hidden] attributes removed. Take no notice of the green square in any treated folder's Read Only checkbox - that checkbox is only a tool for changing the attribute of all files in the folder [and sub-folders if you set it so in the box that appears], it is meaningless for the folder itself.
You could use...
attrib -r -h "C:\Program Files\Microsoft Games*.*" /s /d
to treat all files in all folders under M$ Games.

0

Well now for no reason whenever I open a new folder it makes a new window. Havne't touched the settingsm, checked them, still the same they've been for 9 years. Any Ideas on that?

0

Explorer window, Tools, Folder options... setting correct on that page?
You might also check, while you have that box open, via File Types tab, scrolling down and selecting Folders [not File Folders], then pressing Advanced button, that "explore" is boldened. If not select it, and press Set Default, Okay your way out.

Edited by gerbil

0

In this case, that box in the Edit File Types window being greyed should not matter. If explore is boldened then folders should open in the same window. You do have to restart explorer to have the change take effect.... use Task Manager to end explorer.exe and restart it.

0

Hmm. Try going Start > Run, and entering the cmd window. Then in that, enter:
regsvr32 /i shell32.dll

0

unreconginsed flag error. how can i get folders to "open" in the same window, like without the explorer bar, as this takes ages to load through the folders, and lags up the screen.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.