0

Hi all,
my configuration is :
2 HDD SATA Seagate 200G each, RAID, Windows Xp , Mobo Asus a7n8x.
The problem :
Windows could not start because the following file is missing or corrupt : \WINDOWS\SYSTEM32\CONFIG\SYSTEM
So, I tried to get to the recovery console to fix this problem by replacing the missing or corrupted file, but I can't access the console using the Windows CD... a new message pops up saying that Setup did not find any hard disk drives installed in your comput.
So, my question is :
How to get the recovery console to work at this point ?
I didn't mount this PC and I'm a newbie in this area, but how can I tell what kind of RAID this is ? RAID 0, 1 .. etc.
I have the sata driver sil3112 installed, both HDD are well plugged in and working...could it be a corrupted RAID array ? can I reinstall it ? or disabling it while attending the repair of the corrupted file ?
Thank you all for your help. Karlos

3
Contributors
3
Replies
4
Views
11 Years
Discussion Span
Last Post by kkarlos
0

I think that you can't get into the recovery console uless you install the drivers for your SCSI controller. You have to hit F6 at the beggining of the windows setup, then insert a floppy that contains the drivers.

0

You have a MAJOR problem there. 3 problems that are solvable, but just barely. I've been there and it isn't pretty.

1st problem is SATA + XP (not sp1 nor sp2) you MUST have (so-called) F6 driver floppy (yes, floppy) to reinstall the windows. XP has difficulty with SATA controllers and doesn't have necessary drivers to access the drives. Your motherboard came with bootable Driver CD and utility that creates F6 driver floppy. (providing you have a floppy drive installed - if not, you'll have to install one - it's cheap)

To find out which RAID mode you're using you need to press f10 key during boot-up that will open a RAID Settings window (2 identcal HD's means it is probbably stripping mode, but mirroring and spanning are possible)

2nd problem is you will not be able to recover even with the f6 drivers, because (I had same thing "config\system corrupted or missing") it will not be able to log-in. Istead you will get blue screen of death saying "IRQL_NOT_LESS_OR_EQUAL".

3rd and the biggest one is YOU WILL NOT BE ABLE TO REINSTALL THE WINDOWS. Just after EULA screen you'll get the same BSOD.

Way I solved it was (I just happened to borrow USB HD) installing windows on USB HD (USB, IDE SATA, don't matter), and deleting the files in question (C:\WINDOWS\SYSTEM32\CONFIG\*.* where C: stands for your current HD('s)) because they are accessed prior to windows installation and repair console. If they are corrupted, it will BSOD on you. No matter what.
After you have deleted those bloody files you will be able to reinstall the windows "normally".

0

Thanks all...Ok, I fixed my problem. I did exactly that. I have provided a new si3112 driver from Silicon Image (downloaded from their website) while the CD was booting Setup, and it worked. I finally reached the recovery console. Actually, I tried that before posting here, but obviously, either my driver was corrupted or simply not updated. Weird though...So, it's fixed. Thanks you all for your input. KKarlos.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.