0

Could use some help or troubleshooting ideas for a problem with using my computer's USB 2.0 ports. I'm using a few month's old Pentium 4 3.2 GHz machine with WinXP Professional.

I had had my previous monitor plugged into the USB port on the computer, as it acted as my USB hub. The ports on the monitor were USB 1.0. Everything had worked fine; no problems whatsoever. Since I recently got a new monitor and could no longer use the monitor hub, I purchased a USB 2.0 hub. When I plug it into the computer, it works perfectly. Every device connected to the hub works perfectly. But when the computer is rebooted, it absolutely, positively will not load up winXP. The screen stays black. I have my speakers on loud and there is no windows greeting music. It hangs up before loading winXP. If I unplug the USB and then reboot, it boots into WinXP just fine.

Other things I've tried:
1. I disconnected the hub and just plugged in my camera card reader (2.0). Just as with the hub, it works perfectly when I just plug it in. But when I reboot, the screen stays black and the computer will not load windows.
2. I have an older camera card reader that uses USB 1.0. I plugged that into the computer. When I reboot, it was able to load WinXP just fine.

Conclusion:
USB 2.0 doesn't seem to work correctly (i.e. can't boot WinXP). USB 1.0 works. The computer is fairly new and does come with USB 2.0.

So, the Question:
The hub I bought (Belkin High-speed 7 port 2.0) says it supports 2.0 as well as 1.0. When it's plugged in, USB 2.0 devices do work. But the computer simply won't boot up into windows with that device (or any 2.0 USB device)
plugged in.

Does anyone have any ideas? I'd like to keep my USB hub plugged in without unplugging it before rebooting.

3
Contributors
2
Replies
3
Views
13 Years
Discussion Span
Last Post by zenlikestate
0

What type of system do you have?

Certain system BIOSes are set such that they try and boot from USB devices. Your digital camera card reader is considered a Mass Storage Device, and the system could be trying to boot from it. Disable USB emulation in the BIOS, and see if that doesn't help.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.