0

It has been almost 6 months now with this Spool.exe problem. In the event viewer I can see the "Faulting application spoolsv.exe..." message. I gathered from some research that this is related to corrupt printer driver. I tried twice to uninstall/reinstall printer drivers, but never succeeded. Every time after uninstall I made sure that I reinstalled the latest driver from Manufacturer web site.

Every time the spool service stops, there are some files (.SHD, .SPL) sitting in the C:\WINDOWS\system32\spool\PRINTERS folder, I have to manually remove all of them and restart the spool service. This used to happen at a rate of about once per week, now it happens more frequently. Maybe it is coincident, but I do notice as people print more labels to the Zebra printers, the problem occur more frequently. I could only suspect that it may have something to do with the Zebra driver.

Please advises are welcome, thank you in advance.

P.S. I have tried delete the printers from Registry, but I plan to use cleanspl.exe next time to tried to see if somehow I can revert back to the previous point before any printers were installed.

2
Contributors
1
Reply
2
Views
10 Years
Discussion Span
Last Post by waykas
0

Did you find a solution to your problem? We are having the same issue and the only way to fix it is to delete the SPL files and restart the spooler application. It appears to happen every time we have a large number of jobs printing on the Zebra printers.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.