I am trying to fix problems on Windows XP Home edition SP2 accessing CD or DVD discs. The system doesn't seem to recognize discs inserted into the drive. I installed a new drive, a LITEON DVD/CD re-writer, to replace an older drive that seemed to stop working. Yet, the new drive fails in a similar way to the old drive that I just replaced. The drive appears in the BIOS, in the Device Manager, and in Windows Explorer. But it doesn't recognize a new disc inserted into the drive. If I reboot the system with a disc present in the drive, then I can access the disc's contents in the usual manner, but once I eject the disc and insert another disc, then it fails to recognize the newly inserted disc. I've installed all the latest service packs and updates, and have tried to update the driver, uninstalled & reinstalled the drive via Device Manager, re-installed the NERO burning suite, removed InCD and other software that I thought might cause a device conflict/lock, all to no avail. Furthermore, burning a disc seems to work, and I can read the newly created disc on another computer.

To elaborate further on the mode of failure, when I insert a disc, I see the DVD/CD drive light go on solid for a few seconds while the hard drive light flashes a bit, suggesting something is getting loaded and executed by the OS. I also observe a subtle change of behavior in Windows Explorer, as it seems to be able to sense the presence or absence of a disc, and the type of disc (it displays either CD-Drive D: or DVD-Drive D:) but it never displays the content of the disc, as if something is preventing it from reaching the point where it recognizes the file system on the disc. Furthermore, Windows is configured to prompt for the action to take when a disc is inserted, yet I never observe the pop-up window prompting for a program selection.

In all cases, if I reboot the system with a disc present in the drive, I can access the disc via Windows Explorer or other applications without problems. But I can't get the system to recognize any disc when it has been inserted after the system has been booted and is running.

update firmware to latest version
google for it and make sure its the latest firmware version so make sure you get the firmware from the manufacturer website

When I installed a fresh copy of Windows XP, everything worked and the problem vanished. It must have been a problem with the instance of XP on that machine, the registry settings, conflicts with other programs, etc., yet nothing I could find in the posts, like upper filters & lower filters, fixed the problem.

i had the same problem once and yes after you install a clean version of windows xp it works,

...i missed this thread in the early stages... and there is a key.. naturally.. but i guess u do not need it now...

oh, all right then....
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom] "AutoRun"=dword:1

...if that dword is zero, then no autorun. If you reinstall windows then you're gunna reset that one to one. But that is the hard way around.

I have a very similar problem ... Where do I find the ... [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom] "AutoRun"=dword:1 on the computer ... I must have had it at some point, but you can bet that something like regcure cleaned it out

ignore that last note ... i went into regedit and found the path you suggested and the fix didn't work, it was already set at 1

Dear All,

I have actually had a similar problem, and have had almost no success in trying to isolate the problem. I don't know if it is the same thing or not, but I'm hoping that maybe some extra data might be handy...

I have a relatively new machine that has just had XP reinstalled, due to a corrupted installation. It has two DVD read-writers, one fairly old, one new. The old drive was having problems with recognising discs, much as elunow describes, but it also had problems playing DVDs as well - it looked like buffering problems. These problems got worse fairly rapidly - to the point where it became basically useless within 5 plays.

So I started using the second (new) drive, and initially it was OK, but then it started doing the same. Again, within about 5-10 disc insertions, in was basically useless. In both cases, some discs were better and worse than others (The Myth played the best, and Firefly disc 1 wouldn't play as all) - although most discs just stuttered, as if there was a buffering problem.

I asked someone to have a look at the drives, and bought an external USB drive. This drive worked perfectly for the first 10-15 DVDs insterted, then started not to respond to inserted discs (like in elunow's case), and the drive then rapidly deteriorated until it, too, was useless (although the shop very kindly took it back).

The only common link is that the DVD it started having the problems with was Medieval Total War Kingdoms (which initially took forever to to install) - but I don't know any mechanism by which a DVD can screw a drive (is there one?).

During this process, I have replaced the cable joining the drives to the mother board. By process of elimination:

It is not the cable
It is not a physical problem with the drives (not initially, at least)
Windows doesn't recognise a problem with any of the drives
None of the drives had proprietory firmware

The only thing left appears to be either the Microsoft driver, or some sort of virus which corrupts DVD drives.

Any thoughts on the matter would be greatly appreciated.


PS To make things worse, though, I am now using my old computer - and its DVD drive is now misbehaving. It is not deteriorating, though, so I hope it is not the same thing....

My problem mirrors the first example exactly.

The autorun thing didnt work as it was already set to 1.

Is reinstalling XP the only option?

did you try setting up auto run by right clicking on the cdrom icon in mycomputer go properties and autorun and set it to desired programs .
''also did you try going to start/run/regedit and do the following .

Possible Solution......

There are 2 reg keys that can screw the device......remove them both and reboot......

The keys are:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325 -11CE-BFC1-08002BE10318} - "Upperfilters" and "Lowerfilters".

Pardon my ignorance, but you mean i should delete them both permanently?

Pardon my ignorance, but you mean i should delete them both permanently?

yes just the upper and lower filters if they are there .,also before you do go to file and export regedit ,back up registry then make changes ,

FYI, That didnt work.

I reformatted and loaded XP back on and the problem was fixed (along with a few others).

I have a full copy of nero 6 and what i thought was a full copy of nero 7. I loaded nero 7 on and when i realised it was a trial version i removed it using nero cleaning tool.

The problem came back on reboot.

It might have something to do with nero 7?

Im getting pretty good at reformatting now though, so i'll probably just do it again to fix it and stay clear of Nero hoping for the best.

For anyone that has this problem, in my case it was a prgram called DVD43 that was the cause. Nothing wrong with Windows or the hardware. It's a region free/CSS free program.


I have been experiencing the same problem as elunow describes, including some drive activity and Windows Explorer knowing that a disc is present (by displaying the proper icon) but not acknowledging it's presence. If I click on the drive I get a message "Insert a disc in drive X". If I left click to display properties it takes an eternitiy to display the menu, but when it finally does, if I click on Autoplay then I can display the disc contents and access it as normal.

I checked the suggested registry entries and found that my Autorun setting was already = 1. Also, there was no lowerfilter entry to delete but there was an upperfilter entry, so I deleted it and rebooted. My problem was not fixed.

I have 2 internal drives and one external (all different manufacturers). They all behave the same. So I think that eliminates any driver or firmware problem being the cause. It has to be registry or OS related, but I have not been able to isolate it.

I am not keen on reinstalling XP to fix the problem as it is a huge undertaking with no guarantee that the problem will not recur.

Has anyone had any luck figuring this out?

An additonal comment regarding PPLSPOET post: I also have Nero 6 installed but have not installed Nero 7. I am not sure exactly when my problem began and whether or not it coincided with installing Nero 6.

I have the EXACT PROBLEM....I installed Nero 7 and lost my CD ROM drive. I ficed that, I deleted my filters and my autorun is at 1. I am still not up and running. My CD ROM drive says "please insert disk into D drive" Can youplease tell me how you fixed this, or anyone can help?

I encountered this problem as well and replaced the drive, thinking the drive was shot. At that time I didn't have any specialized software for my disc drive, and the old disc drive was a read only. I installed a new drive and with the drive I installed the software that came with it, one application being Nero7. The drive worked beautifully the first couple times I used it, and now it is doing the same exact thing as the old drive! What everyone has described here is the exact problem I am having. I've eliminated it being related to hardware, eliminated the software issue (it did the same thing before Nero7 was installed), and from your posts assume it is not a registry error that anyone has discovered to be common with this problem. Has anyone ever gotten an answer on this short of reinstalling XP?

I never did fix it. We just got a new computer, but would like to fix it. I tried everything, new drives, filter adjustment, everything. I can't figure out how to reload XP with the disks because I can't put any disks in the computer to because it doesn't recognize it. How do you reload software if your disk doesn't work. I would have download it from a link.

Good point!!!

I never did fix it. We just got a new computer, but would like to fix it. I tried everything, new drives, filter adjustment, everything. I can't figure out how to reload XP with the disks because I can't put any disks in the computer to because it doesn't recognize it. How do you reload software if your disk doesn't work. I would have download it from a link.

I have not been able to "fix" the problem insofar as eliminating it, but have been able to get around it. The drive does show up in Windows Explorer but doesn't seem to know there is a disc inserted. I simply right click on the drive, select "properties" and then click on "AutoPlay". Everything shows up and is accesable then. It's not a fix but it works.

I am having exacly the same issues running Win 2k. I dont have Nero so i know its not software issue. Would like to use the above fix but there is no option for "autorun" under properties when you right click the icon in Win 2k.
After browing the web for a few days with this issue, there are loads of us with the same problem. We are all probably running different versions of windows and associated DVD/CD software so I suspect its something REALLY SIMPLE.
Anyone got any more clues.

Use other CDROM controller on the mobo(move the CDROM cable to the other connector on the mainboard).
Install the latest mobo chipset driver, reboot to take effect.

If necessary, update the mobo BIOS.

Hope this helps!

This is not an XP problem or Hardware Problem. It is definately Software Related. I havent nailed down the actual program on my Vista system yet but I think it is a clash with Itunes and Pinnacle Studio. Only solution I have found is a complete re-install. I am tired of doing this, anyone else figure it out yet?

The Left-Click Properties doesnt work for me either, it just flat doesn't see a disk.

do you get a code 39 error? if so go to utube and enter code 39 fix and follow instructions , worked for me!!

you know what I just did? I went to device manager, disabled the driver for DVD drive then enabled it again. This fixed the problem for me.

Well folks under the heading of "It's a Mystery" my problem has magically disappeared. I got a new PC last year running Vista. I took my XP machine downstairs and have only used it sparingly, mostly just keeping the antivirus up to date and applying Windows Updates. I decided to try jakericablanka's driver fix to see if it would work on my old machine, but first I tried inserting several different discs to see if perhaps it was related to the type of disc (blank, one I burned, prewritten with software or data files, etc.) It read them all just fine and in addition autorun now works, which it hasn't done for years. Go figure? I am totally at a loss unless one of the Windows Updates that I applied fixed the problem.

My Drive let me access it for CD but not DVD -
For me the solution was using Administrator in Safe mode to Change Drive to SHARED.

OMG I have been working on this for 3 months, and THAT fixed it for me!!!

I notice this is a fairly old thread and suspect it is probably not active, but I am experiencing the same problem but on Vista Basic. Any suggestions

Remove the side off of the computer to access the dvd drive. Unplug the power cable (not the grey ribbon cable)Then plug it back in. Now go to Start, Control Panel, System, Hardware, Device Manager, right click anywhere in the window and click Scan for hardware changes. Once the scan is complete your drive will work but it will have been given a different Drive letter.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.