I am unable to change the home page of IE even after making changes in the General tab of Internet options menu. IE always opens with microsoft.com as the home page. Any solutions?

Did you click on OK at the bottom of the General window after you made the setting?
If not, it threw the setting away.

Are the settings for IE stored in a file owned by the system administrator? If so, you will need administrator privilege to change it.

Is the shortcut you are opening IE with asking for that web page?

I think the problem is with his security software (e.g norton and its friends). My mcaffe suite has homepage protection to stop viruses and spyware changing the homepage but sometimes it blocks me from legitimately changing it.